ubuntu-kylin-default-settings includes broken apt repo

Bug #1670202 reported by Jeremy Bicha on 2017-03-05
16
This bug affects 2 people
Affects Status Importance Assigned to Milestone
ubuntukylin-default-settings
Undecided
handsome_feng
ubuntukylin-default-settings (Ubuntu)
High
Unassigned
Xenial
High
handsome_feng

Bug Description

[Impact]

* Users on ubuntu flavos except Ubuntu Kylin will getting these apt warnings:

===
Err:8 http://archive.ubuntukylin.com:10006/ubuntukylin trusty InRelease
  The following signatures couldn't be verified because the public key is not available: NO_PUBKEY D259B7555E1D3C58
Reading package lists... Done
W: GPG error: http://archive.ubuntukylin.com:10006/ubuntukylin trusty InRelease: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY D259B7555E1D3C58
===

* Add the ubuntukylin-keyring to the depends of ubuntukylin-default-settings will fix this problem.

[Test Case]

* Install ubuntukylin-default-settings.
* Then run "sudo apt-get update" in terminal.
* You will encounter the apt warnings as show above.

Expected
* Install ubuntukylin-default-settings.
* Run "sudo apt-get udpate" in terminal.
* All going well

Changed in ubuntukylin-default-settings (Ubuntu):
status: New → Confirmed
Aron Xu (happyaron) wrote :

This was expected to work previously when Ubuntu Kylin's repo is synced from Canonical's infrastructure, but later the repo is signed by another key so that all users have the problem.

handsome_feng (feng-kylin) wrote :

We have fix this at 1.3.18, and we are working to ship the series form trusty to zesty.
Thanks a lot!

Changed in ubuntukylin-default-settings (Ubuntu):
status: Confirmed → Fix Released
Changed in ubuntukylin-default-settings:
status: New → Fix Committed
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in ubuntukylin-keyring (Ubuntu):
status: New → Confirmed
Miles Robinson (oddfox) wrote :

I may be doing something wrong but I even went so far as to manually download and install ubuntukylin-default-settings_1.3.19_all.deb on my 17.04 installation and I still get the following message when running apt-get update:

Get:10 http://archive.ubuntukylin.com:10006/ubuntukylin trusty InRelease [16.0 kB]
Err:10 http://archive.ubuntukylin.com:10006/ubuntukylin trusty InRelease
  The following signatures couldn't be verified because the public key is not available: NO_PUBKEY D259B7555E1D3C58
Reading package lists... Done
W: GPG error: http://archive.ubuntukylin.com:10006/ubuntukylin trusty InRelease: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY D259B7555E1D3C58
E: The repository 'http://archive.ubuntukylin.com:10006/ubuntukylin trusty InRelease' is not signed.
N: Updating from such a repository can't be done securely, and is therefore disabled by default.
N: See apt-secure(8) manpage for repository creation and user configuration details.

Jeremy Bicha (jbicha) wrote :

Yes, this bug has not been fixed so I'm reopening.

Changed in ubuntukylin-default-settings (Ubuntu):
status: Fix Released → Triaged
Changed in ubuntukylin-default-settings:
status: Fix Released → Confirmed
Changed in ubuntukylin-default-settings:
assignee: nobody → ShuiLu Pi (pishuilu1128)
Miles Robinson (oddfox) wrote :

By the way, installing ubuntukylin-keyring resolved the issue for me.

Jeremy Bicha (jbicha) wrote :

I believe the keyring dependency was fixed, but it needs to be SRU'd to 16.04 LTS "xenial".

Changed in ubuntukylin-default-settings (Ubuntu):
status: Triaged → Fix Released
Changed in ubuntukylin-default-settings (Ubuntu Xenial):
status: New → Triaged
no longer affects: ubuntukylin-keyring (Ubuntu)
no longer affects: ubuntukylin-keyring (Ubuntu Xenial)
Changed in ubuntukylin-default-settings:
assignee: ShuiLu Pi (pishuilu1128) → handsome_feng (feng-kylin)
Changed in ubuntukylin-default-settings (Ubuntu Xenial):
assignee: nobody → handsome_feng (feng-kylin)
handsome_feng (feng-kylin) wrote :
tags: added: verification-needed
tags: added: verification-needed-xenial
description: updated
Simon Quigley (tsimonq2) wrote :

Uploaded.

Changed in ubuntukylin-default-settings (Ubuntu Xenial):
importance: Undecided → High
Changed in ubuntukylin-default-settings (Ubuntu):
importance: Undecided → High

Hello Jeremy, or anyone else affected,

Accepted ubuntukylin-default-settings into xenial-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/ubuntukylin-default-settings/1.3.14ubuntu0.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-xenial to verification-done-xenial. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-xenial. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in ubuntukylin-default-settings (Ubuntu Xenial):
status: Triaged → Fix Committed
handsome_feng (feng-kylin) wrote :

Hi,
   I have test it on ubuntu xenial, and the ubuntukylin-default-settings-1.3.14ubuntu0.1 fix the bug.

Thanks!

tags: added: verification-done-xenial
removed: verification-needed-xenial

The verification of the Stable Release Update for ubuntukylin-default-settings has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntukylin-default-settings - 1.3.14ubuntu0.1

---------------
ubuntukylin-default-settings (1.3.14ubuntu0.1) xenial; urgency=high

  * Add ubuntukylin-keyring to the Depends. (LP: #1670202)

 -- handsome_feng <email address hidden> Thu, 01 Mar 2018 11:02:29 +0800

Changed in ubuntukylin-default-settings (Ubuntu Xenial):
status: Fix Committed → Fix Released
Changed in ubuntukylin-default-settings:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers