ubuntu-wallpapers-karmic conflicts with ubuntu-wallpapers-extra

Bug #975778 reported by José Lou Chang on 2012-04-07
74
This bug affects 10 people
Affects Status Importance Assigned to Milestone
ubuntu-wallpapers (Ubuntu)
High
Unassigned

Bug Description

When I applied to install all the wallpapers installed by previous version of Ubuntu, Synaptic game the following error:

E: /var/cache/apt/archives/ubuntu-wallpapers-karmic_0.34.0_all.deb: trying to overwrite '/usr/share/backgrounds/Bay.jpg', which is also in package ubuntu-wallpapers-extra 0.1

In the end the installation of ubuntu-wallpapers-karmic is canceled or aborted.

I don't believe it to be a major problem since this can just be ignored, but I decided to report nonetheless.

Here is the terminal output when installing the wallpapers:

perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
 LANGUAGE = "ja:es_PE:es_ES:en_US:en",
 LC_ALL = (unset),
 LC_TIME = "en_US.UTF-8",
 LC_MONETARY = "en_US.UTF-8",
 LC_NUMERIC = "en_US.UTF-8",
 LANG = "ja_JP.UTF-8"
    are supported and installed on your system.
perl: warning: Falling back to the standard locale ("C").
locale: Cannot set LC_CTYPE to default locale: No such file or directory
locale: Cannot set LC_MESSAGES to default locale: No such file or directory
locale: Cannot set LC_ALL to default locale: No such file or directory
Gtk-WARNING **: Locale not supported by C library.
 Using the fallback 'C' locale. at /usr/share/perl5/Debconf/FrontEnd/Gnome.pm line 97, <> line 5.
Gtk-WARNING **: Locale not supported by C library.
 Using the fallback 'C' locale. at /usr/share/perl5/Debconf/FrontEnd/Gnome.pm line 103, <> line 5.
Selecting previously unselected package ubuntu-wallpapers-extra.
(Reading database ... 231833 files and directories currently installed.)
Unpacking ubuntu-wallpapers-extra (from .../ubuntu-wallpapers-extra_0.1_all.deb) ...
Selecting previously unselected package ubuntu-wallpapers-karmic.
Unpacking ubuntu-wallpapers-karmic (from .../ubuntu-wallpapers-karmic_0.34.0_all.deb) ...
dpkg: error processing /var/cache/apt/archives/ubuntu-wallpapers-karmic_0.34.0_all.deb (--unpack):
 trying to overwrite '/usr/share/backgrounds/Bay.jpg', which is also in package ubuntu-wallpapers-extra 0.1
No apport report written because MaxReports is reached already
                                                              dpkg-deb: error: subprocess paste was killed by signal (Broken pipe)
Selecting previously unselected package ubuntu-wallpapers-lucid.
Unpacking ubuntu-wallpapers-lucid (from .../ubuntu-wallpapers-lucid_0.34.0_all.deb) ...
Selecting previously unselected package ubuntu-wallpapers-maverick.
Unpacking ubuntu-wallpapers-maverick (from .../ubuntu-wallpapers-maverick_0.34.0_all.deb) ...
Selecting previously unselected package ubuntu-wallpapers-natty.
Unpacking ubuntu-wallpapers-natty (from .../ubuntu-wallpapers-natty_0.34.0_all.deb) ...
Processing triggers for gconf2 ...
Errors were encountered while processing:
 /var/cache/apt/archives/ubuntu-wallpapers-karmic_0.34.0_all.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
A package failed to install. Trying to recover:
Setting up ubuntu-wallpapers-maverick (0.34.0) ...
Setting up ubuntu-wallpapers-extra (0.1) ...
Setting up ubuntu-wallpapers-natty (0.34.0) ...
Setting up ubuntu-wallpapers-lucid (0.34.0) ...

-------------------------------------------------------

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: ubuntu-wallpapers-karmic (not installed)
ProcVersionSignature: Ubuntu 3.2.0-21.34-generic 3.2.13
Uname: Linux 3.2.0-21-generic x86_64
NonfreeKernelModules: wl
ApportVersion: 2.0-0ubuntu4
Architecture: amd64
Date: Sat Apr 7 00:41:25 2012
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Alpha amd64 (20120325)
SourcePackage: ubuntu-wallpapers
UpgradeStatus: No upgrade log present (probably fresh install)

Related branches

José Lou Chang (obake) wrote :
José Lou Chang (obake) on 2012-04-07
description: updated
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in ubuntu-wallpapers (Ubuntu):
status: New → Confirmed
Max Bowsher (maxb) on 2012-04-07
summary: - ubuntu-wallpapers-karmic may conflict with ubuntu-wallpapers-extra
+ ubuntu-wallpapers-karmic conflicts with ubuntu-wallpapers-extra
Max Bowsher (maxb) wrote :

I too just encountered this.

I unpacked both .deb files, and observed the following:

* The set of image files in both packages is identical

* Only ubuntu-backgrounds-karmic contains a background sequence XML file: /usr/share/backgrounds/contest/karmic.xml

* The /usr/share/gnome-background-properties/*.xml file contained in the two packages is identical, with the exception of the entry within the XML referencing the background sequence XML file mentioned above.

* ubuntu-wallpapers-extra additionally ships a file /usr/share/gconf/defaults/16_ubuntu-wallpapers-extra aiming to set one of its own images as a default GNOME background if installed.

Following the reasoning that gconf is deprecated by dconf, and that an additional wallpaper package probably shouldn't be trying to influence the default background anyway, I propose that ubuntu-wallpapers-karmic is strictly better than ubuntu-wallpapers-extra.

I am therefore subscribing ~ubuntu-sponsors, requesting sponsorship for a removal request for ubuntu-wallpapers-extra.

Iain Lane (laney) wrote :

We should build a transitional package from ubuntu-wallpapers for this too.

Changed in ubuntu-wallpapers (Ubuntu):
status: Confirmed → Triaged
importance: Undecided → High
Iain Lane (laney) wrote :

The attached branch does this. Please remove ubuntu-wallpapers-extra and sponsor the branch.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntu-wallpapers - 0.34.1

---------------
ubuntu-wallpapers (0.34.1) precise; urgency=low

  [ Ken VanDine ]
  * debian/control
    - dropped build depends for xsltproc
    - set priority for transitional package ubuntu-wallpapers-extra to extra

  [ Iain Lane ]
  * debian/control
    - Provide transitional package for ubuntu-wallpapers-extra, an old package
      which was providing the Karmic wallpapers and thus shared files with
      ubuntu-wallpapers-karmic. (LP: #975778)
     - Put ubuntu-wallpapers (the package) in Section: metapackages as
       dependencies of packages in this section are considered "manual" by apt
       and therefore will not be removed on upgrades. This means that users
       will keep wallpapers from old releases when upgrading. Thanks to James
       Westby for pointing this out to me. (LP: #863509)
 -- Iain Lane <email address hidden> Sat, 07 Apr 2012 21:36:50 +0100

Changed in ubuntu-wallpapers (Ubuntu):
status: Triaged → Fix Released
Martin Pitt (pitti) wrote :

I removed ubuntu-wallpapers-extra source from precise. I also fixed the override for ubuntu-wallpapers according to what the latest source says ("metapackages").

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments