Ubuntu

FFe: Upload Precise Ubuntu 12.04 LTS wallpapers

Reported by Paul Sladen on 2012-02-16
64
This bug affects 6 people
Affects Status Importance Assigned to Milestone
ubuntu-wallpapers (Ubuntu)
Wishlist
Andrea Cimitan

Bug Description

Following on from bug #829213 the wallpapers in Ubuntu come from the Ubuntu Wallpaper contest which closes at 15 March 2012 18:00 UTC:

  "Precisely how we’re going to make the wallpapers in 12.04 the best ever!"
  http://design.canonical.com/2012/01/precisely-how-were-going-to-make-the-wallpapers-in-12-04-the-best-ever/

  "Precise Pangolin wallpaper submissions group"
  http://www.flickr.com/groups/1860176@N24/

There are over 1700 entries so far! The previous winners will get that down to a shortlist of ~30 entries. There are generally two types of image, most are photographic (JPGs) with a small number of non photographic, drawn images (PNGs). Then this needs to happen:

  1. Publish the list of winning entries on design.canonical.com
  2. All images are must be CC-BY-SA which is a criteria for inclusion and this is a stated requirement of submission. Contributors have been asked to update the relevant metadata on Flickr
  3. Scale all the images to the same 2000px width and corresponding height to maintain aspect ratio. If in doubt this should be done from the centre.
  4. I understand that compression is managed when it's packaged so if it's oversize we can recompress/ reduce the number of images. For reference our current wallpapers are around 2.5MB and we anticipate this will be about the same size.
  5. Upload to the archive (main) for Ubuntu 12.04 LTS

In addition, the default wall paper will need tweaking, which Otto Greenslade has attached to bug #968399 ("Incremental tweaks to default wallpaper for Ubuntu 12.04 LTS").

Paul Sladen (sladen) on 2012-02-16
Changed in ubuntu-wallpapers (Ubuntu):
status: New → Confirmed
importance: Undecided → Wishlist
assignee: nobody → Paul Sladen (sladen)
milestone: none → ubuntu-12.04
Paul Sladen (sladen) on 2012-02-29
description: updated
Paul Sladen (sladen) wrote :

The compeition has closed now, and Iain Farrell is currently working with the previous winners on the short-listing process.

Iain Farrell (iain-farrell) wrote :

Just a short update, we met tonight for a couple of hours and have shortlisted about 13 with more invites awaiting replies. We'll have a set of zips in time for the freeze.

Iain Farrell (iain-farrell) wrote :

http://www.flickr.com/groups/1899757@N25/pool/

We have a final selection - we're waiting on high res copies of some of them but whatever we have at the end of today - about 6 ish - I'll be uploading to the bug. Then we can try and update if we get any more in later - assuming we have space :)

Jeremy Bicha (jbicha) wrote :

Thanks Iain & Paul!

+1 from the Docs Team for getting this into Beta 2

Iain Farrell (iain-farrell) wrote :

Zip containing wallpaper files v1

Iain Farrell (iain-farrell) wrote :

As if by magic more images appeared - news of the release spurred on a few more people to send in their high resolution images :) Please take v1.1 of the zip file.

Paul Sladen (sladen) wrote :

Licensing and technical audit;
Remember that the aim of the contest is to promote the creation of Free and Libre content, and ship as many as will fit to as many people as possible!

Three of the images in the shortlist (and two in the .zip) are not CC-BY-SA and so can't be shiped, as only free/libre images are eligable for inclusion (all images offered _must_ to be licensed as CC-BY, CC-BY-SA or CC0 to be considered). Currently this rules *out* shipping of the following three as we can't do so legally:

  Forbidden City by pixelflake (wrong licence)
  White Pigeons by noombox (wrong licence)
  Yellow Flower by Angela Henderson (wrong licence)

Andrea Cimitan did an initial preview test of the remaining images checking for theming/desktop interactions. A couple of the images highlight issues with the present average-highlight colour algorithm in Unity/Unity-2D. Either the images or code may tweaking.

Cut-offs. The following exhibits an issue with the person's head being cut off by the top menu bar on all 16:9 widescreen displays (now the common-case). This may be solvable by cropping a slice off the bottom to give a wider aspect, and effectively moving crop from the default centre:

  Jumping Man by Marcus Møller (re-cropping)

Dark/unsaturated: The following has very low histogram spread with everything pretty in the bottom 20th-percentile:

  White Flower by Zuphi (low saturation/histogram)

There images with high-frequency noise tend to have compression issues—we only have a limited space budget on the CD and can't blow it on just a single image, because we have to maximise the number shipped. This particularly affects:

  The Brew by Fernando Garcia

(but we'll see what fits as trying various combinations of recompression).

Question:

Iain and the shortlist team; have you picked any illustrations for shortlisting aswell? There's traditionally been an illustrated animal-of-the-release in the pool too a la the Pangolin at the top of:

  http://www.omgubuntu.co.uk/2012/03/10-wallpapers-from-the-precise-contest-pool/

I'm asking as in the packaging code we have a separate codepath to manage illustrations, to that for photographs (as they compress differently).

Iain Farrell (iain-farrell) wrote :

Original images

Paul Sladen (sladen) wrote :

Iain: groovy. There's so much more detail and clarify in those ones.

ray (rayworld) wrote :

Hi all, and sorry for the intromission.

My name is Ray García. I did a wallpaper that was selected in the final wallpapers shortlist (http://www.flickr.com/groups/1899757@N25/pool/ "Tie my boat")

Unfortunately, i accepted the access to the shortlist a little bit late. I'm on the shortlist, but I don't know if my wallpaper was finally selected.

I would be delighted to contribute to the community with this wallpaper, if I am still on time, of course...

I attached the full-resolution wallpaper right here.

Hoping some good news,
cheers, Ray.

Paul Sladen (sladen) wrote :

Ray: thanks for the upload of the original!

For this cycle there's now an average colour algorithm that is used to select the background-colour of the Dash, and indicator pop-ups. Some of the images in the pool are trigging strange results, so Rosie/Cimi/Otto are still playing with them.

Paul Sladen (sladen) wrote :

Two more late-arrivals in high-res:

Paul Sladen (sladen) wrote :
ray (rayworld) wrote :

You're welcome, Paul :)

Paul Sladen (sladen) wrote :

Two more originals found via Flickr Pro accounts:

  http://farm8.staticflickr.com/7016/6577838653_a529ea9014_o_d.jpg (Shannon Lucas)
  http://farm8.staticflickr.com/7172/6525199899_0d6bbe0c52_o_d.jpg (Lars Clausen)

Still waiting for:

  1. Vlad Gerasimov's Pangolin illustration; emailed via http://www.vladstudio.com/contact/ but he's in the far east of Russia, so the timezone might be a while for a reply
  2. The speaker. Wrong licence and no high-res. I've asked Phil Jackson for both (via Flickr)
  3. Frosty roof. Wrong licence and no high-res. I've asked Phil Jackon for both (via Flickr)

My submission (8000x5000 100% quality jpg) is attached (also sent via email).

Paul Sladen (sladen) wrote :

Vlad was right I think an 8000x5000 submission is the biggest we've had.

Nick Tait (jnick-tait) wrote :

Precise Pangolin Wallpapers

Paul Sladen (sladen) wrote :

Moon Over Malaga, blackened completely outside of the moon, and grayscaled; other of which should increase the compression potential.

Hey, I'm honored. I'm away from the computer on which the higher res. images reside. I'll try to get them in the next few days.

Paul Sladen (sladen) wrote :

phil-jackson: Could you update the licence on both of:

  http://www.flickr.com/photos/phil-jackson/3735844560/in/pool-1899757@N25
  http://www.flickr.com/photos/phil-jackson/3078893011/in/pool-1899757@N25

to be plain CC-BY or CC-BY-SA regardlessly.

Whilst we /can/ work with placeholder images in finishing the technical evaluations, but we /can't/ even consider material which is they're marked "non-commericial" or are restricted in ways that don't been the threshold of freedom that Ubuntu is giving its users.

Paul Sladen (sladen) wrote :

Whilst we /can/ work with placeholder images in finishing the technical evaluations; we /can't/ even consider material which is marked "non-commericial", or which is restricted in ways that do not meet the threshold of freedom that Ubuntu is offering to its users.

Licence changed, though, I might have to regenerate the images so they would be outright new works.

Paul Sladen (sladen) wrote :

Phil: Thank you! You should not need to regenerate anything You're still the copyright holder, and able to licence the work non-exclusively multiple times, each with different terms and conditions.

Having the licence flag correctly set on Flickr is a sufficient confirmation of your intentions (since only you are in a position where can change that setting from inside Flickr for a particular image).

Person do let us know when you've found the high-res versions.

A no, I might have to regen them because the ones on flickr are the highest res non-raw versions I have. I'll make them as similar as possible but you might have to re-judge :)

Zip containing hi-res, high quality versions of my photos.

Paul Sladen (sladen) wrote :

Phil: Thanks for both, I'll point Rosie here in the (UTC) morning.

Andrea Cimitan (cimi) wrote :

Hires versions

Paul Sladen (sladen) on 2012-04-02
description: updated
Andrea Cimitan (cimi) on 2012-04-04
Changed in ubuntu-wallpapers (Ubuntu):
assignee: Paul Sladen (sladen) → Andrea Cimitan (cimi)
Jeremy Bicha (jbicha) wrote :

Are we going to merge in my branch for bug 863509 first or try that later?

https://code.launchpad.net/~jbicha/ubuntu-wallpapers/lp-863509-package-old-wallpapers

Paul Sladen (sladen) wrote :

Jeremy: I'd rather do that switch after the LTS is out: Would you be happy:

  (1) holding it for another month
  (2) integrating the 12.04 wallpaper collection
  (3) uploading as soon as Q opens?

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntu-wallpapers - 0.33.0

---------------
ubuntu-wallpapers (0.33.0) precise; urgency=low

  [Andrea Cimitan/Otto Greenslade/Xi Zhu]
  * Wallpapers from the Ubuntu 12.04 community contest (LP: #933562)
  * Incremental update to the default wallpaper (LP: #968399)
 -- Andrea Cimitan <email address hidden> Wed, 04 Apr 2012 12:50:37 +0100

Changed in ubuntu-wallpapers (Ubuntu):
status: Confirmed → Fix Released
Jeremy Bicha (jbicha) wrote :

Paul, no it needs to be done for Precise. Otherwise, when people upgrade from Precise to Quirky, they'll lose their Precise wallpapers and have to re-install them afterwards. I think the current behavior violates Debian policy, in that local configurations are not given a reasonable attempt at being preserved.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers