Ubuntu

Upgrading Ubuntu to new version deletes previous wallpapers

Reported by Jeremy Bicha on 2011-09-30
80
This bug affects 16 people
Affects Status Importance Assigned to Milestone
ubuntu-wallpapers (Ubuntu)
High
Canonical Desktop Team
Precise
High
Canonical Desktop Team

Bug Description

Still needs done in Update Manager
==================================
1. When upgrading from 11.10, update-manager should also install ubuntu-wallpapers-oneiric. When upgrading from 10.04, update-manager should also install ubuntu-wallpapers-lucid
2. All ubuntu-wallpapers* packages should be marked as manually installed so that they won't be automatically removed when upgrading to the next Ubuntu release.

Original bug report
===================
As mentioned on this forum thread, upgrading Ubuntu deletes the previous wallpapers. This is bad because apparently if someone had set their wallpaper to say a Natty community wallpaper, they would get a black background on updating to Oneiric with no easy way to get their old wallpaper back. http://ubuntuforums.org/showthread.php?t=1852257

This is also very bad because Ubuntu updates aren't supposed to mess with user preferences.

I suggest that the old wallpapers be kept in the ubuntu-wallpapers source package. A new ubuntu-wallpapers metapackage should be created that depends on ubuntu-wallpapers-oneiric. That dependency just gets updated for each release. Users who have ubuntu-wallpapers-natty installed won't lose them when they upgrade their install ubuntu-wallpapers. Those who do a clean install of Ubuntu Oneiric can still install the Natty wallpapers if they want them (which is good because some people do a clean install just because they think it's better).

ProblemType: BugDistroRelease: Ubuntu 11.10
Package: ubuntu-wallpapers 0.32.1
ProcVersionSignature: Ubuntu 3.0.0-12.19-generic 3.0.4
Uname: Linux 3.0.0-12-generic x86_64
ApportVersion: 1.23-0ubuntu2
Architecture: amd64
Date: Fri Sep 30 13:50:24 2011
PackageArchitecture: allSourcePackage: ubuntu-wallpapers
UpgradeStatus: No upgrade log present (probably fresh install)

Jeremy Bicha (jbicha) wrote :
description: updated
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in ubuntu-wallpapers (Ubuntu):
status: New → Confirmed
Changed in ubuntu-wallpapers (Ubuntu Precise):
importance: Undecided → High
assignee: nobody → Canonical Desktop Team (canonical-desktop-team)
Jeremy Bicha (jbicha) wrote :

I'm working on this.

Jeremy Bicha (jbicha) on 2012-02-28
summary: - Upgrading Ubuntu to new version deletes previous wallpapers
+ UIFe: Upgrading Ubuntu to new version deletes previous wallpapers
summary: - UIFe: Upgrading Ubuntu to new version deletes previous wallpapers
+ Upgrading Ubuntu to new version deletes previous wallpapers
tags: added: rls-mgr-p-tracking
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntu-wallpapers - 0.34.0

---------------
ubuntu-wallpapers (0.34.0) precise; urgency=low

  [ Jeremy Bicha ]
  * New packages containing community wallpapers from karmic to oneiric
    (LP: #863509)
  * Bump dh compat to 8 & Standards-Version to 3.9.3
  * debian/control.in:
    - Drop old gutsy conflicts
    - Conflict/replace against older ubuntu-wallpapers versions
  * Update AUTHORS, COPYING, & debian/copyright

  [ Ken VanDine ]
  * Added ubuntu-wallpapers-precise
  * debian/rules
    - Dropped the xsltproc stuff, we don't need to generate gconf defaults
      anymore
  * debian/copyright
    - added license paragraphs
 -- Ken VanDine <email address hidden> Thu, 05 Apr 2012 11:08:18 -0400

Changed in ubuntu-wallpapers (Ubuntu Precise):
status: Confirmed → Fix Released
Jeremy Bicha (jbicha) on 2012-04-07
description: updated
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in update-manager (Ubuntu):
status: New → Confirmed
Martin Pitt (pitti) on 2012-04-11
no longer affects: update-manager (Ubuntu)
no longer affects: update-manager (Ubuntu Precise)
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers