ubuntu-virt-mgmt installing kvm and libvirt-bin

Bug #367763 reported by Niklas Hagman on 2009-04-27
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
ubuntu-virt (Ubuntu)
Undecided
Unassigned

Bug Description

When doing installation of metapackage ubuntu-virt-mgmt, server parts is also installed. Like libvirt-bin and kvm. This is an dependencies error.

ubuntu-virt-mgmt should in my meaning only install stuff that is used to control a virtualization environment. Not create on as it does now. Creating a virtualization environment is for metapackage ubuntu-virt-server to take care of.

Niklas Hagman (blinkiz) wrote :

I don't think the problem is in the metapackage ubuntu-virt-mgmt directly. Package "virt-manager" also installs a complete virtualization environment. So feel free to move this bug report around until it's in the right project/package.

Dustin Kirkland  (kirkland) wrote :

Hello Niklas-

Thanks for the report. I think you're confused about two different packages.

 * ubuntu-virt-server is a meta package that installs the basic packages needed to *host* virtual machines

 * ubuntu-virt-mgmt is a second meta package (also part of the same source package) that contains the packages needed to manage a virtual machine.

From your description, I think you want to install both of these on your systems.

Thanks,
:-Dustin

Changed in ubuntu-virt (Ubuntu):
status: New → Invalid
Niklas Hagman (blinkiz) wrote :

ubuntu-virt-mgmt is installing packages needed to manage a virtual machines. BUT it is also installing packages to *host* virtual machines.

This bug report is created because of this. Dependencies error.
Is the same problem in intrepid as in jaunty.

Changed in ubuntu-virt (Ubuntu):
status: Invalid → New
Dustin Kirkland  (kirkland) wrote :

Ah, okay, sorry, I misread.

So ubuntu-virt-mgmt depends on:
 * virt-manager, python-vm-builder, virt-viewer

As you mentioned, we'd need to discuss whether those packages should depend on the server parts of virtualization.

:-Dustin

Niklas Hagman (blinkiz) wrote :

It's okay to install these tree packages as long kvm or libvirt-bin does not get installed. But it is. And that's the error am trying to identify with this bug report.

metapackage ubuntu-virt-mgmt has lost is value because the server parts of virtualization is also installed. I see "ubuntu-virt-mgmt" as a good metapackage for me to install on my laptop. On my server, "ubuntu-virt-server" is installed. And according to Dustin Kirkland above, this is how the metapackage ubuntu-virt-mgmt is meant for. Because of this, I see this more as a bug then a wishlist thing.

"sudo apt-get install virt-manger" is installing libvirt-bin and kvm. Why?
"sudo apt-get install python-vm-builder" is installing kvm. Why?
I don't understand these dependencies any good, so someone else needs to help me find why packages to *host* virtual machines is installed.

Niklas Hagman (blinkiz) wrote :

My personal goal here is to install virt-manager on my laptop to be able to control my server. If I do install virt-manager am forced to install a complete kvm/libvirt environment and this breaks my VirtualBox setup on my laptop.

So I still need to compile virt-manager from source to get around this bug. Grrrr...

Niklas Hagman (blinkiz) on 2009-04-29
summary: - Server part of virtualization is installed
+ ubuntu-virt-mgmt installing kvm and libvirt-bin

virt-manager recommends libvirt-bin, and libvirt-bin recommends kvm. Since Intrepid, we install recommended packages by default. You are free to remove them, though. (or run "apt-get install virt-manager kvm- libvirt-bin-", for instance)

Niklas Hagman (blinkiz) wrote :

Oh. didn't know that recommended packages was installed by default. Thats great that I can deselect packages with "-" sign.
Okay, I let ubuntu staff decide if this bug should stay open or not. I believe its still a problem that ubuntu-virt-mgmt is installing almost completely is counterpart ubuntu-virt-server by default.

James Page (james-page) on 2013-09-19
Changed in ubuntu-virt (Ubuntu):
status: New → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers