ubuntu-virt is not generated from seeds

Bug #1540323 reported by Robie Basak on 2016-02-01
18
This bug affects 2 people
Affects Status Importance Assigned to Milestone
tasksel (Ubuntu)
Undecided
Unassigned
ubuntu-virt (Ubuntu)
Undecided
Andy Whitcroft

Bug Description

I would expect this source package to not exist, and use ubuntu-meta instead.

Joshua Powers (powersj) wrote :

@robie

This package has not been updated since trusty (v 1.4). Is there an action to remove this entirely? Moving to incomplete.

Changed in ubuntu-virt (Ubuntu):
status: New → Incomplete
Robie Basak (racb) wrote :

I don't follow. This bug *is* the action to resolve this.

Changed in ubuntu-virt (Ubuntu):
status: Incomplete → New

Hi Robie,
so as you know ubuntu-virt only generates virtual packages.
I never used is and only came by lately (to fix outdated dependencies), effectively all it "provides" is a one shot way to e.g. install all kvm virt related things e.g. via:

 $ apt install ubuntu-virt
And it has the option to split by -mgmnt or -server.

Anyway I think this is not important at all.
I usually rather recommend to use
 $ apt install uvtool-libvirt
Which pulls in all you usually need as well and the great uvtool :-)

I never touched ubuntu-meta, how would that look like - maybe like this?

But IIRC ubuntu-meta is generated by the update script from the seeds, not vice versa right?
So the change would be in the seeds instead of ubuntu-meta?

Also I think that is somewhat over-dose for something we don't expect being really used.
How would be the opinions around "just" dropping ubuntu-virt?

Robie Basak (racb) wrote :

> So the change would be in the seeds instead of ubuntu-meta?

This ubuntu-virt package is generated from its own source though. AFAICT, it has nothing to do with the seeds, nor with ubuntu-meta.

tags: added: patch

Yes, it is it's own source indeed.

But now we went full circle (ubuntu-virt -> ubuntu-meta -> seeds -> ubuntu-virt) and I'm more puzzled than before about the initial description now :-)

@racb - Lets talk later to untangle this please

After a discussion to untangle this confusion I feel better focused - we both had somewhat mis-understandable comments which didn't make it any better :-)
Thanks rbasak to help me clarifying this!

-- Details --

According to popcon [1] (to somewhat guess usage) we look at ~0.27% of the installations actually having the meta package "ubuntu-virt-server" installed.
ubuntu-virt-mgmt is about half of that and the over-arching ubuntu-virt is even fewer.

There is one seed (and an assocated tasksel) as one can see in reverse dependencies [2].
The "Virt-Host" seed [3] is inconsistent - it does not "just" depend on ubuntu-virt or any of its subsets. Instead if depends on ubuntu-virt-server, but then also explicitly libvirt-bin, openssh and various per arch qemu's.

Also these days there is no singular "Ubuntu virtualization stack" anymore. These days virt-stacks are mostly defined by their management interfaces.
If one wants containers he picks LXD. If he is going openstack he will go that route and so on.

Therfore I challenge if it is still important to have a "ubuntu-virt" meta package?
For the tasksel it might makes sense to exist, but even then it should be done via the seed directly.

---

Proposal:
A - drop ubuntu-virt* meta pkg in Artful:
 A1. change the virt-host seed to directly on correct binary packages
 A2. drop the source package ubuntu-virt in artful (and thereby the meta packages ubuntu-virt, ubuntu-virt-mgmt, ubuntu-virt-server)

Alternative:
B - keep ubuntu-virt* meta pkg, but restructure it's source in >=Artful:
 B1. Add seeds for ubuntu-virt-* as we decided we really need them
 B2. make the creation of the ubuntu-virt-* meta packages part of ubuntu-meta
 B3. drop the direct redundant dependencies from virt-host seed
 B4. drop the source package ubuntu-virt in artful

I outlined B right away in case A can't be accepted to quickly get to something actionable.

[1]: http://popcon.ubuntu.com/by_inst
[2]: http://people.canonical.com/~ubuntu-archive/germinate-output/ubuntu.artful/rdepends/ubuntu-virt/ubuntu-virt-server
[3]: http://people.canonical.com/~ubuntu-archive/seeds/ubuntu.artful/virt-host

I got the ok from Dustin who was the original creator and maintainer to go on with proposal A.

Preparing a branch for the ubuntu.artful seed.

Not sure how "valid" my local verification germinate runs against the changed content were.
I definitely see it:
a) still completing with good RC
b) the changes showing up in generated virt-host.seedtext
But at least with the current invocation my locally created rdepends dir is empty.

Furthermore I parsed through the whole of [1] to see if I might miss references we should change - but didn't find more that we would want to cover.

A review is highly welcome - not only because I can't upload on my own, but because it is the first time I mess with that (important) part of Ubuntu.

[1]: http://people.canonical.com/~ubuntu-archive/seeds/

@Robie Basak - since you are context switched into the topic already, could you take a look at the proposed branch and let me know if/what is missing.

Otherwise if it is ok as I read [1] there isn't much "sponsoring" or process around it "just" a core-dev to upload. I wonder about that being so "easy" for changing the seeds, but maybe I overlook a safety check behind that.

[1]: https://wiki.ubuntu.com/SeedManagement#Changing_the_Seeds

It came up in the discussion that the argument against the meta package applies just as much to the task. That is absolutely true, so I modified the MP to remove all of the task as well.

As I read through tasksel updates we will need to regenerate tasks there once the seed change is done. That is regenerated via ubuntu-seeds.pl.

Adding a task for it to the bug.

Changed in tasksel (Ubuntu):
status: New → Confirmed

FYI - I pinged on the MP to be considered.

The other change (tasksel) is blocked on the seeds MP being merged to let the regen in tasksel pick up the changes correctly.

MPs to seeds are merged - checking the real germinate process.

[1] files lost virt host - ok
[2] structure lost virt host - ok
[3]: supported replaced the dependencies in misc - ok
[4]: supported sources (comparing to zesty) did not loose (or add) and packages due to the change - ok

That said germinate seems to be fully processed looking into regenerating tasksel now for a proposal.

[1]: http://people.canonical.com/~ubuntu-archive/germinate-output/ubuntu.artful/
[2]: http://people.canonical.com/~ubuntu-archive/germinate-output/ubuntu.artful/structure
[3]: http://people.canonical.com/~ubuntu-archive/germinate-output/ubuntu.artful/supported-misc-servers.seedtext
[4]: http://people.canonical.com/~ubuntu-archive/germinate-output/ubuntu.artful/supported-misc-servers.sources

Tasksel is another bzr branch at lp:~ubuntu-core-dev/tasksel/ubuntu but that is outdated.
The other VCS in d/control is Debians git and has no Ubuntu branch.
[1] has no other info either.
Reading through the most recent changes to tasksel I found similar issues on the branches like [2]
Long story short - I'll provide a debdiff to the package unless somebody can point me to a better way.

Praises to git to help me keep track what it actually changed this was regenerated via:
 $ ./ubuntu-seeds.pl ubuntu-tasks artful ubuntu xubuntu ubuntustudio ubuntu-mate ubuntu-gnome ubuntu-budgie lubuntu kubuntu platform

Note: There is another change on lubuntu-core-share picked up by the regenerate, which is due to [3]. I kept it in the Debdiff and adapted the changelog to mention it; if you prefer otherwise -
 please drop it or let me know if it should not be in the update.

Please review the debdiff and consider sponsoring it into Artful.

[1]: https://code.launchpad.net/tasksel
[2]: https://code.launchpad.net/~ubuntubudgie-dev/tasksel/ubuntu-budgie-tasksel-proposal.zesty/+merge/313844
[3]: http://bazaar.launchpad.net/~lubuntu-dev/ubuntu-seeds/lubuntu.artful/revision/374

Robie Basak (racb) on 2017-07-11
Changed in tasksel (Ubuntu):
status: Confirmed → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package tasksel - 3.34ubuntu7

---------------
tasksel (3.34ubuntu7) artful; urgency=medium

  * Update Ubuntu tasks from seeds
    - picks up the dropping of virt-host (LP: #1540323)
    - picks up renaming of lubuntu-core-share to core-share

 -- Christian Ehrhardt <email address hidden> Tue, 11 Jul 2017 09:17:17 +0200

Changed in tasksel (Ubuntu):
status: Fix Committed → Fix Released
Changed in ubuntu-virt (Ubuntu):
status: New → Triaged

Now that also tasksel is fixed as well it is time to clean up in the archive:

Dependencies:
$ reverse-depends --with-suggests --release=artful src:ubuntu-virt
No reverse dependencies found

Making sure there is really no trace left, I check [1] and [2] with recursive wget+grep.
But there were no dependencies left either.

Therefore I ask an Archive Admin (now subscribed) to please remove src:ubuntu-virt and all binary packages it builds from Artful.

[1]: http://people.canonical.com/~ubuntu-archive/germinate-output/ubuntu.artful/
[2]: http://people.canonical.com/~ubuntu-archive/seeds/ubuntu.artful/

Andy Whitcroft (apw) wrote :

Confirmed this is no longer depended on, and indeed has already slipped into universe as a result.

Removing packages from artful:
        ubuntu-virt 1.5 in artful
                ubuntu-virt 1.5 in artful amd64
                ubuntu-virt 1.5 in artful arm64
                ubuntu-virt 1.5 in artful armhf
                ubuntu-virt 1.5 in artful i386
                ubuntu-virt 1.5 in artful ppc64el
                ubuntu-virt 1.5 in artful s390x
                ubuntu-virt-mgmt 1.5 in artful amd64
                ubuntu-virt-mgmt 1.5 in artful arm64
                ubuntu-virt-mgmt 1.5 in artful armhf
                ubuntu-virt-mgmt 1.5 in artful i386
                ubuntu-virt-mgmt 1.5 in artful ppc64el
                ubuntu-virt-mgmt 1.5 in artful s390x
                ubuntu-virt-server 1.5 in artful amd64
                ubuntu-virt-server 1.5 in artful arm64
                ubuntu-virt-server 1.5 in artful armhf
                ubuntu-virt-server 1.5 in artful i386
                ubuntu-virt-server 1.5 in artful ppc64el
                ubuntu-virt-server 1.5 in artful s390x
Comment: Redundant package metas now produced from the main seeds (LP: #1540323)
Remove [y|N]? y
1 package successfully removed.

Changed in ubuntu-virt (Ubuntu):
assignee: nobody → Andy Whitcroft (apw)
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers