Please port your package away from Qt 4

Bug #1757896 reported by Simon Quigley
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
ubuntu-unity-meta (Ubuntu)
Fix Released
Undecided
Khurshid Alam

Bug Description

Currently Qt 4 has been dead upstream and we are starting to have problems maintaining it, like for example in the OpenSSL 1.1 support case.

Following in the footsteps of Debian[1], all packages directly or indirectly depending on qt4-x11 (like this one) must either get ported to Qt 5 and uploaded to the development release or get removed (by means of demotion to -proposed or removal of the package) before the 19.04 release. If it is possible to port your package by the 18.10 release, please do so.

If you have any questions about porting or this transition, please ask in #ubuntu-qt (preferred) or directly ping me

[1] https://wiki.debian.org/Qt4Removal

Tags: qt4-removal
Changed in ubuntu-unity-meta (Ubuntu):
status: New → In Progress
assignee: nobody → Khurshid Alam (khurshid-alam)
Rik Mills (rikmills)
Changed in ubuntu-unity-meta (Ubuntu):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers