Toolkit gallery doesn't change QGuiApplication::layoutDirection

Bug #1666869 reported by Adnane Belmadiaf on 2017-02-22
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
ubuntu-ui-toolkit (Ubuntu)
Undecided
Christian Dywan

Bug Description

While working on fixing the iconprovider to load -rtl icons i saw that QGuiApplication::layoutDirection() is always Qt::LeftToRight and never changes even if the gallery layout changes to RTL, i think the layout changes are only applied to the elements rather that application.

Related branches

summary: - QGuiApplication::layoutDirection() is always Qt::LeftToRight
+ Toolkit gallery doesn't change QGuiApplication::layoutDirection
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in ubuntu-ui-toolkit (Ubuntu):
status: New → Confirmed
Changed in ubuntu-ui-toolkit (Ubuntu):
assignee: nobody → Christian Dywan (kalikiana)
status: Confirmed → In Progress
tags: added: unity8
Changed in ubuntu-ui-toolkit (Ubuntu):
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntu-ui-toolkit - 1.3.2190+17.04.20170327

---------------
ubuntu-ui-toolkit (1.3.2190+17.04.20170327) zesty; urgency=medium

  [ Christian Dywan ]
  * Make AdaptivePageLayout handle layoutDirection out of the box.
  * Change layoutDirection from gallery (via UCApplication). Fixes LP: #1666869
  * Use layoutDirection to select icon for Back button. Fixes LP: #1665938
  * Ellipsize subtitle in the PageHeader. Fixes LP: #1660390

  [ Albert Astals Cid ]
  * Fix regression that broke BorderImage. Fixes LP: #1671449

 -- Zoltán Balogh <email address hidden> Mon, 27 Mar 2017 09:27:32 +0000

Changed in ubuntu-ui-toolkit (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers