filterCaseSensitivity doesn't work when used in SortFilterModel

Bug #1663924 reported by Adnane Belmadiaf on 2017-02-11
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
ubuntu-ui-toolkit (Ubuntu)
Undecided
Christian Dywan

Bug Description

SortFilterModel does support sortCaseSensitivity but not filterCaseSensitivity or it doesn't work, demo attached.

Related branches

Adnane Belmadiaf (daker) wrote :
Christian Dywan (kalikiana) wrote :

The property can't work: QSortFilterProxyModel.sortCaseSensitivity doesn't change the pattern and the superclass doesn't have any signals, making it impossible to manually update the results.

We 'could' consider overriding the property to make this work. However, I'm not sure it's particularly useful: in your example, new RegExp("^" + searchTerms, "i") achieves the same as setting the superclass property, as does using a literal regular expression such as /^B/i.

Christian Dywan (kalikiana) wrote :

It may be useful to have a dedicated unit test for this in any case, so I proposed a branch.

Changed in ubuntu-ui-toolkit (Ubuntu):
status: New → In Progress
assignee: nobody → Christian Dywan (kalikiana)
Adnane Belmadiaf (daker) wrote :

I can confirm that using new RegExp("^" + searchTerms, "i") solves the issue, maybe we can add that to the docs ?

Changed in ubuntu-ui-toolkit (Ubuntu):
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntu-ui-toolkit - 1.3.2184+17.04.20170306

---------------
ubuntu-ui-toolkit (1.3.2184+17.04.20170306) zesty; urgency=medium

  [ Adnane Belmadiaf ]
  * Add support for CheckBox label when set
  * Add more tests for checkbox. Fixes LP: #1333228, LP: #1442851.
  * Make sure we resets partial text input from the input method.
    Fixes LP: #1630872.
  * Fix ListItem title/subtitle alignment & elide in RTL mode.
    Fixes LP: #1665944.
  * Fix PageHeader title alignment & elide in RTL mode. Fixes LP: #1665942.
  * Fix UbuntuListView docs. Fixes LP: #1486940.
  * Add count prop to OptionSelector. Fixes LP: #1341559.
  * Replace the hardcoded color with a theme color. Fixes LP: #1664758.
  * Fix the import statement for Menu, MenuBar and MenuGroup.
    Fixes LP: #1660604.

  [ Albert Astals Cid ]
  * Fix memory leak in UCStyleHints
  * ThinDivider: Anchors can't be null, set to undefined
  * No need to call UCUnits::resolveResource to learn we just need to load it
    normally because the fact that we already loaded it normally means we need
    to load it normally. Fixes LP: #1558663.
  * Fix conditional jump or move depends on uninitialised value(s)

  [ Christian Dywan ]
  * Initialize UCApplication with no side effects. Fixes LP: #1662868.
  * Unit test case insensitive FilterBehavior.pattern. Fixes LP: #1663924.
  * ListItemPopover delegate should (in)visible as per action Bug 1662220:
    [ListItem] Popupmenu shows traces of disabled actions

  [ Olivier Tilloy ]
  * Check that window is not null before accessing its activeFocusItem property.
    Fixes LP: #1664620.

  [ Lukáš Tinkl ]
  * Unbreak the startup race between unity8/qtmir and UITK trying talk to
    content-hub. Fixes LP: #1663106.

 -- Zoltán Balogh <email address hidden> Mon, 06 Mar 2017 16:04:56 +0000

Changed in ubuntu-ui-toolkit (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments