Clear text (x) does not clear the first suggested but not committed word

Bug #1630872 reported by Zoltan Balogh on 2016-10-06
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
ubuntu-ui-toolkit (Ubuntu)
Critical
Adnane Belmadiaf

Bug Description

When the "Word suggestions" option in the "Language & Text" settings then the (x) clear button does not clear the first not committed word from the text input.
It seems that the suggested word is not yet in the text innut but only in the input method and the clear button does not clear the input method.
After the first word is committed, the second suggestion is cleared if you clear the content.

Related branches

Christian Dywan (kalikiana) wrote :
Christian Dywan (kalikiana) wrote :

- No AP tests fail.
- Word suggestions are off by default, but don't affect the test results.
- The most recent change related to the clear button is confirmed to not affect this bug: http://bazaar.launchpad.net/~ubuntu-sdk-team/ubuntu-ui-toolkit/staging/revision/2115
- Apparently with AP we don't test the button visibility directly.
- We don't force the right IM settings to reproduce it either.

Changed in ubuntu-ui-toolkit (Ubuntu):
status: Confirmed → Triaged
Adnane Belmadiaf (daker) wrote :

Maybe this is related bug 1661890

Adnane Belmadiaf (daker) wrote :

This has been fixed in Qt 5.7 by introducing a clear method http://doc.qt.io/qt-5/qml-qtquick-textinput.html#clear-method

Adnane Belmadiaf (daker) on 2017-02-21
Changed in ubuntu-ui-toolkit (Ubuntu):
assignee: Christian Dywan (kalikiana) → Adnane Belmadiaf (daker)
Changed in ubuntu-ui-toolkit (Ubuntu):
status: Triaged → In Progress
Changed in ubuntu-ui-toolkit (Ubuntu):
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntu-ui-toolkit - 1.3.2184+17.04.20170306

---------------
ubuntu-ui-toolkit (1.3.2184+17.04.20170306) zesty; urgency=medium

  [ Adnane Belmadiaf ]
  * Add support for CheckBox label when set
  * Add more tests for checkbox. Fixes LP: #1333228, LP: #1442851.
  * Make sure we resets partial text input from the input method.
    Fixes LP: #1630872.
  * Fix ListItem title/subtitle alignment & elide in RTL mode.
    Fixes LP: #1665944.
  * Fix PageHeader title alignment & elide in RTL mode. Fixes LP: #1665942.
  * Fix UbuntuListView docs. Fixes LP: #1486940.
  * Add count prop to OptionSelector. Fixes LP: #1341559.
  * Replace the hardcoded color with a theme color. Fixes LP: #1664758.
  * Fix the import statement for Menu, MenuBar and MenuGroup.
    Fixes LP: #1660604.

  [ Albert Astals Cid ]
  * Fix memory leak in UCStyleHints
  * ThinDivider: Anchors can't be null, set to undefined
  * No need to call UCUnits::resolveResource to learn we just need to load it
    normally because the fact that we already loaded it normally means we need
    to load it normally. Fixes LP: #1558663.
  * Fix conditional jump or move depends on uninitialised value(s)

  [ Christian Dywan ]
  * Initialize UCApplication with no side effects. Fixes LP: #1662868.
  * Unit test case insensitive FilterBehavior.pattern. Fixes LP: #1663924.
  * ListItemPopover delegate should (in)visible as per action Bug 1662220:
    [ListItem] Popupmenu shows traces of disabled actions

  [ Olivier Tilloy ]
  * Check that window is not null before accessing its activeFocusItem property.
    Fixes LP: #1664620.

  [ Lukáš Tinkl ]
  * Unbreak the startup race between unity8/qtmir and UITK trying talk to
    content-hub. Fixes LP: #1663106.

 -- Zoltán Balogh <email address hidden> Mon, 06 Mar 2017 16:04:56 +0000

Changed in ubuntu-ui-toolkit (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers