tst_textarea.11.qml unit test fails

Bug #1624342 reported by Tim Peeters on 2016-09-16
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
ubuntu-ui-toolkit (Ubuntu)
Critical
Christian Dywan

Bug Description

Fails with Qt 5.6.

FAIL! : components::TextAreaAPI::test_0_color() TextArea.color is same as TextEdit.canUndo
   Actual (): #5d5d5d
   Expected (): #000000
   Loc: [/tmp/buildd/ubuntu-ui-toolkit-1.3.2085+16.10.20160831.4/tests/unit/visual/tst_textarea.11.qml(141)]

See https://jenkins.ubuntu.com/ubuntu-sdk/job/ubuntu-ui-toolkit-ci-amd64-devel/1201/consoleFull

Andrea Bernabei (faenil) wrote :

1) typo, should be "TextArea.color is same as TextEdit.color"

2) does it make sense to expect TextArea (which has Ubuntu styling) to have the same default colour as TextEdit? Maybe we should just change the test?

Zsombor Egri (zsombi) on 2016-09-20
Changed in ubuntu-ui-toolkit (Ubuntu):
importance: Undecided → Critical
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in ubuntu-ui-toolkit (Ubuntu):
status: New → Confirmed
Changed in ubuntu-ui-toolkit (Ubuntu):
assignee: nobody → Christian Dywan (kalikiana)
Changed in ubuntu-ui-toolkit (Ubuntu):
status: Confirmed → In Progress
Changed in ubuntu-ui-toolkit (Ubuntu):
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntu-ui-toolkit - 1.3.2151+17.04.20161223

---------------
ubuntu-ui-toolkit (1.3.2151+17.04.20161223) zesty; urgency=medium

  [ Zsombor Egri ]
  * Enable mouse, touchpad and keyboard detection in UITK. Fixes LP: #1536669
  * Colors revisited.
  * Qt5.7 related fix for theming - by Glen Whitney.

  [ Timo Jyrinki ]
  * parent = Q_NULLPTR instead of 0. Fixes LP: #1642617
  * More blank lines. Fixes LP: #1642622
  * Drop tst_pickerpanel.11.qml (deprecated).

  [ Christian Dywan ]
  * Include OSK input in TextArea.displayText. Fixes LP: #1595910

  * Drop questionable color tests from tst_textarea.11.qml. Fixes LP: #1624342

  [ Lukáš Tinkl ]
  * Fix slider progress rect with RTL languages.

 -- Marco Trevisan (Treviño) <mail@3v1n0.net> Fri, 23 Dec 2016 14:52:55 +0000

Changed in ubuntu-ui-toolkit (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers