tst_textfield.11.qml unit test failures

Bug #1624340 reported by Tim Peeters on 2016-09-16
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
ubuntu-ui-toolkit (Ubuntu)
Critical
Christian Dywan

Bug Description

Fails with Qt 5.6.

FAIL! : components::TextFieldAPI::test_0_cursorRectangle() cursorRectangle 0 by default
   Actual (): QRectF(0, 4, 1, 16)
   Expected (): QRectF(0, 0, 0, 0)
   Loc: [/tmp/buildd/ubuntu-ui-toolkit-1.3.2085+16.10.20160831.4/tests/unit/visual/tst_textfield.11.qml(168)]

See https://jenkins.ubuntu.com/ubuntu-sdk/job/ubuntu-ui-toolkit-ci-amd64-devel/1201/consoleFull.

Related branches

Zsombor Egri (zsombi) on 2016-09-20
Changed in ubuntu-ui-toolkit (Ubuntu):
importance: Undecided → Critical
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in ubuntu-ui-toolkit (Ubuntu):
status: New → Confirmed
Changed in ubuntu-ui-toolkit (Ubuntu):
assignee: nobody → Christian Dywan (kalikiana)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntu-ui-toolkit - 1.3.2141+16.10.20161013.5

---------------
ubuntu-ui-toolkit (1.3.2141+16.10.20161013.5) yakkety; urgency=medium

  [ Zsombor Egri ]
  * Do not show focus frame on ListItem when clicked. Fixes LP: #1628855
  * Fix color used to test ListItem.highlighted. Fixes LP: #1624328

  [ Christian Dywan ]
  * Don't skip the entirety of tst_textfield.11.qml. Fixes LP: #1624340

  [ Andrea Bernabei ]
  * SlotsLayout: do not set mainSlot's implicitSize, set its real size instead
    Fixes LP: #1630167.

  [ Tim Peeters ]
  * Enable proper focus handling in the scrolling ActionBar. Fixes LP: #1575893

 -- Zoltán Balogh <email address hidden> Thu, 13 Oct 2016 17:16:31 +0000

Changed in ubuntu-ui-toolkit (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers