UbuntuShape on intel i915 (Atom) uses fallback CPU rendering

Bug #1585723 reported by Gerry Boland
38
This bug affects 7 people
Affects Status Importance Assigned to Milestone
ubuntu-ui-toolkit (Ubuntu)
High
Loïc Molinari

Bug Description

I'm digging into unity8 performance problems on older generation Intel GPUs - specifically i915 Atom GPUs.

I've tested a simple QML file with a single empty UbuntuShape in it:

import QtQuick 2.4
import Ubuntu.Components 1.3

Rectangle {
    width: 400
    height: 300
    color: "blue"

    UbuntuShape {}
}

Running it with INTEL_DEBUG=perf env var set, I get this output:

i915_program_error: Exceeded max ALU instructions (76 out of 64)
ENTER FALLBACK 10000: Program
Mapping a busy BO, causing a stall on the GPU.

which implies that MESA was unable to compile one of the UbuntuShape shaders as it created more ALU instructions than the GPU could deal with. MESA falls back to CPU rendering as a result.

The GPU stall message I guess is related to that.

Related branches

Gerry Boland (gerboland)
description: updated
Revision history for this message
Gerry Boland (gerboland) wrote :

Ouch, on the hardware I have access to to test on, even a single Ubuntu Shape in a simple QML file has a massive hit on rendering performance. Rendering times went up 130ms *per shape*!

Revision history for this message
Gerry Boland (gerboland) wrote :

FYI: INTEL_DEBUG=all is useful, it shows the opcodes mesa is generating from your shaders.

Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in ubuntu-ui-toolkit (Ubuntu):
status: New → Confirmed
Revision history for this message
Daniel van Vugt (vanvugt) wrote :

i915_program_error: Exceeded max ALU instructions (76 out of 64)

^^ This means we're very close. The shader is only ~18% longer than the i915 hardware limit which should be quite feasible to resolve.

tags: added: performance
Revision history for this message
Emanuele Antonio Faraone (emanueleant03) wrote :

I tried to use unity8 after updating Qtubuntu and I encountered these problems if I try to open the app crashes unity8 (I can use only the scopes), the pointer is giant, the system is very slow.

Revision history for this message
Emanuele Antonio Faraone (emanueleant03) wrote :

if I try to resize a window, it takes several seconds to show the result, not even Work the scopes

Revision history for this message
Emanuele Antonio Faraone (emanueleant03) wrote :

it is unusable

Gerry Boland (gerboland)
Changed in ubuntu-ui-toolkit (Ubuntu):
importance: Undecided → High
Revision history for this message
Emanuele Antonio Faraone (emanueleant03) wrote :

And now?

Revision history for this message
Emanuele Antonio Faraone (emanueleant03) wrote :

?

Revision history for this message
Emanuele Antonio Faraone (emanueleant03) wrote :

With the new version of EGL convenience the problem is the same of the problem with the old version of Qtubuntu .

Revision history for this message
Emanuele Antonio Faraone (emanueleant03) wrote :

Any news now?(sorry for my insistence but it is important)

Revision history for this message
Andrea Bernabei (faenil) wrote :

Hi Emanuele, I asked the developer of Ubuntu Shape, and he said the new (improved!) version of the UbuntuShape should not have this problem.

It will still take a few weeks before that is released though, as there are a lot of pieces involved.

But still, I hope that's good news for you :)

Revision history for this message
Emanuele Antonio Faraone (emanueleant03) wrote :

Thanks Andrea!

Revision history for this message
Emanuele Antonio Faraone (emanueleant03) wrote :

Is it landed?

Revision history for this message
Andrea Bernabei (faenil) wrote :

nope, it will still take a few weeks, from what I understood (sorry if I can't give more precise info, that is all I know :/ )

Revision history for this message
Emanuele Antonio Faraone (emanueleant03) wrote :

And now is it landed?

Revision history for this message
Emanuele Antonio Faraone (emanueleant03) wrote :

?

Revision history for this message
Andrea Bernabei (faenil) wrote :

You can assume it is landed when this bug is marked as Fix Released

tags: added: i915
removed: performance
tags: added: performance
removed: i915
Gerry Boland (gerboland)
tags: added: unity8
Revision history for this message
Emanuele Antonio Faraone (emanueleant03) wrote :

Any news?(sorry for my insistence)

Changed in ubuntu-ui-toolkit (Ubuntu):
assignee: nobody → Loïc Molinari (loic.molinari)
Changed in ubuntu-ui-toolkit (Ubuntu):
status: Confirmed → In Progress
Revision history for this message
Emanuele Antonio Faraone (emanueleant03) wrote :

no commit since December, there are news?

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers