tst_listitem.* failures in test_0_defaults with Qt 5.6 on amd64

Bug #1560004 reported by Timo Jyrinki
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
ubuntu-ui-toolkit (Ubuntu)
High
Christian Dywan

Bug Description

Update 2016-07-20: Updated information from latest Qt 5.6.1 builds and 20160615 UITK.

UITK fails some tests with Qt 5.6 on amd64, preventing a build (unless overridden):

https://launchpadlibrarian.net/253811553/buildlog_ubuntu-xenial-amd64.ubuntu-ui-toolkit_1.3.1938+16.04.20160412build1~xenial1~qt560~1_BUILDING.txt.gz

FAIL! : components::ListItemAPI::test_0_defaults() Transparent by default
   Actual (): #00000000
   Expected (): #000000
   Loc: [/home/cris/bau/uut.staging/tests/unit/visual/tst_listitem.12.qml(248)]

amd64 on Qt 5.6.1
30 failures which MUST be fixed:
  dpr2
  dpr3
  performance
  subtheming
  tst_datepicker12.bug1567840.SEGFAULT.qml
  tst_datepicker13.bug1567840.SEGFAULT.qml
  tst_expandablescolumn.qml
  tst_listitem.qml
  tst_listitem13.qml
  tst_pagehead_sections_bug1511839.qml
  tst_scrollbar.qml
  tst_scrollbar_header.qml
  tst_sections.qml
  tst_ubuntulistview.qml

60 fatal warnings which MUST be fixed:
  tst_actionbar.qml
  tst_expandable.qml
  tst_pagestack_deprecated_toolbar.qml

--

More information about Qt 5.6 at https://wiki.ubuntu.com/Touch/QtTesting

Related branches

Revision history for this message
Andrea Bernabei (faenil) wrote :

In Scrollbar, UbuntuListView and ExpandableColumns tests the issue is the same,
"Type Error" when trying to do either
var sceneThumbX = thumb.mapToItem(column).x

or
fuzzyCompare(ubuntuListView.mapFromItem(item).y, item.collapsedHeight, .5);

or
compare(expandablesColumn.mapFromItem(item).y, item.collapsedHeight);

description: updated
Changed in ubuntu-ui-toolkit (Ubuntu):
importance: Undecided → High
Revision history for this message
Timo Jyrinki (timo-jyrinki) wrote :

Still happens with Qt 5.6.1, so something that will need to get fixed.

description: updated
summary: - UITK test failures with Qt 5.6 on amd64
+ tst_listitem.* failures with Qt 5.6 on amd64
description: updated
summary: - tst_listitem.* failures with Qt 5.6 on amd64
+ tst_listitem.* failures in test_0_defaults with Qt 5.6 on amd64
Changed in ubuntu-ui-toolkit (Ubuntu):
assignee: nobody → Christian Dywan (kalikiana)
Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in ubuntu-ui-toolkit (Ubuntu):
status: New → Confirmed
Changed in ubuntu-ui-toolkit (Ubuntu):
status: Confirmed → In Progress
Changed in ubuntu-ui-toolkit (Ubuntu):
status: In Progress → Fix Committed
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntu-ui-toolkit - 1.3.2060+16.10.20160814

---------------
ubuntu-ui-toolkit (1.3.2060+16.10.20160814) yakkety; urgency=medium

  [ Zoltan Balogh ]
  * Fix OptionSelectorTestCase tests.
  * Fix more OptionSelector autopilot tests

  [ Timo Jyrinki ]
  * Disable documentation building for GLES builds. Fixes LP: #1606222.
  * Replace abs with qFabs due to GCC6 breakage. Fixes LP: #1610943.
  * Limit s390x dependencies more due to upstart/s390x problems and removed
    packages in archives. Fixes LP: #1610951

  [ Andrea Bernabei ]
  * ListItemLayout doc: add elide mode change example and add section about
    labels default properties values. Fixes LP: #1603450.
  * ListItemLayout doc: add explicit note about the need to bind ListItem's
    height to layout's height.
  * More Scrollbar optimizations: 20% faster creation time. Fixes LP: #1606451
  * Scrollbar: fix wrong thumb color on tap/mouse release and increase coverage
    of hover states unit tests. Fixes LP: #1608897

  [ Zsombor Egri ]
  * Fix null pointer property initializer used with 1.3 PageWrapper.
    Fixes LP: #1604780.
  * Fix BottomEdge content URL preloading. Fixes LP: #1604509.

  [Albert Astals Cid ]
  * UCUnits::resolveResource: Prefer image path if it exists. This saves
    searching the disk for @gu images, which is a big speedup. According to
    callgrind loading 100 images from a folder that contains 380 images goes
    from around 3 million instructions per UCUnits::resolveResource call down
    to around 10 thousand. This optimization is ok since it is not correct to
    ship both image.png and image@20.png. You either have to ship gu-enabled
    files or not, but mixing them is not allowed. Searched for cases in which
    that may be happening in my phone and found none. Fixes LP: #1604029.

  [ Tim Peeters ]
  * Configure colors of the buttons in the ActionBar and PageHeader through
    their Styles. Fixes LP: #1597774.
  * Fix assigning of constant values to a grouped property in StyleHints.
    Fixes LP: #1602836.
  * Fix list view keyboard navigation for RightToLeft and BottomToTop
    directions. Fixes LP: #1605634
  * Use external QML files instead of embedded QML strings for autopilot tests.
    Fixes LP: #1578319
  * Fix failing autopilot header tests.
  * Fix ActionSelectionPopover Autopilot CPO tests.

  [Christian Dywan ]
  * Include indexes in "offline" docs and filter out link errors.
    Fixes LP: #1603937.
  * Increase focus ring thickness from 1dp to 2dp. Fixes LP: #1602690.
  * Add a snippet about tests to the toplevel README
  * Enter/Return to trigger, Space to expand ComboButton. Fixes LP: #1523817.
  * Initialize engine variable before using it in the _engine case.
  * Use Qt.rgba instead of #0000 checking ListItem default color.
    Fixes LP: #1560004
  * Don't use a different .desktop file in the gallery tests.
    Fixes LP: #1578319
  * Update scaling docs, set QT_SCALE_FACTOR and unset GRID_UNIT_PX.
    Fixes LP: #1610208

  [ Florian Boucault ]
  * Sections: load Icons asynchronously.

 -- Zoltán Balogh <email address hidden> Sun, 14 Aug 2016 09:06:46 +0000

Changed in ubuntu-ui-toolkit (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers