Error: Cannot assign to non-existent property "activeFocusOnPress"

Bug #1532953 reported by Olivier Tilloy on 2016-01-11
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Canonical System Image
Low
Zoltan Balogh
ubuntu-ui-toolkit (Ubuntu)
Low
Olivier Tilloy

Bug Description

When launching webbrowser-app on the latest rc-proposed touch images, I’m seeing the following errors in the console:

file:///usr/lib/arm-linux-gnueabihf/qt5/qml/Ubuntu/Components/1.3/TextField.qml:926: Error: Cannot assign to non-existent property "activeFocusOnPress"
file:///usr/lib/arm-linux-gnueabihf/qt5/qml/Ubuntu/Components/1.3/TextField.qml:902: Error: Cannot assign to non-existent property "activeFocusOnPress"

I’ve been seeing those for a few weeks now, but forgot to report the bug until now, as browser functionality doesn’t seem to be degraded.

Related branches

Olivier Tilloy (osomon) wrote :

It appears the TextField component attempts to set activeFocusOnPress to false on all the children of its primaryItem and secondaryItem. This doesn’t work for plain QtQuick items, which don’t have this Ubuntu-specific property. The code should probably check for the existence of the property before trying to set it.

Olivier Tilloy (osomon) wrote :

I can easily reproduce the error with the following standalone example:

    import QtQuick 2.4
    import Ubuntu.Components 1.3
    TextField {
        primaryItem: Item {}
    }

Olivier Tilloy (osomon) on 2016-01-26
Changed in ubuntu-ui-toolkit (Ubuntu):
assignee: nobody → Olivier Tilloy (osomon)
status: New → In Progress
importance: Undecided → Low
Launchpad Janitor (janitor) wrote :
Download full text (7.0 KiB)

This bug was fixed in the package ubuntu-ui-toolkit - 1.3.1872+16.04.20160308-0ubuntu1

---------------
ubuntu-ui-toolkit (1.3.1872+16.04.20160308-0ubuntu1) xenial; urgency=medium

  [ Timo Jyrinki ]
  * Fix gles unit test skipping.
  * Add s390x to the unit test skipping architectures
  * UITK test plan - wily -> xenial. Fixes LP: #1544490

  [ Christian Dywan ]
  * Print errors when QuickUtils fails to create a component.
  * unit tests shouldn't use deprecated Dialog.callera
  * Correctly count only test case results. The result= value is used in suites
    and results.
  * Skip tst_pagehead_visible flakes on non-arm. Fixes LP: #1534651
  * Skip flaky tst_mousefilterTest::doubleClicked. Fixes LP: #1542215
  * Suppress click signal if releasing outside of ListItem. Fixes LP: #1541148.
  * Use gdb in runtest.sh to produce backtraces.
  * Arrow keys change value of a Slider. Fixes LP: #1523824.
  * Only use Maliit when enabled explicitly in the environment

  [ Oliver Tilloy ]
  * Do not try to assign to non-existent property "activeFocusOnPress".
    Fixes LP: #1532953
  * Bubble up ESC key press event if there is no popover to close.
    Fixes LP: #1546627

  [ Loïc Molinari ]
  * Added private items and nodes for the new component styles.
    Fixes LP: #1523836
  * Made use of new private Frame item for the focusing.
  * Fixed performance monitor crash because of a NULL timer pointer dereference.
    Fixes LP: #1546986
  * Fixed performance monitor dangling pointer crash. Fixes LP: #1546984
  * [ProportionalShape] Ensured width/height ratio is correct with default values.
    Fixes LP: #1546546
  * Added a workaround to prevent a crash while changing the QPA scale factor.

  [ Florian Boucault ]
  * Always on performance monitor that logs frames that too long to render.
  * MainView: proceed to selecting the theme automatically at startup too.
    Fixes LP: #1535819
  * MainView: when no gradient color is needed for the background, rely on
    QQuickWindow's GL clear color. Lessens overdraw considerably for most
    apps. Fixes LP: #1439133.
  * Panel: MathUtils used without import prefix was leading to undefined
    reference.
  * Label: use native rendering on low dpi screens (GRID_UNIT_PX <= 10) for
    sharper looking text.
  * Gallery: added palette browser to Colors page.

  [ Tim Peeters ]
  * Support scrolling in ListViews with horizontal orientation to the
    qquicklistview CPO.
  * Add background to AppHeader and remove contents clipping from MainView.
    Fixes LP: #1531016, LP: #1531457.
  * Hide AppHeader when using AdaptivePageLayout. Fixes bug 1531871.
    Fixes LP: #1531871.
  * Implement horizontal flicking in the flickable autopilot CPO.
  * Re-order to list of pages in the gallery to be alphabetical.
  * Fix the autopilot failures introduced with the horizontal scrolling in
    the Flickable CPO.
  * Update documentation for MainView, Page, AdaptivePageLayout to use the new
    PageHeader in all examples. Deprecate old properties. Fixes LP: #1540574
  * Add 'animate' property to new internal AppHeaderBase, and do not show a
    header animation when starting an app without header.
    Fixes LP: #1518002, LP: #1524901.
 ...

Read more...

Changed in ubuntu-ui-toolkit (Ubuntu):
status: In Progress → Fix Released
Changed in canonical-devices-system-image:
status: New → Fix Committed
importance: Undecided → Low
assignee: nobody → Zoltan Balogh (bzoltan)
milestone: none → ww08-2016
Changed in canonical-devices-system-image:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers