(Shift)Tab must not leave dialog/popover/menu

Bug #1526208 reported by Christian Dywan on 2015-12-15
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Canonical System Image
High
Zoltan Balogh
qtdeclarative-opensource-src (Ubuntu)
High
Timo Jyrinki
qtdeclarative-opensource-src (Ubuntu RTM)
Undecided
Unassigned
ubuntu-ui-toolkit (Ubuntu)
High
Unassigned

Bug Description

It must not be possible to leave a dialog/popover/menu using (Shift)Tab. The only expected ways to leave are Escape and any component or key in the popover which would result in closing it.

http://code.qt.io/cgit/qt/qtdeclarative.git/diff/?id=6328dd2d2743ed540efea89742261f24552d7611
5.6 alpha introduces private API, isTabFence, to confine focus to a container. We could introduce API on StyledItem to expose that and use it in popovers.

description: updated
Changed in qtdeclarative-opensource-src (Ubuntu):
assignee: nobody → Timo Jyrinki (timo-jyrinki)
importance: Undecided → High
status: New → Confirmed
Changed in qtdeclarative-opensource-src (Ubuntu):
status: Confirmed → In Progress
Timo Jyrinki (timo-jyrinki) wrote :

Scheduled for OTA-10 because it's only needed there together with UITK changes.

Changed in canonical-devices-system-image:
importance: Undecided → High
assignee: nobody → Zoltan Balogh (bzoltan)
milestone: none → ww08-2016
Timo Jyrinki (timo-jyrinki) wrote :

There's a second infinite loop fix WIP at https://codereview.qt-project.org/#/c/146886/

Changed in canonical-devices-system-image:
status: New → In Progress
Timo Jyrinki (timo-jyrinki) wrote :

060 updated with patch set 2 from upstream, armhf build will be ready in 2h.

Timo Jyrinki (timo-jyrinki) wrote :

Moved to silo 23 for final builds, please retest!

Timo Jyrinki (timo-jyrinki) wrote :

It was successfully tested three days ago and QA was asked to add it into their queue despite britney warnings caused by -proposed but not this landing.

Changed in qtdeclarative-opensource-src (Ubuntu RTM):
status: New → In Progress
Łukasz Zemczak (sil2100) wrote :

This bug was fixed in the package qtdeclarative-opensource-src 5.4.1-1ubuntu11~overlay3 in https://launchpad.net/~ci-train-ppa-service/+archive/ubuntu/stable-phone-overlay

---------------

qtdeclarative-opensource-src (5.4.1-1ubuntu11~overlay3) vivid; urgency=medium

  * debian/patches/Add-isTabFence-private-flag.patch:
    - Tab should not leave dialog/popover/menu (LP: #1526208)
  * debian/patches/QQuickItem-fix-an-infinite-loop-nextItemInFocusChain.patch
    debian/patches/QQuickItem-fix-another-infinite-loop-in-nextItemInFo.patch:
    - Refine the previous patch (LP: #1526208)

 -- Timo Jyrinki <email address hidden> Sat, 30 Jan 2016 14:00:48 +0000

Changed in qtdeclarative-opensource-src (Ubuntu RTM):
status: In Progress → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package qtdeclarative-opensource-src - 5.5.1-2ubuntu4

---------------
qtdeclarative-opensource-src (5.5.1-2ubuntu4) xenial; urgency=medium

  * debian/patches/Add-isTabFence-private-flag.patch:
    - Tab should not leave dialog/popover/menu (LP: #1526208)
  * debian/patches/QQuickItem-fix-an-infinite-loop-nextItemInFocusChain.patch
    debian/patches/QQuickItem-fix-another-infinite-loop-in-nextItemInFo.patch:
    - Refine the previous patch (LP: #1526208)

 -- Timo Jyrinki <email address hidden> Sat, 30 Jan 2016 14:06:58 +0000

Changed in qtdeclarative-opensource-src (Ubuntu):
status: In Progress → Fix Released
Changed in canonical-devices-system-image:
status: In Progress → Fix Committed
Changed in canonical-devices-system-image:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related blueprints