UITK trunk causes address-book-app test to fail on xenial only

Bug #1525174 reported by Timo Jyrinki on 2015-12-11
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
address-book-app (Ubuntu)
Undecided
Unassigned
ubuntu-ui-toolkit (Ubuntu)
Critical
Unassigned

Bug Description

With current UITK trunk (that was released to vivid only as a special case since there are no problems there) the following error is gotten with address-book-app's contact_list test:

1/9 Test #1: contact_list .....................***Failed 0.65 sec
********* Start testing of qmltestrunner *********
Config: Using QtTest library 5.5.1, Qt 5.5.1 (x86_64-little_endian-lp64 shared (dynamic) release build; by GCC 5.3.1 20151207)
PASS : qmltestrunner::contactListTestCase::initTestCase()
QWARN : qmltestrunner::contactListTestCase::test_managerProperty() Fail to connect with syncfw
QFATAL : qmltestrunner::contactListTestCase::test_managerProperty() Damper::maxDelta must be a positive number.
FAIL! : qmltestrunner::contactListTestCase::test_managerProperty() Received a fatal error.
   Loc: [Unknown file(0)]
Totals: 1 passed, 1 failed, 0 skipped, 0 blacklisted
********* Finished testing of qmltestrunner *********
Aborted (core dumped)

This happens only with the UITK trunk and only on xenial.

Related branches

Changed in ubuntu-ui-toolkit (Ubuntu):
importance: Undecided → Critical
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in address-book-app (Ubuntu):
status: New → Confirmed
Changed in ubuntu-ui-toolkit (Ubuntu):
status: New → Confirmed
Christian Dywan (kalikiana) wrote :

The "maxDelta must be a positive number" seems to come from setPixelsPerMm in UCSwipeArea. It seems that window->screen()->physicalDotsPerInch() / 25.4 can be negative on Xenial.

Launchpad Janitor (janitor) wrote :
Download full text (7.7 KiB)

This bug was fixed in the package ubuntu-ui-toolkit - 1.3.1761+16.04.20151216.1-0ubuntu1

---------------
ubuntu-ui-toolkit (1.3.1761+16.04.20151216.1-0ubuntu1) xenial; urgency=medium

  [ Zoltán Balogh ]
  * Drop dependency on qtc plugin script and wait for the shell with a local
    function.

  [ Christian Dywan ]
  * runtest.sh needs to add subdirs to the libpath. Fixes: LP: #1524710.
  * Explicit click/ touch threshold beyond handler.
  * Enter/Return/Space should trigger() Button. Fixes: LP: #1523794.
  * Only set ppmm in SwipeArea if screen has valid dpi. Fixes: LP: #1525174.

  [ Tim Peeters ]
  * Implement header slot management for convergence:
    - Adapt the number of action slots to the width of the view.
    - When a new action appears, show a quick fade-in.
    - Reverse the order of the actions in the header.
    - Update icon width to 4GU. Fixes: LP: #1428757.
  * To prevent an invalid sectionIndex, reset the value of sectionIndex to -1
    when the model of Sections is changed. Fixes: LP: #1513933.

  [ Loïc Molinari ]
  * UbuntuShape - Cleaned up includes.

  [ Albert Astals Cid ]
  * Simplify logic for emitting draggingChanged/pressedChanged
    No need for a switch that considers the possible cases, just store the
    status before and check after
    Fixes an issue in which the SwipeArea pressedChanged signal was not emitted
    if switching directly from WaitingForTouch to Recognized.
  * Fix memory leak in SwipeArea
    SwipeAreaPrivate is not deleted directly so make it part of the qobject
    hierarchy so it's auto deleted on parent destruction.

  [ Zsombor Egri ]
  * Add reset functionality to Action.shortcut property. Fixes: LP: #1518420.
  * Add contentWidth and contentHeight to Dialog so foreground can be resized.
    Fixes: LP: #1249325.
  * Fixing ListItem.selected and ListItem.selectMode bugs.
    Fixes: LP: #1493880, LP: #1493882, LP: #1514928.
  * Add private implementations to ActionItem, AbstractButton, BottomEdgeHint
    and BottomEdge. Fixes: LP: #1524234
  * Close Popups.Dialog when Esc key is pressed. Fixes LP: #1523833
  * Invoke the overridden trigger() function for Action and ActionItem
    derivates. Fixes LP: #1524234
  * Fix BottomEdge assertion when the content is committed by clicking on the
    hint. Fixes LP: #1524407

  [ CI Train Bot ]
  * No-change rebuild.

ubuntu-ui-toolkit (1.3.1742+16.04.20151209-0ubuntu1) xenial; urgency=medium

  [ Zoltán Balogh ]
  * Enable building the UITK tests in any case.
  * Remove Q_Q(UCStyledItemBase) because of unused variable warning.
  * Resolve Trusty specific compiler issue not resolving QPointer data on
    connections.
  * Use only the object name when selecting sections and labels in tests.

  [Zsombor Egri ]
  * Update BottomEdge with UI/UX agreed during the sprint. Fixes LP: #1368811.
  * BottomEdge component. Fixes LP: #1368811.
  * Remove build failure on Xenial caused by deprecated Qt functions.
  * Fix BottomEdgeHint consumes activeFocusOnPress handling. Fixes LP: #1517777
  * Migrate DirectionalDragArea from Unity8, named as SwipeArea. Original code
    (from lp:unity8) by: Daniel d'Andrada <email address hidden>.
  * Delete QQuickVi...

Read more...

Changed in ubuntu-ui-toolkit (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers