TextField/Area should only show focus outline for keyboard input focus

Bug #1522739 reported by Christian Dywan
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Canonical System Image
High
Zoltan Balogh
ubuntu-ui-toolkit (Ubuntu)
High
Christian Dywan
ubuntu-ui-toolkit (Ubuntu RTM)
High
Christian Dywan

Bug Description

As it says on the tin. TextField and TextArea should only show the focus outline for keyboard input focus ie. Tab was used to enter the component. Touch or mouse input only affects cursor/ selection (activeFocus will still be true for all of these cases and affect the tab order).

Related branches

Changed in canonical-devices-system-image:
assignee: nobody → Zoltan Balogh (bzoltan)
milestone: none → ww08-2016
Changed in canonical-devices-system-image:
importance: Undecided → High
status: New → Confirmed
Changed in canonical-devices-system-image:
status: Confirmed → In Progress
Changed in ubuntu-ui-toolkit (Ubuntu):
status: Triaged → In Progress
Changed in canonical-devices-system-image:
milestone: ww08-2016 → 11
Changed in ubuntu-ui-toolkit (Ubuntu RTM):
status: New → In Progress
importance: Undecided → High
assignee: nobody → Christian Dywan (kalikiana)
Changed in canonical-devices-system-image:
status: In Progress → Confirmed
Changed in ubuntu-ui-toolkit (Ubuntu):
status: In Progress → Fix Committed
Changed in canonical-devices-system-image:
status: Confirmed → In Progress
Revision history for this message
Łukasz Zemczak (sil2100) wrote :

This bug was fixed in the package ubuntu-ui-toolkit 1.3.1960+15.04.20160428.1 in https://launchpad.net/~ci-train-ppa-service/+archive/ubuntu/stable-phone-overlay

---------------

ubuntu-ui-toolkit (1.3.1960+15.04.20160428.1) vivid; urgency=medium

  [ Andrea Bernabei ]
  * Scrollbar: new visual update for pressed/hovered states plus handling of
    restricted size corner cases (shrinking etc). Fixes LP: #1573355

  [ Christian Dywan ]
  * Run pep8 as part of 'make check' unit test runs. The MR includes fixes to
    make pep8 pass on Jenkins as well as a regression in the test method
    introduced by the previous, larger pep8-related reformattings.
    Fixes LP: #1454322, LP: #1572981.
  * Use gu in expected position for test_popover_follows_pointerTarget.
    Fixes LP: #1569794.
  * XML test results all may not start with test_tst_. Fixes LP: #1573629
  * Handle keyNavigationFocus in InputHandler. Fixes LP: #1522739

  [ Zsombor Egri ]
  * Fix binding loops in AbstractButton. Fixes LP: #1553090

  [ Gerry Boland ]
  * Enable dynamic changing of grid units instigated by the shell. Fixes LP: #1573532

  [ Tim Peeters ]
  * Fix horizontal keyboard navigation in ListView. Fixes LP: #1572991
  * Sections keyboard and focus handling. Fixes LP: #1523840
  * Fix header screen orientation detection. Fixes LP: #1574663

  [ CI Train Bot ]
  * No-change rebuild.

 -- Zoltan Balogh <email address hidden> Thu, 28 Apr 2016 11:27:10 +0000

Changed in ubuntu-ui-toolkit (Ubuntu RTM):
status: In Progress → Fix Released
Changed in canonical-devices-system-image:
status: In Progress → Fix Committed
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntu-ui-toolkit - 1.3.1984+16.10.20160527.2

---------------
ubuntu-ui-toolkit (1.3.1984+16.10.20160527.2) yakkety; urgency=medium

  [ Christian Dywan ]
  * Slimmer frame for TextFields: 0.5dp. Fixes LP: #1578190.

  [ Albert Astals Cid ]
  * Add override
    The override specifier (since C++11) specifies that a virtual function
    overrides another virtual function. In a member function declaration or
    definition, override ensures that the function is virtual and is overriding
    a virtual function from the base class.

  [ Tim Peeters ]
  * Fix reference error in PullToRefreshStyle. Fixes LP: #1582843
  * Mark Tab, Tabs, TabBar, PageHeadConfiguration, PageHeadSections,
    PageHeadState, ToolbarButton, ToolbarItems as deprecated in the
    documentation. Fixes LP: #1566735, LP: #1566741.

  [ CI Train Bot ]
  * Resync trunk.

 -- Zoltan Balogh <email address hidden> Fri, 27 May 2016 07:08:44 +0000

Changed in ubuntu-ui-toolkit (Ubuntu):
status: Fix Committed → Fix Released
Changed in canonical-devices-system-image:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related blueprints