"Meta object revision without matching export" in Qt Creator

Bug #1511728 reported by Josh Kelley on 2015-10-30
38
This bug affects 8 people
Affects Status Importance Assigned to Milestone
Client Developer Experience
High
Zoltan Balogh
ubuntu-ui-toolkit (Ubuntu)
High
Zsombor Egri

Bug Description

When I try to create a new Qt Quick Controls project in Qt Creator 3.5.0, after I finish the project creation wizard, I get the following errors:

Warnings while parsing QML type information of /usr/lib/x86_64-linux-gnu/qt5/qml/Ubuntu/Components:
Failed to parse "/usr/lib/x86_64-linux-gnu/qt5/qml/Ubuntu/Components/plugins.qmltypes".
Error: /usr/lib/x86_64-linux-gnu/qt5/qml/Ubuntu/Components/plugins.qmltypes:1058:39: Meta object revision without matching export.
/usr/lib/x86_64-linux-gnu/qt5/qml/Ubuntu/Components/plugins.qmltypes:1067:39: Meta object revision without matching export.
/usr/lib/x86_64-linux-gnu/qt5/qml/Ubuntu/Components/plugins.qmltypes:1085:39: Meta object revision without matching export.

Project ERROR: Unknown module(s) in QT: quick qml
Warnings while parsing QML type information of /usr/lib/x86_64-linux-gnu/qt5/qml/Ubuntu/Components:
Failed to parse "/usr/lib/x86_64-linux-gnu/qt5/qml/Ubuntu/Components/plugins.qmltypes".
Error: /usr/lib/x86_64-linux-gnu/qt5/qml/Ubuntu/Components/plugins.qmltypes:1058:39: Meta object revision without matching export.
/usr/lib/x86_64-linux-gnu/qt5/qml/Ubuntu/Components/plugins.qmltypes:1067:39: Meta object revision without matching export.
/usr/lib/x86_64-linux-gnu/qt5/qml/Ubuntu/Components/plugins.qmltypes:1085:39: Meta object revision without matching export.

As I result, the Run button in Qt Creator is grayed out with the following error: 'The .pro file "untitled.pro" could not be parsed.'

ProblemType: Bug
DistroRelease: Ubuntu 15.10
Package: qtdeclarative5-ubuntu-ui-toolkit-plugin 1.3.1627+15.10.20150908-0ubuntu1
ProcVersionSignature: Ubuntu 4.2.0-16.19-generic 4.2.3
Uname: Linux 4.2.0-16-generic x86_64
ApportVersion: 2.19.1-0ubuntu4
Architecture: amd64
CurrentDesktop: Unity
Date: Fri Oct 30 09:17:48 2015
InstallationDate: Installed on 2015-03-04 (239 days ago)
InstallationMedia: Ubuntu 14.10 "Utopic Unicorn" - Release amd64 (20141022.1)
SourcePackage: ubuntu-ui-toolkit
UpgradeStatus: Upgraded to wily on 2015-10-23 (7 days ago)

Josh Kelley (joshkel) wrote :
Adam Nickle (nicklecoder) wrote :

This bug is caused by setting `exportMetaObjectRevisions` to `[0,0]` on `Component` blocks that only have one `export` defined. Deleting the comma and the second `0` fixes this.

This change needs to be applied on lines 1058, 1067, and 1085 of the following file:

`/usr/lib/x86_64-linux-gnu/qt5/qml/Ubuntu/Components/plugins.qmltypes`

Once I made those changes, I was able to enter the design page for a new QML app with qmake without encountering a blocking popup block.

I am running a fresh install of Ubuntu 15.10 with an amd64 architecture; other architectures may need to replace the `x86_64-linux-gnu` part of the file path with something more system-appropriate.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in ubuntu-ui-toolkit (Ubuntu):
status: New → Confirmed
Changed in ubuntu-ui-toolkit (Ubuntu):
importance: Undecided → High

$ apt-show-versions qtdeclarative5-ubuntu-ui-toolkit-pluginqtdeclarative5-ubuntu-ui-toolkit-plugin:amd64/xenial 1.3.1872+16.04.20160314-0ubuntu1 uptodate

I’ve tried to change [0.1] whit [0], [1], [1.1]. Nothing change :/

Pat McGowan (pat-mcgowan) wrote :

Confirmed today on Wily install

Changed in canonical-developer-experience:
assignee: nobody → Zoltan Balogh (bzoltan)
importance: Undecided → High
status: New → Confirmed
Pat McGowan (pat-mcgowan) wrote :

Please apply the fix described here

Changed in ubuntu-ui-toolkit (Ubuntu):
assignee: nobody → Zsombor Egri (zsombi)
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers