ListItem leadingActions have odd behaviour

Bug #1501668 reported by Neil McPhail on 2015-10-01
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
ubuntu-ui-toolkit (Ubuntu)
Undecided
Unassigned

Bug Description

I _think_ this is a bug in the ListItem leadingActions implementation, but please move this if it is another component.

Krillin running default channel (Ubuntu 15.04 r25 as per most recent OTA update).

In the browser app "bookmarks" page and the clock app "alarms" page, the listed items can be dragged to the right to reveal a "trash" icon. Clicking on that icon will often just remove the icon, rather than the list item. The listed item will only be deleted if the initial right-drag was all the way to the middle of the screen.

Example:
- Open the Clock app and create a new alarm
- drag the alarm far enough to the right for the "trash" item to be visible. Release and allow to settle. The item should be in the "ready to be deleted" state
- Click the trash icon. *The icon will disappear but the item will not*.

- drag the alarm much further to the right (at least to the middle of the screen), release and allow to settle. Once again, it will be in the "ready to be deleted" state and will be visually identical to the above
- Click the trash icon. *The icon and the item will be deleted, which is correct behaviour*.

As this affects more than one app, I think the bug is likely to be in the component rather than the app.

Neil McPhail (njmcphail) wrote :

This may be a duplicate of https://bugs.launchpad.net/ubuntu/+source/ubuntu-ui-toolkit/+bug/1486008 , but I am not sure if it is the same problem.

Ajinkya Dahale (ajinkyadahale) wrote :

Can confirm on VegetaHD running default stable (rc5). Said behavior occurs in alarms and history items in Browser. I cannot remove the start.ubuntu.com bookmark, but that might be by design. It behaves normally in the notes list in Notes, and also in the queue in Music, however with a slight artifact of the song's name lingering for a little while longer.

Neil McPhail (njmcphail) wrote :

This seems to be fixed with OTA-7

Changed in ubuntu-ui-toolkit (Ubuntu):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers