ListItem's selectedChanged signal is emitted when the selection hasn't changed

Bug #1493880 reported by Michael Sheldon on 2015-09-09
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
ubuntu-ui-toolkit (Ubuntu)
Medium
Zsombor Egri

Bug Description

Steps to reproduce:

1) Run the following QML:

import QtQuick 2.4
import Ubuntu.Components 1.3

MainView {
    Page {
        ListView {
            anchors.fill: parent
            model: 5
            delegate: ListItem {
                onSelectedChanged: {
                    console.log("Selected changed for index: " + index + " to: " + selected)
                }
                Label {
                    anchors.centerIn: parent
                    text: index
                }
                Component.onCompleted: {
                    selectMode = true
                }
            }
        }
    }
}

2) Select item 4

Expected outcome:

 Terminal should display:

qml: Selected changed for index: 4 to: true

Actual outcome:

 Terminal actually displays:

qml: Selected changed for index: 0 to: false
qml: Selected changed for index: 1 to: false
qml: Selected changed for index: 2 to: false
qml: Selected changed for index: 3 to: false
qml: Selected changed for index: 4 to: true

Items 0 - 3 haven't changed so shouldn't have their selectedChange signal emitted when item 4 changes.

Related branches

Zsombor Egri (zsombi) on 2015-10-01
Changed in ubuntu-ui-toolkit (Ubuntu):
assignee: nobody → Zsombor Egri (zsombi)
importance: Undecided → Medium
status: New → Confirmed
status: Confirmed → In Progress
Launchpad Janitor (janitor) wrote :
Download full text (7.7 KiB)

This bug was fixed in the package ubuntu-ui-toolkit - 1.3.1761+16.04.20151216.1-0ubuntu1

---------------
ubuntu-ui-toolkit (1.3.1761+16.04.20151216.1-0ubuntu1) xenial; urgency=medium

  [ Zoltán Balogh ]
  * Drop dependency on qtc plugin script and wait for the shell with a local
    function.

  [ Christian Dywan ]
  * runtest.sh needs to add subdirs to the libpath. Fixes: LP: #1524710.
  * Explicit click/ touch threshold beyond handler.
  * Enter/Return/Space should trigger() Button. Fixes: LP: #1523794.
  * Only set ppmm in SwipeArea if screen has valid dpi. Fixes: LP: #1525174.

  [ Tim Peeters ]
  * Implement header slot management for convergence:
    - Adapt the number of action slots to the width of the view.
    - When a new action appears, show a quick fade-in.
    - Reverse the order of the actions in the header.
    - Update icon width to 4GU. Fixes: LP: #1428757.
  * To prevent an invalid sectionIndex, reset the value of sectionIndex to -1
    when the model of Sections is changed. Fixes: LP: #1513933.

  [ Loïc Molinari ]
  * UbuntuShape - Cleaned up includes.

  [ Albert Astals Cid ]
  * Simplify logic for emitting draggingChanged/pressedChanged
    No need for a switch that considers the possible cases, just store the
    status before and check after
    Fixes an issue in which the SwipeArea pressedChanged signal was not emitted
    if switching directly from WaitingForTouch to Recognized.
  * Fix memory leak in SwipeArea
    SwipeAreaPrivate is not deleted directly so make it part of the qobject
    hierarchy so it's auto deleted on parent destruction.

  [ Zsombor Egri ]
  * Add reset functionality to Action.shortcut property. Fixes: LP: #1518420.
  * Add contentWidth and contentHeight to Dialog so foreground can be resized.
    Fixes: LP: #1249325.
  * Fixing ListItem.selected and ListItem.selectMode bugs.
    Fixes: LP: #1493880, LP: #1493882, LP: #1514928.
  * Add private implementations to ActionItem, AbstractButton, BottomEdgeHint
    and BottomEdge. Fixes: LP: #1524234
  * Close Popups.Dialog when Esc key is pressed. Fixes LP: #1523833
  * Invoke the overridden trigger() function for Action and ActionItem
    derivates. Fixes LP: #1524234
  * Fix BottomEdge assertion when the content is committed by clicking on the
    hint. Fixes LP: #1524407

  [ CI Train Bot ]
  * No-change rebuild.

ubuntu-ui-toolkit (1.3.1742+16.04.20151209-0ubuntu1) xenial; urgency=medium

  [ Zoltán Balogh ]
  * Enable building the UITK tests in any case.
  * Remove Q_Q(UCStyledItemBase) because of unused variable warning.
  * Resolve Trusty specific compiler issue not resolving QPointer data on
    connections.
  * Use only the object name when selecting sections and labels in tests.

  [Zsombor Egri ]
  * Update BottomEdge with UI/UX agreed during the sprint. Fixes LP: #1368811.
  * BottomEdge component. Fixes LP: #1368811.
  * Remove build failure on Xenial caused by deprecated Qt functions.
  * Fix BottomEdgeHint consumes activeFocusOnPress handling. Fixes LP: #1517777
  * Migrate DirectionalDragArea from Unity8, named as SwipeArea. Original code
    (from lp:unity8) by: Daniel d'Andrada <email address hidden>.
  * Delete QQuickVi...

Read more...

Changed in ubuntu-ui-toolkit (Ubuntu):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers