hidden header allows clicking the back button while animating away

Bug #1478147 reported by Michael Zanetti on 2015-07-24
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
ubuntu-ui-toolkit (Ubuntu)
Undecided
Tim Peeters

Bug Description

Create a Page with a hidden header:

head {
  visible: false
  locked: true
}

When pushing this page to the stack, the header will hide by animating to the top. During this animation the back button can be seen and also be pressed which causes the page to be popped from the stack.

This is especially problematic when pushing a regular page (with normal header) on top of the one with the hidden header. The user can then do a double-tap on the back button and pop both pages from the stack, even though the developer explicitly restricted that by hiding the header.

Related branches

Michael Zanetti (mzanetti) wrote :

I found a workaround by adding:

backAction: Action { visible: false }

to the header configuration. This additionally gets rid of the back button. I'll leave this bug open as I still think that MouseAreas in the header should be disabled while its hiding animation is running.

Changed in ubuntu-ui-toolkit (Ubuntu):
assignee: nobody → Christian Dywan (kalikiana)
assignee: Christian Dywan (kalikiana) → nobody
Tim Peeters (tpeeters) wrote :

We disabled the header animations for now, so this bug is no longer valid.

When we re-enable the animations, we need to take care of this of course.

Tim Peeters (tpeeters) wrote :

Sorry I didn't read it properly, this is animating the header itself in or out. I'll look into it.

Changed in ubuntu-ui-toolkit (Ubuntu):
assignee: nobody → Tim Peeters (tpeeters)
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in ubuntu-ui-toolkit (Ubuntu):
status: New → Confirmed
Tim Peeters (tpeeters) wrote :

The header can contain action buttons on the right side in addition to the back button. I think we want to disable all buttons when the header is animating.

We can put a MouseArea on top of them to catch the events, or actually disable them (without making them look disabled) when the header is animating.

Tim Peeters (tpeeters) on 2015-08-05
Changed in ubuntu-ui-toolkit (Ubuntu):
status: Confirmed → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntu-ui-toolkit - 1.3.1603+15.10.20150812-0ubuntu1

---------------
ubuntu-ui-toolkit (1.3.1603+15.10.20150812-0ubuntu1) wily; urgency=medium

  [ Tim Peeters ]
  * Use grid units in Icons in the showcase gallery. Fixes LP: #1481489
  * Disable header buttons when the header is animating. Fixes LP: #1478147
  * Add ActionBar examples to the gallery.
  * Make the default MainView background plain white. Fixes LP: #1481834

  [ Zsombor Egri ]
  * Fixing swiping over active components. Fixes LP: #1479688.
  * Fixing broken BottomEdgeHint gallery page.

  [ Zoltán Balogh ]
  * Fix packaging question marks / issues. Fixes LP: #1481584

  [ Loïc Molinari ]
  * UbuntuShape - Added support drop shadow aspect support to UbuntuShapeOverlay
    Fixes LP: #1480197.
  * UbuntuShape - Removed content orientation work around.
    The shape was using a workaround to make it render correctly when the
    content orientation was not the native one. This was perfect for the
    OrientationHelper shipped with the toolkit but now that the Shell
    implements the rotation, this is not needed anymore and causes some
    rendering issues. Note that the shape will still needs to support
    correct rendering when rotated using the rotation property of the Item,
    but that is a different issue. Fixes LP: #1466656.
  * UbuntuShape - Added a DropShadow aspect. Fixes LP: #1478129.
  * Renamed ShellIcon to ProportionalShape.
  * UbuntuShape - Added an ShellIcon item. Fixes LP: #1478130

  [ Nick Dedekind ]
  * Added LiveTimer.

  [ Christian Dywan ]
  * Grab focus when Dialog is shown.
  * Set Qt.IBeamCursor on text component MouseArea's. Fixes LP: #1483823
  * Make automaticOrientation on MainView a no-op. Fixes LP: #1470258
  * Fix warnings on undefine theme.name in gallery
    examples/ubuntu-ui-toolkit-gallery/ubuntu-ui-toolkit-gallery.qml:48:
      TypeError: Cannot read property of null.

  [ Ken VanDine ]
  * Don't fail if MainView doesn't have a useDeprecatedToolbar property
    Fixes LP: #1451243

  [ CI Train Bot ]
  * Resync trunk. added: examples/ubuntu-ui-toolkit-gallery/po/uk.po

 -- CI Train Bot <email address hidden> Wed, 12 Aug 2015 17:31:20 +0000

Changed in ubuntu-ui-toolkit (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers