[UbuntuShape] Specifying a ShaderEffectSource as source is broken

Bug #1447495 reported by Loïc Molinari on 2015-04-23
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
ubuntu-ui-toolkit (Ubuntu)
High
Unassigned
Vivid
Undecided
Unassigned

Bug Description

Specifying a ShaderEffectSource as source property of an UbuntuShape is broken. The problem is that the the underlaying offscreen framebuffer is never updated and the resulting texture is transparent. That happens since Qt 5.4.

Related branches

description: updated
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntu-ui-toolkit - 1.3.1510+15.10.20150519-0ubuntu1

---------------
ubuntu-ui-toolkit (1.3.1510+15.10.20150519-0ubuntu1) wily; urgency=medium

  [ Loïc Molinari ]
  * Set QSGNode debug description on the shape-based nodes to ease renderer
    debugging. Fixes LP: #1437270
  * Ensured QSGLayer-based source textures (like ShaderEffectSource) are
    updated before rendering. Fixes LP: #1447495

  [ Tim Peeters ]
  * Update sections test program.
  * Document the correct version when Page.head.visible and Page.head.locked
    were added.
  * Revert to use the old header in trunk.
  * Introduce the new ActionBar component.
  * Restore moving property on AppHeader 1.2.

  [ Zsombor Egri ]
  * Provide versioning for theme loading. Each toolkit must be released with a
    well defined system theme version, and theme modules must have the same
    version as the toolkit. Fixes LP: #1447113
  * Fix import versions in entire UITK and examples. Move example code under
    1.3 folder. Fixes LP: #1447113
  * Separate 1.2 from 1.3 versions in all Ubuntu.Component modules.
    Fixes LP: #1447113

  [ Zoltan Balogh ]
  * Fix header CPO for 1.2 without moving attribute. Let the header CPO try
    both old and new buttons.

  [ Christian Dywan ]
  * Add version subfolder to benchmark test paths.
  * Only show handlers if text isn't empty. Fixes LP: #1450213.
  * Only print unique deprecation notes. Fixes LP: #1454281.

  [ CI Train Bot ]
  * New rebuild forced.

 -- CI Train Bot <email address hidden> Tue, 19 May 2015 10:47:09 +0000

Changed in ubuntu-ui-toolkit (Ubuntu):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers