Preview UITK version 1.3 conflicts released version 1.2

Bug #1447113 reported by Michael Hall on 2015-04-22
14
This bug affects 3 people
Affects Status Importance Assigned to Milestone
ubuntu-ui-toolkit (Ubuntu)
Critical
Zsombor Egri
Vivid
Undecided
Unassigned

Bug Description

My app uses Ubuntu.Components 1.1 and one of my Page sub-classes has it's own 'theme' property. When I upgraded my device (mako) to the latest daily release it brought in the new header styles, which introduced a new 'theme' property on Page. Because this new property is marked at FINAL, and my sub-class was trying to redfine it, my app would crash on startup.

Related branches

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in ubuntu-ui-toolkit (Ubuntu):
status: New → Confirmed
Zsombor Egri (zsombi) on 2015-04-22
Changed in ubuntu-ui-toolkit (Ubuntu):
importance: Undecided → High
assignee: nobody → Zsombor Egri (zsombi)
status: Confirmed → In Progress
Zsombor Egri (zsombi) on 2015-04-25
summary: - Page.theme property introduced in 1.2 conflicts with app properties
+ Preview UITK version 1.3 conflicts released version 1.2
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntu-ui-toolkit - 1.3.1510+15.10.20150519-0ubuntu1

---------------
ubuntu-ui-toolkit (1.3.1510+15.10.20150519-0ubuntu1) wily; urgency=medium

  [ Loïc Molinari ]
  * Set QSGNode debug description on the shape-based nodes to ease renderer
    debugging. Fixes LP: #1437270
  * Ensured QSGLayer-based source textures (like ShaderEffectSource) are
    updated before rendering. Fixes LP: #1447495

  [ Tim Peeters ]
  * Update sections test program.
  * Document the correct version when Page.head.visible and Page.head.locked
    were added.
  * Revert to use the old header in trunk.
  * Introduce the new ActionBar component.
  * Restore moving property on AppHeader 1.2.

  [ Zsombor Egri ]
  * Provide versioning for theme loading. Each toolkit must be released with a
    well defined system theme version, and theme modules must have the same
    version as the toolkit. Fixes LP: #1447113
  * Fix import versions in entire UITK and examples. Move example code under
    1.3 folder. Fixes LP: #1447113
  * Separate 1.2 from 1.3 versions in all Ubuntu.Component modules.
    Fixes LP: #1447113

  [ Zoltan Balogh ]
  * Fix header CPO for 1.2 without moving attribute. Let the header CPO try
    both old and new buttons.

  [ Christian Dywan ]
  * Add version subfolder to benchmark test paths.
  * Only show handlers if text isn't empty. Fixes LP: #1450213.
  * Only print unique deprecation notes. Fixes LP: #1454281.

  [ CI Train Bot ]
  * New rebuild forced.

 -- CI Train Bot <email address hidden> Tue, 19 May 2015 10:47:09 +0000

Changed in ubuntu-ui-toolkit (Ubuntu):
status: In Progress → Fix Released
Zoltan Balogh (bzoltan) on 2015-05-20
Changed in ubuntu-ui-toolkit (Ubuntu):
importance: High → Critical
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers