Text cursor/selection handles too small and confusing

Bug #1407723 reported by Michał Sawicz on 2015-01-05
18
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Canonical System Image
High
Zoltan Balogh
ubuntu-ui-toolkit (Ubuntu)
High
Christian Dywan

Bug Description

It is still very difficult to reliably select text in text fields and areas, the handles are tiny and even if you manage to target them, you'll cover the text you operate on with your finger.

It is also very difficult to distinguish between moving the cursor and selecting text.

ProblemType: Bug
DistroRelease: Ubuntu 15.04
Package: qtdeclarative5-ubuntu-ui-toolkit-plugin 1.1.1364+15.04.20141209-0ubuntu2
Uname: Linux 3.4.67 armv7l
ApportVersion: 2.15-0ubuntu3
Architecture: armhf
Date: Mon Jan 5 16:25:22 2015
InstallationDate: Installed on 2014-12-18 (18 days ago)
InstallationMedia: Ubuntu Vivid Vervet (development branch) - armhf (20141218-020204)
SourcePackage: ubuntu-ui-toolkit
UpgradeStatus: No upgrade log present (probably fresh install)

Related branches

Michał Sawicz (saviq) wrote :
Zsombor Egri (zsombi) on 2015-01-09
Changed in ubuntu-ui-toolkit (Ubuntu):
status: New → In Progress
importance: Undecided → High
assignee: nobody → Christian Dywan (kalikiana)
Pat McGowan (pat-mcgowan) wrote :

if you get a fix we could land this milestone

Changed in canonical-devices-system-image:
importance: Undecided → High
milestone: none → ww05-2015
status: New → Confirmed
Zsombor Egri (zsombi) on 2015-01-23
Changed in ubuntu-ui-toolkit (Ubuntu RTM):
assignee: nobody → Christian Dywan (kalikiana)
importance: Undecided → High
status: New → Confirmed
Changed in ubuntu-ui-toolkit (Ubuntu RTM):
status: Confirmed → In Progress
Changed in canonical-devices-system-image:
status: Confirmed → In Progress
Changed in canonical-devices-system-image:
milestone: ww05-2015 → ww07-2015
Jouni Helminen (jounihelminen) wrote :

We have reworked the design to address the issues. Linked design below shows the new position (below text) and size of the handles. The image also shows desired touch area in transparent red (the red touch area should only be visualised on the test branch for testing purposes, normally should be invisible)

https://www.dropbox.com/sh/hn3cchu7npzd4pd/AAB1Jm716xKSq2ZUmx9BVwlva?dl=0

Changed in canonical-devices-system-image:
assignee: nobody → Zoltan Balogh (bzoltan)
milestone: ww07-2015 → ww09-2015
Changed in canonical-devices-system-image:
milestone: ww09-2015 → ww13-2015
Changed in ubuntu-ui-toolkit (Ubuntu):
status: In Progress → Fix Committed
Changed in ubuntu-ui-toolkit (Ubuntu RTM):
status: In Progress → Confirmed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntu-ui-toolkit - 1.2.1450+15.04.20150318-0ubuntu1

---------------
ubuntu-ui-toolkit (1.2.1450+15.04.20150318-0ubuntu1) vivid; urgency=medium

  [ Timo Jyrinki ]
  * Clean QML cache after updating package, before reboot. LP: #1431228

  [ Zoltán Balogh ]
  * Improved test plan script. Fixes LP: #1430201

  [ Christian Dywan ]
  * New text handler visuals and improved behavior.
    Fixes LP: #1391335, LP: #1407723, LP: #1415548
  * Split off test verification and run it once only for 'make check'.
    Fixes LP: #1431698
  * Tweak assert_discard_popover to work better with textfield in header.
    Fixes LP: #1432611

  [ Tim Peeters ]
  * Make the filenames for header and navigation tests consistent and
    split up the big tabbed header.qml into multiple smaller test files.
    Fixes LP: #1429838

  [ Loïc Molinari ]
  * Optimized Slider and ProgressBar components. Switched to the native
    UbuntuShapeOverlay instead of PartialColorizeUbuntuShape to render
    the progression in the Slider and ProgressBar components. The
    rendering is now faster since it removes an FBO indirection and
    enables batching by the QtQtuick renderer.
    Fixes LP: #1398370, LP: #1427169
  * Added a dedicated overlay shape. Made use of the new UbuntuShape
    architecture to create an extended shape with efficient overlay
    rendering. Fixes LP: #1396170
  * Removed misleading statement from UbuntuShape documentation.
    Fixes LP: #1430198
  * Renamed the overlayGeometry property to overlayRect. The
    overlayGeometry being of type QRect, using overlayRect instead
    makes it more precise, less generic. Fixes LP: #1430278
  * Converted sourceOpacity from float to qreal. Respect the same
    guideline QtQuick items use to expose floating-point properties.
    That doesn't break the QML API since there's no precision loss
    from single to double precision, the cast is implicit.
    Fixes LP: #1430267
  * Fixed embedded QML code snippets indentation. Fixes LP: #1430274

  [ Florian Boucault ]
  * CheckBox: apply clipping to the Ubuntu shape and not to the CheckBox
    itself so that the tick never overflows. Fixes LP: #1430191

  [ Daniel Holbach ]
  * A number of links changed on design.ubuntu.com - let's make sure
    they're fixed in our docs. Fixes LP: #1428051

  [ CI Train Bot ]
  * New rebuild forced.
 -- CI Train Bot <email address hidden> Wed, 18 Mar 2015 12:23:35 +0000

Changed in ubuntu-ui-toolkit (Ubuntu):
status: Fix Committed → Fix Released
Changed in canonical-devices-system-image:
status: In Progress → Fix Released
no longer affects: ubuntu-ui-toolkit (Ubuntu RTM)
no longer affects: ubuntu-ui-toolkit (Ubuntu Vivid)
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers