[UbuntuShape] Add support for rectangle overlay

Bug #1396170 reported by Loïc Molinari on 2014-11-25
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Canonical System Image
High
Zoltan Balogh
ubuntu-ui-toolkit (Ubuntu)
High
Loïc Molinari
Vivid
Undecided
Unassigned
ubuntu-ui-toolkit (Ubuntu RTM)
Undecided
Unassigned

Bug Description

The Unity shell and other apps require a shaped rectangle overlay blended over an image. This is currently implement with a 2-pass solution that is neither efficient, nor flexible. It would be good to have that implemented efficiently in the toolkit.

Related branches

Pat McGowan (pat-mcgowan) wrote :

Need this to support bug #1330959

Changed in canonical-devices-system-image:
importance: Undecided → High
milestone: none → ww03-2015
status: New → Confirmed
Changed in canonical-devices-system-image:
milestone: ww03-2015 → ww05-2015
Changed in canonical-devices-system-image:
milestone: ww05-2015 → ww07-2015
Changed in canonical-devices-system-image:
milestone: ww07-2015 → ww11-2015
Changed in canonical-devices-system-image:
status: Confirmed → In Progress
milestone: ww11-2015 → ww13-2015
assignee: nobody → Zoltan Balogh (bzoltan)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntu-ui-toolkit - 1.2.1450+15.04.20150318-0ubuntu1

---------------
ubuntu-ui-toolkit (1.2.1450+15.04.20150318-0ubuntu1) vivid; urgency=medium

  [ Timo Jyrinki ]
  * Clean QML cache after updating package, before reboot. LP: #1431228

  [ Zoltán Balogh ]
  * Improved test plan script. Fixes LP: #1430201

  [ Christian Dywan ]
  * New text handler visuals and improved behavior.
    Fixes LP: #1391335, LP: #1407723, LP: #1415548
  * Split off test verification and run it once only for 'make check'.
    Fixes LP: #1431698
  * Tweak assert_discard_popover to work better with textfield in header.
    Fixes LP: #1432611

  [ Tim Peeters ]
  * Make the filenames for header and navigation tests consistent and
    split up the big tabbed header.qml into multiple smaller test files.
    Fixes LP: #1429838

  [ Loïc Molinari ]
  * Optimized Slider and ProgressBar components. Switched to the native
    UbuntuShapeOverlay instead of PartialColorizeUbuntuShape to render
    the progression in the Slider and ProgressBar components. The
    rendering is now faster since it removes an FBO indirection and
    enables batching by the QtQtuick renderer.
    Fixes LP: #1398370, LP: #1427169
  * Added a dedicated overlay shape. Made use of the new UbuntuShape
    architecture to create an extended shape with efficient overlay
    rendering. Fixes LP: #1396170
  * Removed misleading statement from UbuntuShape documentation.
    Fixes LP: #1430198
  * Renamed the overlayGeometry property to overlayRect. The
    overlayGeometry being of type QRect, using overlayRect instead
    makes it more precise, less generic. Fixes LP: #1430278
  * Converted sourceOpacity from float to qreal. Respect the same
    guideline QtQuick items use to expose floating-point properties.
    That doesn't break the QML API since there's no precision loss
    from single to double precision, the cast is implicit.
    Fixes LP: #1430267
  * Fixed embedded QML code snippets indentation. Fixes LP: #1430274

  [ Florian Boucault ]
  * CheckBox: apply clipping to the Ubuntu shape and not to the CheckBox
    itself so that the tick never overflows. Fixes LP: #1430191

  [ Daniel Holbach ]
  * A number of links changed on design.ubuntu.com - let's make sure
    they're fixed in our docs. Fixes LP: #1428051

  [ CI Train Bot ]
  * New rebuild forced.
 -- CI Train Bot <email address hidden> Wed, 18 Mar 2015 12:23:35 +0000

Changed in ubuntu-ui-toolkit (Ubuntu):
status: In Progress → Fix Released
Changed in canonical-devices-system-image:
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers