Setting i18n.domain breaks translation

Bug #1322630 reported by Michał Sawicz on 2014-05-23
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Ubuntu UI Toolkit
Fix Released
Critical
Christian Dywan
ubuntu-ui-toolkit (Ubuntu)
Undecided
Unassigned
Vivid
Undecided
Unassigned

Bug Description

Given a file:

import QtQuick 2.0
import Ubuntu.Components 0.1

Item {
    Component.onCompleted: {
        //i18n.domain = "unity8";
        console.debug(i18n.tr("Search"), "vs.", i18n.dtr("unity8", "Search"));
    }
}

The output is (provided you have unity8 installed):
$ LANG=pl_PL.UTF-8 qmlscene test.qml
Search vs. Szukaj

But if you uncomment the commented line:
$ LANG=pl_PL.UTF-8 qmlscene test.qml
Search vs. Search

This, more or less, means that translations are broken in the current Ubuntu SDK...

ProblemType: Bug
DistroRelease: Ubuntu 14.10
Package: qtdeclarative5-ubuntu-ui-toolkit-plugin 0.1.46+14.10.20140520-0ubuntu1
ProcVersionSignature: Ubuntu 3.15.0-1.5-generic 3.15.0-rc5
Uname: Linux 3.15.0-1-generic x86_64
NonfreeKernelModules: nvidia wl
ApportVersion: 2.14.2-0ubuntu4
Architecture: amd64
CurrentDesktop: Unity
Date: Fri May 23 15:45:09 2014
SourcePackage: ubuntu-ui-toolkit
UpgradeStatus: No upgrade log present (probably fresh install)

Related branches

Michał Sawicz (saviq) wrote :
David Planella (dpm) on 2014-05-23
tags: added: touch-cn
Tim Peeters (tpeeters) wrote :

My guess is that it broke here:

http://bazaar.launchpad.net/~ubuntu-sdk-team/ubuntu-ui-toolkit/staging/revision/1053

so the fix for click apps made it not work for unity8.

Changed in ubuntu-ui-toolkit:
assignee: nobody → Christian Dywan (kalikiana)
importance: Undecided → Critical
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in ubuntu-ui-toolkit (Ubuntu):
status: New → Confirmed
Changed in ubuntu-ui-toolkit:
status: New → Confirmed
Christian Dywan (kalikiana) wrote :

It looks as though setting the domain (or having MainView do that by default) breaks dtr for that domain *unless* APP_DIR=/usr is set. Apologies for not seeing it before, as the scopes are not affected so I only now realized "search" comes from a different domain.

Christian Dywan (kalikiana) wrote :
Changed in ubuntu-ui-toolkit:
status: Confirmed → In Progress
PS Jenkins bot (ps-jenkins) wrote :

Fix committed into lp:~ubuntu-sdk-team/ubuntu-ui-toolkit/staging at revision 1081, scheduled for release in ubuntu-ui-toolkit, milestone Unknown

Changed in ubuntu-ui-toolkit:
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntu-ui-toolkit - 0.1.46+14.10.20140602-0ubuntu1

---------------
ubuntu-ui-toolkit (0.1.46+14.10.20140602-0ubuntu1) utopic; urgency=low

  [ Tarmac ]
  * [ Christian Dywan ]   * Tweak API parsing to include the Button.font
    property.      (LP: #1322169, #1322630, #1317881)

  [ Zoltán Balogh ]
  * [ Christian Dywan ]   * Tweak API parsing to include the Button.font
    property.      (LP: #1322169, #1322630, #1317881)
 -- Ubuntu daily release <email address hidden> Mon, 02 Jun 2014 11:33:42 +0000

Changed in ubuntu-ui-toolkit (Ubuntu):
status: Confirmed → Fix Released
David Planella (dpm) on 2014-06-27
Changed in ubuntu-ui-toolkit:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers