Toolbar and tabbar must be active when an application is resumed

Bug #1246790 reported by Tim Peeters on 2013-10-31
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Ubuntu UI Toolkit
Fix Released
High
Tim Peeters
Ubuntu UX
Undecided
Vesa Rautiainen
webbrowser-app
Fix Released
Undecided
Unassigned
ubuntu-ui-toolkit (Ubuntu)
Undecided
Tim Peeters

Bug Description

From this MR https://code.launchpad.net/~tpeeters/ubuntu-ui-toolkit/toolbar-tabs-deactivate/+merge/186065 :

> Re-launching an application: tabs should be expanded and toolbar open
> - When opening an application that is in recent application category
> (stopped/suspended) toolbar is not shown and tabs are not expanded.
> - This causes inconsistency between different app launches.
> - So every time the app is launched/opened toolbar should be in open state and
> tabs in expanded state. In place. No animation. No animation because it would
> be too intrusive when going through app stack with right edge swipe.

Currently tab/toolbar are open by default when the app is first launched, not when it is resumed after being suspended.

Perhaps the above behavior can be accomplished by reacting to changes in Application.active.

Related branches

Tim Peeters (tpeeters) on 2013-10-31
Changed in ubuntu-ui-toolkit:
importance: Undecided → Medium
assignee: nobody → Tim Peeters (tpeeters)
tags: added: toolbar
tags: added: tabs
Tim Peeters (tpeeters) on 2013-11-22
Changed in ubuntu-ui-toolkit:
status: New → Won't Fix
status: Won't Fix → Confirmed
Tim Peeters (tpeeters) on 2013-11-25
Changed in ubuntu-ui-toolkit:
importance: Medium → High
Tim Peeters (tpeeters) on 2013-12-02
Changed in ubuntu-ui-toolkit:
status: Confirmed → In Progress
Tim Peeters (tpeeters) wrote :

I am working on this feature in UITK for apps that use a MainView.

webbrowser-app is a special case with a special toolbar (address bar), which uses Panel, and it will not be affected by my changes in UITK, so it will need a separate solution.

PS Jenkins bot (ps-jenkins) wrote :

Fix committed into lp:ubuntu-ui-toolkit at revision None, scheduled for release in ubuntu-ui-toolkit, milestone Unknown

Changed in ubuntu-ui-toolkit:
status: In Progress → Fix Committed
Tim Peeters (tpeeters) on 2013-12-06
Changed in ubuntu-ui-toolkit (Ubuntu):
status: New → Fix Committed
assignee: nobody → Tim Peeters (tpeeters)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntu-ui-toolkit - 0.1.46+14.04.20131216-0ubuntu1

---------------
ubuntu-ui-toolkit (0.1.46+14.04.20131216-0ubuntu1) trusty; urgency=low

  [ Zsombor Egri ]
  * Layouting fails with Qt5.2 if the tests and components are not
    rendered upon testing. Layout unit tests have been transferred to
    X11 unit tests and tests on layout changes all wait till the layout
    change completes. Tested with Qt 5.0.2 and Qt 5.2 RC1. (LP:
    #1256235)
  * Picker visuals facelift, prepared for Date- and TimePicker
    components.
  * Picker selectedIndex miss-behavior fix when model is
    cleared/cropped/reset.

  [ Florian Boucault ]
  * List item progression: use appropriate icon (same as Tabs' arrow)
    and fixes the issue of it being the wrong color in Dark and Gradient
    themes. (LP: #1236777)

  [ Albert Astals ]
  * tst_arguments: Do not use QTEST_MAIN QTEST_MAIN is 99.99% of the
    times what you want when running a Qt testcase but it creates a
    Q*Application and in this case that is not wanted since we are
    creating and destroying them as part of the test and Qt doesn't like
    when there's more than one Q*Application at the same time, so do
    without creating a Q*Application in main. This can of course have
    some implications but it seems that for this testcase all is fine.
    (LP: #1254747)
  * Make the model a var and not a ListModel ListModel is bound
    specifically to QQuickListModel By using a var we can use other
    QAbstractItemModel subclasses in the model.

  [ Nic ]
  * Removed stop animation on text every time an expansion/collapse is
    made. Fixes bug #1231939. (LP: #1231939)
  * Fixed scrolling in selector when parent widget's height is less than
    the selector's ListView height. Fixes bug #1256356. (LP: #1256356)

  [ Timo Jyrinki ]
  * Require either Qt 5.2 or libqt5v8-5-private-dev.

  [ tpeeters ]
  * Reset hide timer when user interacts with toolbar or toolbar
    buttons. (LP: #1249031)
  * Improve detection of tab bar interaction. Now using the new
    TabBar.pressed property instead of TabBar.selectionMode property,
    because selectionMode may be changed without user interaction (for
    example, when resuming an app in a following MR), and then the
    toolbar should not automatically hide.
  * Open the toolbar and tabbar (without animating) when the app is
    resumed. (LP: #1246790)

  [ Christian Dywan ]
  * Accept qmldir files in qmlapicheck and skip internal components.
    (LP: #1256045)
  * Suppress qdoc warnings coming from upstream API.
  * Conditionally define doc folder containing resources. (LP: #1256779)
  * Move doc commands to shellscript and add success output lines.
  * Use Eventually when checking that the textfield is empty There's
    always a delay so we can't just compare it. (LP: #1259476)

  [ Ubuntu daily release ]
  * Automatic snapshot from revision 892
 -- Ubuntu daily release <email address hidden> Mon, 16 Dec 2013 08:17:31 +0000

Changed in ubuntu-ui-toolkit (Ubuntu):
status: Fix Committed → Fix Released
Tim Peeters (tpeeters) on 2014-03-09
Changed in ubuntu-ui-toolkit:
status: Fix Committed → Fix Released
Vesa Rautiainen (vesar) on 2014-04-03
Changed in ubuntu-ux:
assignee: nobody → Vesa Rautiainen (vesar)
Bill Filler (bfiller) on 2014-05-29
Changed in ubuntu-ux:
status: New → Fix Released
Changed in webbrowser-app:
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related blueprints