HUD ($APP_ID) errors printed on console

Bug #1234339 reported by dobey on 2013-10-02
20
This bug affects 4 people
Affects Status Importance Assigned to Milestone
Ubuntu UI Toolkit
Fix Released
Undecided
Zsombor Egri
Unity Action API
Undecided
Unassigned
ubuntu-ui-toolkit (Ubuntu)
Undecided
Zsombor Egri

Bug Description

Simply running and exiting the system-settings app, results in the following errors/warnings printed to the console:

unity::action::ActionManager::ActionManager(QObject*):
 Could not determine application identifier. HUD will not work properly.
 Provide your application identifier in $APP_ID environment variable.
file:///usr/lib/x86_64-linux-gnu/qt5/qml/Ubuntu/Components/ListItems/SingleControl.qml:59: Unable to assign [undefined] to bool

ProblemType: Bug
DistroRelease: Ubuntu 13.10
Package: ubuntu-system-settings 0.1+13.10.20131002-0ubuntu1
ProcVersionSignature: Ubuntu 3.11.0-11.17-generic 3.11.3
Uname: Linux 3.11.0-11-generic x86_64
ApportVersion: 2.12.5-0ubuntu1
Architecture: amd64
Date: Wed Oct 2 14:44:54 2013
InstallationDate: Installed on 2012-10-21 (345 days ago)
InstallationMedia: Ubuntu 12.10 "Quantal Quetzal" - Release amd64 (20121017.5)
MarkForUpload: True
SourcePackage: ubuntu-system-settings
SystemImageInfo: Error: [Errno 2] No such file or directory: 'system-image-cli'
UpgradeStatus: Upgraded to saucy on 2013-08-07 (55 days ago)

Related branches

dobey (dobey) wrote :
Sebastien Bacher (seb128) wrote :

Thanks, those warnings are coming from the toolkit though, reassigning there

affects: ubuntu-system-settings (Ubuntu) → ubuntu-ui-toolkit (Ubuntu)
Sebastien Bacher (seb128) wrote :

I already opened bug #1221300 about the SingleControl warning, retitling the bug about the HUD warnings

summary: - Errors printed on console
+ HUD ($APP_ID) errors printed on console
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in ubuntu-ui-toolkit (Ubuntu):
status: New → Confirmed
tags: added: logspam
Changed in ubuntu-ui-toolkit:
status: New → Confirmed
Antti Kaijanmäki (kaijanmaki) wrote :

From unity-action-api point of view, the $APP_ID must be defined for the component to work properly. Thus printing a warning when the $APP_ID is not defined is IMO exactly the right thing to do,

If UITK needs to be run under unity7 or other platform which don't define the $APP_ID then UITK should not initialize the Action API library at all on such platforms. Therefore I'm marking this as WONTFIX for unity-action-api, but I'm still open for suggestions.

Changed in unity-action-api:
status: New → Won't Fix
Zsombor Egri (zsombi) on 2014-09-16
Changed in ubuntu-ui-toolkit (Ubuntu):
assignee: nobody → Zsombor Egri (zsombi)
Changed in ubuntu-ui-toolkit:
assignee: nobody → Zsombor Egri (zsombi)
status: Confirmed → In Progress
Changed in ubuntu-ui-toolkit (Ubuntu):
status: Confirmed → In Progress
PS Jenkins bot (ps-jenkins) wrote :

Fix committed into lp:ubuntu-ui-toolkit/staging at revision None, scheduled for release in ubuntu-ui-toolkit, milestone Unknown

Changed in ubuntu-ui-toolkit:
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntu-ui-toolkit - 1.1.1262+14.10.20140922.2-0ubuntu1

---------------
ubuntu-ui-toolkit (1.1.1262+14.10.20140922.2-0ubuntu1) utopic; urgency=medium

  [ Leo Arias ]
  * Add logging to the textfield autopilot helpers Fixes LP: #1361750

  [ Zsombor Egri ]
  * Sheet header button space reservation made button presence
    dependent. Fixes: LP: #1356636
  * Tweaks for ListItem dividers. Header margins and font weight
    updated.
  * Exclude UbuntuColors dumped erroneously by qmlplugindump as it
    would be a C++ type.
  * Organizer audible reminder wasn't updated when Alarm sound
    changed.
  * Fix for a wrong Action reference
  * Removing dependency towards Unity.Action, ActionContext and
    ActionManager QML API transferred to UI Toolkit.
    Fixes LP: #1234339, LP: #1294298.
  * Fixing wrong path used in saving state file. Fixes LP: #1363112

  [ Loïc Molinari ]
  * Fixed parallel build, tests/unit_x11 had no rules.
    Fixes LP: #1367850

  [ Zoltán Balogh ]
  * Updated test plan execution for RTM images and for new phablet
    tools.
  * New test plan script

  [ Christian Dywan ]
  * Specify /sbin when calling initctl just like autopilot does.
  * Change gallery to use launcher to allow -touch argument.
  * Overflow panel button 0.5 opacity if disabled Fixes LP: #1369640
  * Open text context menu when pressing Menu key.
  * Do not open context menu when dragging.
  * Hide text input handlers while typing. Fixes LP: #1343821

  [ Albert Astals ]
  * Make the scaling provider respect requestedSizes with one of the
    values 0

  [ Leo Arias ]
  * On autopilot tests launched by upstart, use the local modules
    if running from a branch.

  [ Christian Dywan ]
  * Change gallery to use launcher to allow -touch argument.
 -- Ubuntu daily release <email address hidden> Mon, 22 Sep 2014 15:52:55 +0000

Changed in ubuntu-ui-toolkit (Ubuntu):
status: In Progress → Fix Released
Zoltan Balogh (bzoltan) on 2014-10-01
Changed in ubuntu-ui-toolkit:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers