Font size too small in browser with Qt 5.1 / DPR rework

Bug #1207270 reported by Timo Jyrinki on 2013-08-01
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
ubuntu-ui-toolkit (Ubuntu)
High
Florian Boucault

Bug Description

The font size seems too small in browser with Qt 5.1. The device pixel ratio patch was dropped and there is reportedly something new in Qt 5.1 that can be used instead.

To get Qt 5.2 on device:
See instructions _on the front page of_ https://launchpad.net/~canonical-qt5-edgers/+archive/qt5-beta2

All Qt 5.2 bugs: https://bugs.launchpad.net/bugs/+bugs?field.tag=qt5.2

Related branches

tags: added: qt5.1
description: updated
description: updated
Changed in webbrowser-app:
assignee: nobody → Florian Boucault (fboucault)
status: New → In Progress
importance: Undecided → High
Michał Sawicz (saviq) wrote :

Not a unity8 bug, then.

Changed in unity8:
status: New → Invalid
Dmitry Shachnev (mitya57) wrote :

This happens with any QML application that uses WebView, not only with webbrowser-app.

no longer affects: unity8
description: updated
Timo Jyrinki (timo-jyrinki) wrote :

Bumped importance since Qt 5.1.1 is planned to land and this is clearly a blocker.

summary: - Font size too small in browser with Qt 5.1
+ Font size too small in browser with Qt 5.1 / DPR rework
Changed in webbrowser-app:
importance: High → Critical
description: updated
Florian Boucault (fboucault) wrote :

Fixes are in:
https://code.launchpad.net/~fboucault/qtubuntu/dpr_rebase_qt_5.1/+merge/183500
https://code.launchpad.net/~fboucault/ubuntu-ui-toolkit/dpr_rebase_qt_5.1/+merge/183762

They seem to work pretty well with one exception (QML's BorderImage) for which a patch is being worked on.

affects: webbrowser-app → ubuntu-ui-toolkit
Pat McGowan (pat-mcgowan) wrote :

lower importance given 5.1 will be deferred

Changed in ubuntu-ui-toolkit:
importance: Critical → High
Changed in ubuntu-ui-toolkit:
milestone: none → february-2014
tags: added: qt5.2
removed: qt5.1
Changed in ubuntu-ui-toolkit:
importance: High → Critical

unity is all odd, occupying only a quarter of the screen, and badly cropped with these changes (from ppa:canonical-qt5-edgers/qt5-beta-proper)

http://imgur.com/tqaTLjS
http://imgur.com/4KwLmEc

Florian asked me to try again with surfaceflinger instead of mir. Here's the result.. Similarly amusing, but different.

http://imgur.com/6swNKbI
http://imgur.com/JehiX1r
http://imgur.com/B18ZwIN
http://imgur.com/pBu9F1W
http://imgur.com/b9Q0VKc
http://imgur.com/3PJd9G1

Florian Boucault (fboucault) wrote :

Issues with MIR have been identified and worked on right now.
Issues with SurfaceFlinger are unexpected and installing the .debs manually from the qt5-beta-proper PPA does not let me reproduce it. I suspect the toolkit was not installed properly.

Timo Jyrinki (timo-jyrinki) wrote :

A quick test result: looks about like Alan's surfaceflinger but this time on Mir.

Using:
apt-add-repository ppa:ci-train-ppa-service/landing-006
apt-add-repository ppa:canonical-qt5-edgers/qt5-beta1 # no typo, beta1 has only the packages that are missing from landing-006

added with
apt-add-repository ppa:canonical-qt5-edgers/qt5-beta-proper

... which has qtubuntu DPR branch bzr181 https://launchpad.net/~canonical-qt5-edgers/+archive/qt5-beta-proper/+sourcepub/3958676/+listing-archive-extra and UITK DPR branch bzr761 https://launchpad.net/~canonical-qt5-edgers/+archive/qt5-beta-proper/+sourcepub/3958707/+listing-archive-extra

So more fixes needed.

Note: if you're using qt5-beta2 PPA instead of the two mentioned above, the results should be the same. Functionally the "final" landing PPA added with qt5-beta1 is almost identical to qt5-beta2. But if you reflash your device you may want to use landing-006 + qt5-beta1 instead (and add/remove qt5-beta-proper as needed).

Florian Boucault (fboucault) wrote :

So, latest tests doing:

phablet-flash ubuntu-system --channel devel-proposed
phablet-config writable-image

Then on device:

apt-add-repository ppa:ci-train-ppa-service/landing-006
apt-add-repository ppa:canonical-qt5-edgers/qt5-beta1
apt-get update
apt-get dist-upgrade

Plus downloading and installing the 3 debs from https://launchpad.net/~canonical-qt5-edgers/+archive/qt5-beta-proper/+packages;

qtdeclarative5-ubuntu-ui-toolkit-plugin_0.1.46+14.04.20140304+dpr2-0~967+201403050848~ubuntu14.04.1+fixdpr~test2_armhf.deb
qtubuntu-android_0.53+14.04.20140228-0+201403010003~208~ubuntu14.04.1+fixdpr~test2_armhf.deb
ubuntu-ui-toolkit-theme_0.1.46+14.04.20140304+dpr2-0~967+201403050848~ubuntu14.04.1+fixdpr~test2_armhf.deb

The UI looks right but has some input issues. Working on it.

Florian Boucault (fboucault) wrote :

Input issues with MIR is now resolved thanks to a patch in lp:ubuntu-mir.

Timo Jyrinki (timo-jyrinki) wrote :

Hi! Test results with latest builds from the branches as they are curently:

Image now looks correct. However some issues remain:
- An odd graphical glitch in titles, see image
- It's hard to unlock screen, a swipe from outside of the screen does not work, instead it works when starting a little more inward from the border. See video.

Aside from those two problems, the functionality seems correct.

Instead of manually downloading deb:s, the qt5-beta-proper is made so that only those packages get updated. So:
apt-add-repository ppa:canonical-qt5-edgers/qt5-beta-proper
apt-get update
apt-get dist-upgrade
yields:
The following packages will be upgraded:
  libunity-mir1 qtdeclarative5-ubuntu-ui-toolkit-plugin qtubuntu-android ubuntu-ui-toolkit-theme
4 upgraded, 0 newly installed, 0 to remove and 1 not upgraded.
Need to get 699 kB of archives.
After this operation, 9216 B of additional disk space will be used.
Do you want to continue? [Y/n]

Get:1 http://ppa.launchpad.net/canonical-qt5-edgers/qt5-beta-proper/ubuntu/ trusty/main libunity-mir1 armhf 1:0.2+14.04.20140221.1+dpr1-0~184+201402281532~ubuntu14.04.1+dpr~test1 [120 kB]
Get:2 http://ppa.launchpad.net/canonical-qt5-edgers/qt5-beta-proper/ubuntu/ trusty/main ubuntu-ui-toolkit-theme armhf 1:0.1.46+14.04.20140304+dpr3-0~967+201403050848~ubuntu14.04.1+fixdpr~test2 [192 kB]
Get:3 http://ppa.launchpad.net/canonical-qt5-edgers/qt5-beta-proper/ubuntu/ trusty/main qtdeclarative5-ubuntu-ui-toolkit-plugin armhf 1:0.1.46+14.04.20140304+dpr3-0~967+201403050848~ubuntu14.04.1+fixdpr~test2 [277 kB]
Get:4 http://ppa.launchpad.net/canonical-qt5-edgers/qt5-beta-proper/ubuntu/ trusty/main qtubuntu-android armhf 1:0.53+14.04.20140228+dpr-0+201403010003~208~ubuntu14.04.1+fixdpr~test1 [109 kB]
Fetched 699 kB in 6s (108 kB/s)

Timo Jyrinki (timo-jyrinki) wrote :
Timo Jyrinki (timo-jyrinki) wrote :
Timo Jyrinki (timo-jyrinki) wrote :

One more note on the packages: the version numbers are meaningless, they are just mean to be a) above anything else in other PPA:s (including qt5-beta2 if someone still uses that), b) bump the upstream version number so that also orig tarball gets regenerated.

The changelogs include the information on what they actually are:
--
* Build from lp:~fboucault/qtubuntu/dpr_rebase_qt_5.1 bzr185
--
* Uploading from lp:~fboucault/ubuntu-ui-toolkit/dpr_rebase_qt_5.1 bzr763
* For this test build, also include the test fix Qt 5.2 branches too:
    - lp:~zsombi/ubuntu-ui-toolkit/datepicker-fix1287009
    - lp:~mzanetti/ubuntu-ui-toolkit/more-stable-ubuntulistview-tests
--
* Build from lp:~fboucault/unity-mir/dpr_rebase_qt_5.1 bzr187

description: updated
Tim Peeters (tpeeters) wrote :

I installed today's trusty-proposed image, and added the ppas for landing-006, qt5-beta1 and qt5-beta-proper on maguro.

I have the same problems unlocking that mirv describes above, but after I manager, the chevron was a little bit too large (old size from before the font-size changes?).

When I change the height of the chevron image in our TabBarStyle.qml from units.dp(25) (this came with one of the packages from the PPA I guess) to 0.82*sourceSize.height (which is what we currently have in UITK trunk), the chevron becomes huge as in Mirv's screenshots.

After purging the qt5-beta-proper ppa https://pastebin.canonical.com/106120/ unlocking goes fine, and the chevron size is correct (small) again.

Tim Peeters (tpeeters) wrote :

Summarizing: without qt5-beta-proper PPA chevron size is correct, with it chevron is a bit too large, and with height: 0.82*sourceSize.height for the chevron image in TabBarStyle.qml, the chevron is huge.

Timo Jyrinki (timo-jyrinki) wrote :

Ok, correction, it may've been that LP was slow to publish the "published" binaries. Now looks like attachment. So, input issue the only issue?

Tim Peeters (tpeeters) wrote :

height: units.dp(20) looks good for the chevron

Changed in ubuntu-ui-toolkit:
milestone: february-2014 → march-2014
Florian Boucault (fboucault) wrote :

Changes were made to the toolkit and qtubuntu MRs so that the new code path is only activated for the webbrowser-app and the webapps (using "webapp-container"). New packages generated from the latest revisions of these MRs should be published and tested. It is critical to remove the patched unity-mir packages for it to work properly.

Timo Jyrinki (timo-jyrinki) wrote :

I'm getting a build error with the qtubuntu bzr187:

https://launchpad.net/~canonical-qt5-edgers/+archive/qt5-beta-proper/+sourcepub/4011563/+listing-archive-extra

error: 'gridUnit' was not declared in this scope

Timo Jyrinki (timo-jyrinki) wrote :

There's the option B) from rsalveti of re-enabling DPR fix in qtwebkit. It's available in his PPA, but also with proper packaging very soon at:

ppa:canonical-qt5-edgers/qt5-beta1
https://launchpad.net/~canonical-qt5-edgers/+archive/qt5-beta1/+packages (when armhf has finished building)

I don't know how to test the issue much, but the thing I do notice that Facebook app seems correct after the upgrade and too small without the upgrade.

The benefit of that ^ recompilation is that it can be directly copied to the landing PPA if tested to be fine.

Timo Jyrinki (timo-jyrinki) wrote :

qtwebkit-opensource-src 5.2.1+dfsg-0ubuntu2 has now landed to https://launchpad.net/~ci-train-ppa-service/+archive/landing-006 - according to my and davmor2's testing it seems to fix the issue in the various webapps etc.

Pat McGowan (pat-mcgowan) wrote :

Since we have the patched qtwebkit will remove the qt5.2 tag but leave open to track the eventual fix

tags: removed: qt5.2
Zsombor Egri (zsombi) on 2014-03-31
Changed in ubuntu-ui-toolkit:
milestone: march-2014 → april-2014
Zsombor Egri (zsombi) on 2014-04-03
Changed in ubuntu-ui-toolkit:
milestone: april-2014 → june-2014
Changed in ubuntu-ui-toolkit:
importance: Critical → High
milestone: june-2014 → none
Zoltan Balogh (bzoltan) on 2014-11-24
Changed in ubuntu-ui-toolkit (Ubuntu):
assignee: nobody → Florian Boucault (fboucault)
importance: Undecided → High
status: New → In Progress
Zoltan Balogh (bzoltan) on 2014-11-24
no longer affects: ubuntu-ui-toolkit
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntu-ui-toolkit - 1.3.1627+15.10.20150908-0ubuntu1

---------------
ubuntu-ui-toolkit (1.3.1627+15.10.20150908-0ubuntu1) wily; urgency=medium

  [ Zsombor Egri ]
  * Implement list item expansion.
  * Turn AdaptivePageLayout page creation to be asynchronous.
  * Fix ListItem swipe handling when gesture is initiated over an overlay
    MouseArea which does not accept pressed event. Fixes LP: #1484545
  * AbstractButton to C++. Fixes LP: #1365471, LP: #1458028
  * Haptics singleton moved to C++.
  * ActionItem moved to C++.
  * Making columns resizable in an AdaptivePageLayout.
  * Introducing column configuration into AdaptivePageLayout.

  [ Benjamin Zeller ]
  * Fix build inside qt and shadowbuild.

  [ Tim Peeters ]
  * Remove old and unused header-related files, and update unit test filenames.
  * Don't unset the subheader style when Page.head changes because that unsets
    the parent of Page.head.contents. Fixes LP: #1488922
  * Fix the theming of the MainView.
  * Fix the background color of the overflow panel.

  [ Christian Dywan ]
  * Include change signals with arguments in .api.
  * A public QML type with no version is an error. Rather than silently breaking
    as QML does normally at least apicheck can make this fatal.
  * UbuntuShape shouldn't emit redundant deprecation warnings. Fixes LP: #1481791
  * Update .bzrignore to new upstream style layout. Fixes LP: #1433308
  * Revert unnecessary change of Popover minimumWidth. Fixes LP: #1483708

  [ Ken VanDine ]
  * Fixed a few typos in the api docs for StateSaver.

  [ Olivier Tilloy ]
  * Take custom key indexes into account to allow sorting on custom roles.
    Fixes LP: #1485674

  [ Albert Astals Cid ]
  * Properly free shapeTextures[index] The old code assumes that the UbuntuShape
    will still be around when the opengl context is destroyed, but that seldom
    happens so connect the signal to a lambda that will be there and does the
    cleanup properly. Without this patch testDirectionalDragArea from unity8 was
    hitting the qFatal because it ran out of space in shapeTextures.

  [ Richard Huddie ]
  * Remove all usage of the autopilot simulated keyboard when the OSK is being
    used. Fixes LP: 31483668

  [ Gerry Boland ]
  * Compensate for Qt's device pixel ratio multiplier.
    Fixes: LP: #1207270, LP: #1275748, LP: #1468402

  [ Nick Dedekind ]
  * Added relative date time i18n.

  [ CI Train Bot ]
  * Resync trunk.

 -- Zoltan Balogh <email address hidden> Tue, 08 Sep 2015 04:10:50 +0000

Changed in ubuntu-ui-toolkit (Ubuntu):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers