In image 195 krillin 163 mako system settings is not showing updates

Bug #1410968 reported by Dave Morley
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Telegram app
Invalid
Undecided
Unassigned
ubuntu-system-settings (Ubuntu)
Invalid
Critical
Ken VanDine
ubuntu-system-settings (Ubuntu RTM)
Fix Released
Critical
Ken VanDine
ubuntu-touch-meta (Ubuntu)
New
Critical
Unassigned
ubuntu-touch-meta (Ubuntu RTM)
New
Critical
Unassigned

Bug Description

STEPS:
Setup
1 Enable developer mode
2 from pc phablet-config writable-image
3 adb shell
4 sudo vim.tiny /etc/system-image/channel.ini
5 last 2 lines change the number to be back 10 images i.e. change the 195 to 185
6 sudo rm /userdata/.writable_image
7 rm .local/share/ubuntu-push-client/level.db
8 sudo reboot

Test
1 Wait for the announcement of a new image
2 Drag down the indicator
3 Click on the image notification
4 Setting page opens on updates but is blank

EXPECTED:
The updates page is shown and you can click on update

ACTUAL:
The header is shown other wise it is a blank page after the spinner finishes spinning.

Related branches

Revision history for this message
Dave Morley (davmor2) wrote :
Changed in ubuntu-system-settings (Ubuntu):
importance: Undecided → Critical
assignee: nobody → Ken VanDine (ken-vandine)
I Ahmad (iahmad)
Changed in ubuntu-system-settings (Ubuntu):
status: New → Confirmed
Revision history for this message
Ken VanDine (ken-vandine) wrote :

This was caused by qml-module-ubuntu-connectivity being dropped in the image. ubuntu-system-settings could add a depends for that package, but the real problem is that API is part of the framework so this breaks click packages that use it as well. For example telegram is broken now.

affects: telegram → libqtelegram
Changed in ubuntu-touch-meta (Ubuntu):
importance: Undecided → Critical
Changed in ubuntu-touch-meta (Ubuntu RTM):
importance: Undecided → Critical
Changed in ubuntu-system-settings (Ubuntu RTM):
assignee: nobody → Ken VanDine (ken-vandine)
importance: Undecided → Critical
status: New → Confirmed
Michał Sawicz (saviq)
Changed in ubuntu-system-settings (Ubuntu RTM):
status: Confirmed → In Progress
Changed in ubuntu-system-settings (Ubuntu):
status: Confirmed → In Progress
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntu-system-settings - 0.3+15.04.20150114.1~rtm-0ubuntu1

---------------
ubuntu-system-settings (0.3+15.04.20150114.1~rtm-0ubuntu1) 14.09; urgency=low

  [ Ken VanDine ]
  * Added missing depends for qml-module-ubuntu-connectivity (LP:
    #1410968)
 -- Ubuntu daily release <email address hidden> Wed, 14 Jan 2015 21:01:31 +0000

Changed in ubuntu-system-settings (Ubuntu RTM):
status: In Progress → Fix Released
Changed in ubuntu-system-settings (Ubuntu):
status: In Progress → Invalid
Changed in libqtelegram:
status: New → Invalid
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers

Bug attachments