ubuntu-sdk should depend on ubuntu-html5-theme-examples

Bug #1221919 reported by Kyle Nitzsche on 2013-09-06
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
ubuntu-touch-meta (Ubuntu)
High
Zoltan Balogh

Bug Description

ubuntu-sdk version 1.009~sdkppa~raring1~test6 does not depend on or recommend ubuntu-html5-theme-examples.

ubuntu-html5-theme-examples is the "gallery" of Ubuntu GUI HTML5 widgets. Due the lack of depends, it is hard to find, and it will be harder than necessary to explain in docs.

The gallery is a useful part of the sdk. And since it is just html examples, its footprint is small.

By contrast, the QML gallery of Ubuntu GUI is installed by ubuntu-ui-toolkit-examples, which is a direct depends of ubuntu-sdk. Since HTML5 is now a "first-class" app dev framework in Ubuntu, its dev pkgs should have analagous treatment as QML's.

Zoltan Balogh (bzoltan) on 2014-01-14
Changed in ubuntu-touch-meta (Ubuntu):
assignee: nobody → Zoltan Balogh (bzoltan)
importance: Undecided → High
status: New → Confirmed
Zoltan Balogh (bzoltan) wrote :

There are two MRs filed against the seeds:
https://code.launchpad.net/~bzoltan/ubuntu-seeds/add_html5_examples/+merge/201548
https://code.launchpad.net/~bzoltan/ubuntu-seeds/add_html5_examples/+merge/201549

The very same changes are pushed to the SDK PPA for Precise/Quantal/Raring/Saucy releases.

Changed in ubuntu-touch-meta (Ubuntu):
status: Confirmed → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntu-touch-meta - 1.103

---------------
ubuntu-touch-meta (1.103) trusty; urgency=medium

  * Refreshed dependencies
  * Added ubuntu-html5-container to sdk-libs (LP: #1268699)
  * Added ubuntu-html5-theme-examples to sdk-libs (LP: #1221919)
 -- Martin Pitt <email address hidden> Wed, 15 Jan 2014 12:24:46 +0100

Changed in ubuntu-touch-meta (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers