Emojis are not shown in ubuntu applications (and phone)

Bug #1137630 reported by Francesco Fumanti
80
This bug affects 17 people
Affects Status Importance Assigned to Milestone
ttf-ancient-fonts (Ubuntu)
High
Renato Araujo Oliveira Filho
ubuntu-meta (Ubuntu)
Medium
Marco Trevisan (Treviño)
ubuntu-touch-meta (Ubuntu)
Undecided
Unassigned

Bug Description

Hi,

As Ubuntu is being ported to tablets and phones, where communication is an important aspect of their fonctionality, I would like to ask whether it would be possible to add the glyphs of the emojis and other symbols, which have been defined in Unicode 6.0 and 6.1 to the Ubuntu font.

If I am correct, the emoticons/emojis are code in Unicode from U+1F600 bis U+1F64F.

However, other symbols like broken heart and others might also be interesting, for example: U+1F493 - U+1F493, U+1F4A1 - U+1F4A6, U+2639 - U+2642,...

For those interested, these glyphs are currently included in the fonts-vlgothic package in the Ubuntu repositories.

Cheers

Related branches

summary: - RFC: Emojis would be particularly useful for ubuntu-nexus and phone
+ RFE: Emojis would be useful for ubuntu-nexus and phone
Revision history for this message
Francesco Fumanti (frafu) wrote : Re: RFE: Emojis would be useful for ubuntu-nexus and phone

According to fileformat.info, part of the emoji emoticons are supported in the DejaVu Sans font and the Symbola and LastResort fonts support all the 76 emoticons of the Emoticons Unicode Block.
http://www.fileformat.info/info/unicode/block/emoticons/fontsupport.htm

On Ubuntu, the Symbola font is part of the ttf-ancient-fonts package:
http://packages.ubuntu.com/raring/all/ttf-ancient-fonts/filelist

Revision history for this message
Alessandro Polverini (polve) wrote :

Now that tablet are very popular the use of emoj is encreasing and I was not able to handle those symbols on my ubuntu box.

Fortunately the problem is easily solved installing the public domain font "symbola" as described here:
http://www.kirsle.net/blog/kirsle/make-emoji-work-in-linux

You can download the full package here: http://users.teilar.gr/~g1951d/Symbola708.zip but I attach the font in case the site goes down.

I would ask to include that font in ubuntu by default!

Revision history for this message
cm-t 🦄🏂🌈🎵 (cm-t) wrote :

Hi,

I added this bug #1340598 at the ubuntu-keyboard : User should be able to select an emoji trhought a keyboard layout.

This ubuntu-font bug might be a blocker to the end user: Can't see the emoji he select on the keyboard. The user will aslo not be able to see any emoji anywhere until the system font (ubuntu-font) does not support emoji.

It is not a critical bug, but a user might see this as a regression when adopting ubuntu as OS (phone for example).

Librement

Revision history for this message
Denis Moyogo Jacquerye (moyogo) wrote : Re: [Bug 1137630] Re: RFE: Emojis would be useful for ubuntu-nexus and phone

On Fri, Jul 11, 2014 at 10:53 AM, cm-t arudy <email address hidden> wrote:

> Hi,
>
> I added this bug #1340598 at the ubuntu-keyboard : User should be able
> to select an emoji trhought a keyboard layout.
>
> This ubuntu-font bug might be a blocker to the end user: Can't see the
> emoji he select on the keyboard. The user will aslo not be able to see
> any emoji anywhere until the system font (ubuntu-font) does not support
> emoji.
>

That is what fallback fonts are for. If some Unicode characters do not have
glyphs in a the system font, then a font with glyphs for them is used a
fallback.
Of course the font can have those glyphs, but it doesn’t need to for users
to be able to use emojis. This is not a blocker as long as fallback fonts
are available.

--
Denis Moyogo Jacquerye

summary: - RFE: Emojis would be useful for ubuntu-nexus and phone
+ Emojis are not shown in ubuntu applications (and phone)
Changed in messaging-app:
importance: Undecided → Medium
Revision history for this message
Marco Trevisan (Treviño) (3v1n0) wrote :

In order to fix this in both ubuntu desktop and touch, the only needed thing is to get add the Symbola font from http://users.teilar.gr/~g1951d/Symbola.zip inside ~/.fonts or /usr/share/fonts (I personally tested this also in messaging-app and some webapps).

A version (an outdated one, actually) of the Symbola.ttf is currently shipped in ubuntu in the ttf-ancient-fonts package, that contains a lot of extra things, making the deb quite heavy.
So I think that the package should be probably split in order to make us being able to ship it in the phone (where I think is probably more important) and the desktop.

Revision history for this message
Adolfo Jayme (fitojb) wrote :

As I’ve mentioned over bug 1269017, comment 10:
_______
It’s not mandatory to use specifically the Symbola font. You could also package and use the Noto Color Emoji free font, as Firefox OS has done. [1][2] (FreeType supports that color font... unless Ubuntu Phone doesn’t use FreeType, of course.)

[1]: https://github.com/mozilla-b2g/moztt/commit/2372e891b10ff9a7382bbb4fbcd439a75cebd206
[2]: http://bugzil.la/939280

Revision history for this message
John McAleely (john.mcaleely) wrote :

This impacts save message display on krillin (see dupe)

tags: added: rtm14
Revision history for this message
Sebastien Bacher (seb128) wrote :

duplicate of bug #1269017?

Revision history for this message
Marco Trevisan (Treviño) (3v1n0) wrote :

I'd wait to set this as a duplicate (at least for all ubuntu) to bug #1269017, as that is more related to the messaging-app, which might fix this issue by its own (by showing images for example, or using a font color such as Noto).

This bug is more related to the whole ubuntu ecosystem to support showing Emoji's properly (and this affects for example browsers, webapps or any other system app).

no longer affects: messaging-app
Changed in ttf-ancient-fonts (Ubuntu):
assignee: nobody → Renato Araujo Oliveira Filho (renatofilho)
importance: Undecided → High
status: New → In Progress
Changed in ubuntu-meta (Ubuntu):
importance: Undecided → Medium
status: New → Triaged
Changed in ubuntu-meta (Ubuntu):
assignee: nobody → Marco Trevisan (Treviño) (3v1n0)
status: Triaged → In Progress
Changed in ttf-ancient-fonts (Ubuntu):
status: In Progress → Fix Released
Changed in ubuntu-meta (Ubuntu):
status: In Progress → Fix Released
Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Revision history for this message
Matthew Paul Thomas (mpt) wrote :

Adding Emoji to the Ubuntu font is bug 820034. That isn't necessarily a good idea. However, the problem of "Emojis are not shown in Ubuntu … phone” could be solved in many other ways -- for example, by shipping Symbola or Noto. So this belongs, at least, to ubuntu-touch-meta.

affects: ubuntu-font-family → ubuntu-touch-meta (Ubuntu)
Changed in ubuntu-touch-meta (Ubuntu):
status: New → Confirmed
Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in ubuntu-touch-meta (Ubuntu):
status: New → Confirmed
Revision history for this message
Kagetsuki (zero-tsuki) wrote :

I'm the leader of the emojidex project https://www.emojidex.com . We're trying to get our emoji on Linux as quickly as possible with a special focus on Ubuntu Touch. Our license was written specifically to be GPL compatible and I'd really like to see our emoji in wide use across Linux platforms. If anybody would be willing to help us it would be much appreciated. At the moment we're stuck on just compiling a font that can be viewed.

Revision history for this message
Earendil02 (earendil002) wrote :

On my BQ Aquaris 4.5 the emojis are shown, e.g. in Telegram (not coloured as in Android though).
The problem is that you cannot use them in a message: there's no support in the keyboard.
This is a serious lack and IMHO a fix is overdue.

Revision history for this message
Scott Sweeny (ssweeny) wrote :

In Settings -> Language & Text -> Keyboard Layouts make sure that Emoji is enabled, then use the globe icon on the keyboard to switch to that layout when typing a message.

Revision history for this message
Yuval (yuvilio) wrote :

Another possible approach to globally support emojis, is using fontconfig with a patched cairo. Google developer @behdad put in some great legwork with that . Details here:

https://github.com/googlei18n/noto-emoji/issues/36#issuecomment-168209204

I think what's needed is to assess whether the patch works, is viable to be part of ubuntu cairo binaries (or maybe kicked up to the source maintainers), makes sense as the approach to use, etc..

Count me in as another user looking forward to using emojis on my terminal, text editors, etc.

Revision history for this message
N. W. (nw9165-3201) wrote :

Any update?

Revision history for this message
Michael Letterle (mletterle) wrote :

Pinging this issue, it seems like something that would be expected.

Revision history for this message
Francesco Fumanti (frafu) wrote :

Marmuta is working on it for the on-screen keyboard Onboard. It will probably be included in the next minor release of Onboard.
https://code.launchpad.net/~marmuta/onboard/emoji-palette

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers