Launcher: workspace-switcher, files, applications icons need switching to lens/grayscale style

Bug #704997 reported by Sense Egbert Hofstede on 2011-01-19
18
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Ayatana Design
High
John Lea
Unity
Fix Released
Undecided
Unassigned
unity-lens-applications
Undecided
Unassigned
unity-lens-files
Wishlist
Unassigned
humanity-icon-theme (Ubuntu)
Low
Paul Sladen
ubuntu-themes (Ubuntu)
Wishlist
Paul Sladen
unity (Ubuntu)
Undecided
Unassigned
unity-place-applications (Ubuntu)
Undecided
Unassigned
unity-place-files (Ubuntu)
Undecided
Unassigned

Bug Description

This issue is fixed with the signed off designs in the chinstrap 'sabdfl' folder, when are these latest icons scheduled to be uploaded to Natty? See https://chinstrap.canonical.com/~sabdfl/11_04/desktop_and_netbook/

Original bug report:
---------------------

The work-space switcher icon on the Unity launcher has the same appearance as application icons. This makes it look like it is an application and might lead users to expect it to behave like that.

It is not obvious that this is not a regular application icon, but something else. I suggest to change the icon to reflect this.

Sense Egbert Hofstede (sense) wrote :

 status confirmed
 importance high

This really needs to be passed on to the visual design folks, I forget
the magic project/tag :-)

Thanks for the feedback. Propagating to the design team for review.

Changed in unity:
status: New → Opinion
Changed in unity (Ubuntu):
status: New → Opinion
Changed in unity:
importance: Undecided → Wishlist
Changed in unity (Ubuntu):
importance: Undecided → Wishlist
Changed in ayatana-design:
importance: Undecided → High
status: New → Confirmed
John Lea (johnlea) wrote :

This should be fixed with the new Launcher icons, when are they scheduled to land in Natty?

summary: - Unity work-space switcher icon looks like an application
+ Unity work-space switcher icon looks like an application - new launcher
+ icons need uploading to Natty
description: updated
Changed in ayatana-design:
status: Confirmed → Fix Committed
importance: High → Critical
assignee: nobody → John Lea (johnlea)
tags: added: udt
Paul Sladen (sladen) on 2011-03-11
Changed in ayatana-design:
importance: Critical → High

Bumping down from critical as it doesn't appear to involve data-loss of anything that would require it doing today. John: I've looked through the files in that chinstrap (which before anyone wonders, is only available to people @canonical) but can't see the icons themselves that would be necessary to progress this.

Are the icons available somewhere, or are these just at the mockup stage?

Paul Sladen (sladen) wrote :

Just checked with rosie; it sounds like the icons aren't split out/ready yet, so it will be impossible to implement on the technical side just yet.

Changed in ayatana-design:
status: Fix Committed → Triaged
tags: added: needs-design
John Lea (johnlea) wrote :

All the designs are complete and signed off, they just need exporting and packaging. Paul, Rosie is going to send you a link to download the final files from chinstrap and work your exporting and packaging magic ;-)

Paul Sladen (sladen) wrote :

Thank you to rosie and mpt! None of the software that I have available will open this in an ideal fashion.

I can get an approximation from Gimp's rendering of the vector entities, but I don't think people would be happy with the result.

Please could the necessary parts by exported as SVG so that we can work with them in the target format? (I'm still happy to chop the result up in Inkscape).

Paul Sladen (sladen) wrote :

Rosie: User Interface freeze tonight. Are you able to break out the newer versions of any icons that still need uploading for natty?

Xi Zhu (xi.zhu) wrote :

have done it!

Xi Zhu (xi.zhu) wrote :

Here are the five vector icons for "find media apps", "find internet apps", "find more apps", "find files" which are for dash home, and "workspaces" which is for launcher. You can see the top row icons in dash home screen by clicking on the button in the top-right.

The file opens fine in Inkscape, but still need to applied gradient on.

Paul Sladen (sladen) on 2011-03-23
description: updated
Paul Sladen (sladen) wrote :

Unity currently calls out using 'SetIconName' for both 'user-trash' and 'workspace-switcher' and doesn't ship either of them in itself (although the /other/ four remaining "Find Find Find Find" lens icons are packaged within the Unity source:

  $ grep -r SetIconName.*\" .
  ./src/TrashLauncherIcon.cpp: SetIconName ("user-trash");
  ./src/LauncherController.cpp: _expoIcon->SetIconName ("workspace-switcher");

The icon that is getting used is the one delivered with Humanity:

  /usr/share/icons/Humanity/places/64/user-trash.svg

So replacing this will do the trick:

  $ find -name \*workspace\*
  ./Humanity/apps/48/gnome-panel-workspace-switcher.svg
  ./Humanity/apps/48/workspace-switcher.svg
  ./Humanity/apps/32/gnome-panel-workspace-switcher.svg

affects: unity (Ubuntu) → humanity-icon-theme (Ubuntu)
Paul Sladen (sladen) wrote :

The other two similar images that are semi-hardcoded into the Unity Launcher as part of the chrome are:

  unity-place-files: /usr/share/unity/themes/files.png
  unity-place-applications: /usr/share/unity/themes/applications.png

Paul Sladen (sladen) on 2011-03-24
affects: unity → unity-place-files
Changed in unity-place-files:
status: Opinion → New
summary: - Unity work-space switcher icon looks like an application - new launcher
- icons need uploading to Natty
+ Launcher: workspace-switcher, files, applications icons need switching
+ to lens/grayscale style
Paul Sladen (sladen) wrote :

Bottom-three lens-style icons. The workspace switcher is getting highlighted incorrectly, as those it was a terminal application, but the actual icon/transparency itself appears to be fine.

Paul Sladen (sladen) wrote :

Demonstration that the transparency in the new SVG icon appears to match those of other lens icons.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package humanity-icon-theme - 0.5.3.8

---------------
humanity-icon-theme (0.5.3.8) natty; urgency=low

  * Lens-style 'workspace-switcher.svg' icon and remove
    optimised 32-pixel variant (LP: #704997)
 -- Paul Sladen <email address hidden> Thu, 24 Mar 2011 05:12:00 +0000

Changed in humanity-icon-theme (Ubuntu):
status: Opinion → Fix Released
Didier Roche (didrocks) wrote :

ok, pushed in both trunk.

I had to rescale the icons to 48x48 though to avoid doing unnecessary calculation at startup.

Changed in unity-place-files:
status: New → Fix Committed
Changed in unity-place-applications:
status: New → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity-place-files - 0.5.46-0ubuntu2

---------------
unity-place-files (0.5.46-0ubuntu2) natty; urgency=low

  * Cherry-pick and rescale files.png to latest asset (LP: #704997)
 -- Didier Roche <email address hidden> Thu, 24 Mar 2011 11:14:32 +0100

Changed in unity-place-files (Ubuntu):
status: New → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity-place-applications - 0.2.42-0ubuntu2

---------------
unity-place-applications (0.2.42-0ubuntu2) natty; urgency=low

  * Cherry-pick and rescale applications.png to latest asset (LP: #704997)
 -- Didier Roche <email address hidden> Thu, 24 Mar 2011 11:13:52 +0100

Changed in unity-place-applications (Ubuntu):
status: New → Fix Released
Didier Roche (didrocks) on 2011-03-24
Changed in unity:
status: New → Fix Committed
Xi Zhu (xi.zhu) wrote :

Thank you for doing those changes!

I found a new bug which is about trash icon
https://bugs.launchpad.net/ayatana-design/+bug/741804

Vish (vish) wrote :

Damn Freezes! Need to watch my inbox more vigilantly during these phases... ;p

Replacing Humanity icons is not the way to do this.

We set Ubuntu-mono-dark as is the default icon theme for Ambiance and Ubuntu-mono-light for Radience.
The workplace switcher icons need to go into those themes.

Paul Sladen, Kindly revert the last upload and add these icons to ubunu-mono. Thanks.. :-)

Changed in humanity-icon-theme (Ubuntu):
assignee: nobody → Paul Sladen (sladen)
importance: Wishlist → Low
status: Fix Released → Triaged
Changed in ubuntu-mono (Ubuntu):
assignee: nobody → Paul Sladen (sladen)
importance: Undecided → Wishlist
status: New → Triaged
Dave Morley (davmor2) wrote :

The current mono desktop switcher is too easily mistaken for the terminal icon. This would be especially aggravated if the user had poorer vision.

The 2 icons in question would both look like Black boxes with grey boarders and something inside the black box.

The older coloured icon was far more obvious and distinct.

Neil J. Patel (njpatel) on 2011-03-31
Changed in unity:
milestone: none → 3.8.2
Didier Roche (didrocks) on 2011-04-01
Changed in unity:
status: Fix Committed → Fix Released
Changed in unity-place-applications:
status: Fix Committed → Fix Released
Changed in unity-place-files:
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package humanity-icon-theme - 0.5.3.9

---------------
humanity-icon-theme (0.5.3.9) natty; urgency=low

  [ K Vishnoo Charan Reddy ]
  * Revert workspace icons to regular icons. Lens-style need to
    be in ubuntu-mono; (LP: #704997)
  * Use correct names for archive-* icons
  * Remove exec bits

  [ Martin Pitt ]
  * debian/control: Add python-{rsvg,cairo} to renable SVG optimization
    verification. These needed to be dropped from python-scour due to
    LP#734471.
 -- K Vishnoo Charan Reddy <email address hidden> Fri, 25 Mar 2011 21:58:08 +0530

Changed in humanity-icon-theme (Ubuntu):
status: Triaged → Fix Released
John Lea (johnlea) on 2011-04-19
tags: removed: needs-design udt
John Lea (johnlea) on 2011-10-18
Changed in ayatana-design:
status: Triaged → Fix Released
affects: ubuntu-mono (Ubuntu) → ubuntu-themes (Ubuntu)
Changed in unity (Ubuntu):
status: New → Fix Released
To post a comment you must log in.