Radiance/gtk-3.20/gtk-main.css attempts to import nonexistent gnome-builder.css

Bug #1773045 reported by Nate Eldredge on 2018-05-24
82
This bug affects 15 people
Affects Status Importance Assigned to Milestone
ubuntu-themes (Ubuntu)
Low
Khurshid Alam
Bionic
Undecided
Unassigned

Bug Description

[ Impact ]

Running an application with Radiance theme shows an error

[ Test case ]

1. Run an application (evince) in terminal using Radiance:
   GTK_THEME=Radiance evince
2. No error should be spotted regarding a missing .css file

[ Regression potential ]

None

---

The file /usr/share/themes/Radiance/gtk-3.20/gtk-main.css contains the line

@import url("apps/gnome-builder.css");

But this file does not exist in this package or any other, as far as I can tell from apt-file. This triggers an annoying warning when running various applications (e.g. evince):

(evince:12714): Gtk-WARNING **: 18:41:45.136: Theme parsing error: gtk-main.css:73:38: Failed to import: Error opening file /usr/share/themes/Radiance/gtk-3.20/apps/gnome-builder.css: No such file or directory

ProblemType: BugDistroRelease: Ubuntu 18.04
Package: light-themes 16.10+18.04.20180421.1-0ubuntu1
ProcVersionSignature: Ubuntu 4.15.0-22.24-generic 4.15.17
Uname: Linux 4.15.0-22-generic x86_64
NonfreeKernelModules: wl
ApportVersion: 2.20.9-0ubuntu7
Architecture: amd64
Date: Wed May 23 18:58:41 2018
PackageArchitecture: allSourcePackage: ubuntu-themes
UpgradeStatus: Upgraded to bionic on 2018-05-23 (1 days ago)

Related branches

summary: - Attempt to import nonexistent gnome-builder.css
+ Radiance/gtk-3.20/gtk-main.css attempts to import nonexistent gnome-
+ builder.css
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in ubuntu-themes (Ubuntu):
status: New → Confirmed
apostol (faliagas) wrote :

In /usr/share/themes/Radiance/gtk-3.20/apps create the link
sudo ln -s gedit.css gnome-builder.css
I did not see any difference in gedit, but the error message disappears.

Changed in ubuntu-themes:
status: New → Confirmed
dzmitry (sivakou) wrote :

Too have bug! Any solution?

Igor (igor-go) wrote :

I'm facing this problem when launching temrinus alpha 50

herculano souza (herculano-sou) wrote :

I'm with this same issue :/

Jeff Powell (jrpstonecarver) wrote :

This same issue show up *many* times during the upgrade from 16.04 to 18.04.

Many times.

apostol (faliagas) wrote :

The following provides a tentative FIX to the problem, assuming gedit is installed:
In /usr/share/themes/Radiance/gtk-3.20/apps create the link
sudo ln -s gedit.css gnome-builder.css

Jeff Powell (jrpstonecarver) wrote :

That fix is great, but not for those going through a new install of 18.04. I had to let the entire installation process finish before I could do anything about those messages at all, and their are dozens of them that go by. Given this is a new problem in this theme in 18.04 (at least as far as I know) and was definitely not present in 16.04, the issue should be addressed to avoid errors during installation of (or upgrade to) 18.04. Your fix can't be made until one of those is done.

Anupam Patel (patel-anupam02) wrote :

this fix `In /usr/share/themes/Radiance/gtk-3.20/apps create the link
sudo ln -s gedit.css gnome-builder.css

Anupam Patel (patel-anupam02) wrote :

this fix `In /usr/share/themes/Radiance/gtk-3.20/apps create the link
sudo ln -s gedit.css gnome-builder.css` is not working in ubuntu 18.04

I don't really understand why people are focusing on the ugly symlink workaround. It seems to me that the obvious immediate fix for the warning is to just delete the offending line from gtk-main.css. Of course, the deeper question is whether gnome-builder.css used to provide some important functionality, and whether that functionality needs to be replaced somehow.

John Avery (jkavery) wrote :

I see this problem when running gio open of a Google maps location query URL.

Edward H. Welbon (ehwelbon) wrote :

I notice this happening in upgrades that relate to gtk-main.css. It might be worth looking at the history of changes to understand the change causing this to come in. If the line is not needed it should be deleted not because it is clearly harmful in some specific context so much as it is rather visible.

Doug McMahon (mc3man) wrote :

Just remove the line (73) in /usr/share/themes/Radiance/gtk-3.20/gtk-main.css, it's useless & not in ambiance..

Thomas Mayer (thomas303) wrote :

I've hit this issue right after upgrading from 16.04 to 18.04

Changed in ubuntu-themes (Ubuntu):
assignee: nobody → Khurshid Alam (khurshid-alam)
Changed in ubuntu-themes (Ubuntu):
status: Confirmed → Fix Committed
Changed in ubuntu-themes:
status: Confirmed → Fix Committed
no longer affects: ubuntu-themes
description: updated
Changed in ubuntu-themes (Ubuntu):
importance: Undecided → Low
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntu-themes - 16.10+18.10.20181005-0ubuntu1

---------------
ubuntu-themes (16.10+18.10.20181005-0ubuntu1) cosmic; urgency=medium

  [ Khurshid Alam ]
  * Remove nonexistent gnome-builder.css (LP: #1773045)

  [ Marco Trevisan (Treviño) ]
  * Radiance: fix typo in assets link for focused buttons (LP: #1781736)
  * Radiance: Use scaled image for buttons border (LP: #1781736)
  * Ambiance, Radiance: don't use padding on window buttons for chromium
    (LP: #1782038)
  * Ambiance: use default foreground color for toolbar menus (LP:
    #1758841)
  * Ambiance, Radiance: show proper arrow in combobox (LP: #1743373)
  * Ambiance, Radiance: use default disabled color for actions headerbar
    buttons (LP: #1785699)
  * Ambiace, Radiance: use headerbar destructive-action definition for
    buttons
  * Ambiance, Radiance: fix list selected color for gnome-boxes (LP:
    #1761684)
  * Ambiance, Radiance: properly theme disabled and hovered accelerators
    (LP: #1795895)

 -- Marco Trevisan (Treviño) <mail@3v1n0.net> Fri, 05 Oct 2018 00:13:07 +0000

Changed in ubuntu-themes (Ubuntu):
status: Fix Committed → Fix Released

Hello Nate, or anyone else affected,

Accepted ubuntu-themes into bionic-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/ubuntu-themes/16.10+18.04.20181005-0ubuntu1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-bionic to verification-done-bionic. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-bionic. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Changed in ubuntu-themes (Ubuntu Bionic):
status: New → Fix Committed
tags: added: verification-needed verification-needed-bionic
Kentling (kent-rasmussen) wrote :

16.10+18.04.20181005-0ubuntu1 fixed this issue for me

tags: added: verification-done-bionic
removed: verification-needed-bionic
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers