Combobox arrow and color are inverted

Bug #1743373 reported by Egmont Koblinger on 2018-01-15
22
This bug affects 4 people
Affects Status Importance Assigned to Milestone
ubuntu-themes (Ubuntu)
Medium
Marco Trevisan (Treviño)
Bionic
Undecided
Unassigned

Bug Description

[ Test case ]

Comobobox lists extenders use invalid arrows
 1. Both at the top and at the bottom, the arrow (triangle) points downwards.
 2. Colors of sensitive and insensitive arrows are swapped.

[ Test case ]

 1. Open gnome-terminal, in menu goes to:
    Edit -> Profile Preferences -> Compatibility -> Encoding
 2. The arrow at the top should point upwards
 3. Tha arrow at the bottom should point downwards
 4. Arrows should be visible only when there's actually something
    to scroll up or down.

[ Regression potential ]

Arrows aren't shown as expected in menus or combo-box

---

Open a combobox with plenty of entries. (Example: gnome-terminal -> Edit -> Profile Preferences -> Compatibility -> Encoding)

Notice two bugs:

1. Both at the top and at the bottom, the arrow (triangle) points downwards.

Expected: At the top, the arrow should point upwards.

2. Colors of sensitive and insensitive arrows are swapped. The arrow is black if you cannot scroll in that direction, gray if hovering starts to scroll.

Expected: It should be black if you can scroll in that direction by hovering, and gray if you cannot.

Adwaita doesn't suffer from either of these issues.

ProblemType: BugDistroRelease: Ubuntu 17.10
Package: light-themes 16.10+17.10.20171115-0ubuntu1
ProcVersionSignature: Ubuntu 4.13.0-25.29-generic 4.13.13
Uname: Linux 4.13.0-25-generic x86_64
ApportVersion: 2.20.7-0ubuntu3.7
Architecture: amd64
CurrentDesktop: Unity:Unity7:ubuntu
Date: Mon Jan 15 13:44:49 2018
InstallationDate: Installed on 2016-11-09 (431 days ago)
InstallationMedia: Ubuntu 16.10 "Yakkety Yak" - Release amd64 (20161012.2)
PackageArchitecture: allSourcePackage: ubuntu-themes
UpgradeStatus: Upgraded to artful on 2017-09-21 (115 days ago)

Related branches

Egmont Koblinger (egmont-gmail) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in ubuntu-themes (Ubuntu):
status: New → Confirmed
Changed in ubuntu-themes (Ubuntu):
importance: Undecided → Medium
Changed in ubuntu-themes:
status: New → Confirmed
importance: Undecided → Medium
tags: added: bionic
no longer affects: ubuntu-themes
Changed in ubuntu-themes (Ubuntu):
status: Confirmed → In Progress
assignee: nobody → Marco Trevisan (Treviño) (3v1n0)
description: updated
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntu-themes - 16.10+18.10.20181005-0ubuntu1

---------------
ubuntu-themes (16.10+18.10.20181005-0ubuntu1) cosmic; urgency=medium

  [ Khurshid Alam ]
  * Remove nonexistent gnome-builder.css (LP: #1773045)

  [ Marco Trevisan (Treviño) ]
  * Radiance: fix typo in assets link for focused buttons (LP: #1781736)
  * Radiance: Use scaled image for buttons border (LP: #1781736)
  * Ambiance, Radiance: don't use padding on window buttons for chromium
    (LP: #1782038)
  * Ambiance: use default foreground color for toolbar menus (LP:
    #1758841)
  * Ambiance, Radiance: show proper arrow in combobox (LP: #1743373)
  * Ambiance, Radiance: use default disabled color for actions headerbar
    buttons (LP: #1785699)
  * Ambiace, Radiance: use headerbar destructive-action definition for
    buttons
  * Ambiance, Radiance: fix list selected color for gnome-boxes (LP:
    #1761684)
  * Ambiance, Radiance: properly theme disabled and hovered accelerators
    (LP: #1795895)

 -- Marco Trevisan (Treviño) <mail@3v1n0.net> Fri, 05 Oct 2018 00:13:07 +0000

Changed in ubuntu-themes (Ubuntu):
status: In Progress → Fix Released

Hello Egmont, or anyone else affected,

Accepted ubuntu-themes into bionic-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/ubuntu-themes/16.10+18.04.20181005-0ubuntu1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-bionic to verification-done-bionic. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-bionic. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Changed in ubuntu-themes (Ubuntu Bionic):
status: New → Fix Committed
tags: added: verification-needed verification-needed-bionic
Egmont Koblinger (egmont-gmail) wrote :

I can confirm the issue is fixed in Cosmic beta. Thanks!

apt-cache policy light-themes
light-themes:
  Installato: 16.10+18.04.20181004-0ubuntu1
  Candidato: 16.10+18.04.20181004-0ubuntu1

I confirm this is fixed.

tags: added: verification-done verification-done-bionic
removed: verification-needed verification-needed-bionic
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers