/usr/share/themes/Ambiance/gtk-2.0/apps/mate-panel.rc:30: error: invalid string constant "murrine-scrollbar", expected valid string constant

Bug #1723422 reported by dino99 on 2017-10-13
202
This bug affects 41 people
Affects Status Importance Assigned to Milestone
ubuntu-themes (Ubuntu)
High
Marco Trevisan (Treviño)
Artful
High
Marco Trevisan (Treviño)

Bug Description

[Impact]

Get that error now with each random package upgrade:

/usr/share/themes/Ambiance/gtk-2.0/apps/mate-panel.rc:30: error: invalid string constant "murrine-scrollbar", expected valid string constant

Looks like related to that change:

* gtk2: Ambiance, Radiance: inherit style fixes from MATE themes (LP:
    #961679)

 -- Marco Trevisan (Treviño) <mail@3v1n0.net> Thu, 12 Oct 2017 05:19:32 +0000

That installation is a default Ubuntu , no Mate installed, and Ambiance is set for 'applications' into tweaks

[Test case]

1. Run a gtk2 application (with ambiance/radiance set as theme) in terminal
2. App has to run without any error

[Possible regression]

Different scrollbars in gtk2 apps.

ProblemType: Bug
DistroRelease: Ubuntu 17.10
Package: light-themes 16.10+17.10.20171012.1-0ubuntu1
ProcVersionSignature: Ubuntu 4.13.0-16.19-generic 4.13.4
Uname: Linux 4.13.0-16-generic x86_64
ApportVersion: 2.20.7-0ubuntu3
Architecture: amd64
CurrentDesktop: GNOME
Date: Fri Oct 13 14:52:43 2017
EcryptfsInUse: Yes
PackageArchitecture: all
SourcePackage: ubuntu-themes
UpgradeStatus: No upgrade log present (probably fresh install)

Related branches

dino99 (9d9) wrote :
Jeremy Bicha (jbicha) on 2017-10-14
tags: added: rls-aa-incoming
dipol (dipol0) wrote :

Have same trouble with Vider for Linux ver 6.5.5.1481 on Ubuntu 17.10 (Linux 4.13.4-041304-generic #201709270931 SMP Wed Sep 27 13:35:03 UTC 2017 x86_64 x86_64 x86_64 GNU/Linux)

QSqlDatabasePrivate::removeDatabase: connection 'ConfigureDBConnection' is still in use, all queries will cease to work.
/usr/share/themes/Ambiance/gtk-2.0/apps/mate-panel.rc:30: error: invalid string constant "murrine-scrollbar", expected valid string constant
Unrecognized OpenGL version
Unrecognized OpenGL version
Qt WebEngine ICU data not found at /opt/viber/resources. Trying parent directory...
Qt WebEngine resources not found at /opt/viber/resources. Trying parent directory...
Qt WebEngine ICU data not found at /opt/viber/resources. Trying parent directory...
Qt WebEngine resources not found at /opt/viber/resources. Trying parent directory...
Unrecognized OpenGL version
Unrecognized OpenGL version
Unrecognized OpenGL version
Unrecognized OpenGL version

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in ubuntu-themes (Ubuntu):
status: New → Confirmed
Changed in ubuntu-themes (Ubuntu):
assignee: nobody → Marco Trevisan (Treviño) (3v1n0)

Same problem with XMind, after running setup.sh which installs some dependencies and fonts, when I try to run the application I get the following error:

$ ./XMind_amd64/XMind
/usr/share/themes/Ambiance/gtk-2.0/apps/mate-panel.rc:30: error: invalid string constant "murrine-scrollbar", expected valid string constant

I've downloaded the following version of XMind: https://www.xmind.net/xmind/downloads/xmind-8-update5-linux.zip

This app runs with Java and my current version is:
openjdk version "1.8.0_144"
OpenJDK Runtime Environment (build 1.8.0_144-8u144-b01-2-b01)
OpenJDK 64-Bit Server VM (build 25.144-b01, mixed mode)

If you need any more information please let me know

dino99 (9d9) wrote :

this is not app specific

Changed in xmxmind:
status: New → Invalid
tags: added: rls-bb-incoming
removed: rls-aa-incoming
burdandrei (burdandrei) wrote :

I received this trying to run parcellite on ubuntu 17.10.
Workaround with editing the file did not helped =(

burdandrei (burdandrei) wrote :

If i log out from "Ubuntu" and log in to "Ubuntu Gnome", parcellite works

Changed in xmxmind:
assignee: nobody → Gastón Fournier (gastonfournier)
no longer affects: xmxmind
Changed in ubuntu-themes (Ubuntu):
importance: Undecided → High
status: Confirmed → In Progress
description: updated
joe bloggs (icecream2345) wrote :

Hi

I get this error when trying to run below....

$ gksudo bash ~/Vmware-Player-14.0.0.0-6661328.x86_64.bundle

Ideas most welcome... as right now i am back on win10 machine until i can work out how to install player

Hi

I am also getting this error while running an executable which prompts the GTK GUI. Icon is also not getting displayed in dock.

Please find the screen shot attached where the icon of GUI application in not being displayed in dock, while clicking the executable and getting this error in syslog

dino99 (9d9) on 2017-10-31
description: updated
md_5 (md-5) wrote :

Confirming with OpenJDK Swing applications also.

I have try install the cmap same problem this the log:
............................
phenom9650@phenom9650-desktop:~$ sudo chmod +x Linux64CmapTools_v6.03_10-04-17.bin
[sudo] password for phenom9650:
phenom9650@phenom9650-desktop:~$ ./Linux64CmapTools_v6.03_10-04-17.bin
Preparing to install
Extracting the JRE from the installer archive...
Unpacking the JRE...
Extracting the installation resources from the installer archive...
Configuring the installer for this system's environment...

Launching installer...

/usr/share/themes/Radiance/gtk-2.0/apps/mate-panel.rc:30: error: invalid string constant "murrine-scrollbar", expected valid string constant
...........................

Can also confirm the presence of this bug in JavaFX apps compiled with Oracle JDK 1.8.0_151

I get the same error message as reported when launching my application

/usr/share/themes/Radiance/gtk-2.0/apps/mate-panel.rc:30: error: invalid string constant "murrine-scrollbar", expected valid string constant

Drew (staufferlive) wrote :

Can confirm this bug while using JavaFX in IntelliJ IDEA 2017.2.5 with Oracle JDK 9.0.1...

/usr/share/themes/Radiance/gtk-2.0/apps/mate-panel.rc:30: error: invalid string constant "murrine-scrollbar", expected valid string constant

David Pinel (dav-pinel) wrote :

Same with Postman v5.3.2 64bits on ubuntu 17.10 (in VmwareWorkstation)

# /usr/bin/postman

/usr/share/themes/Ambiance/gtk-2.0/apps/mate-panel.rc:30: error: invalid string constant "murrine-scrollbar", expected valid string constant
Closed Window (id: 1)

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntu-themes - 16.10+18.04.20171114-0ubuntu1

---------------
ubuntu-themes (16.10+18.04.20171114-0ubuntu1) bionic; urgency=medium

  [ Andrea Azzarone ]
  * Fix osd progress bar look. (LP: #1724808)

  [ Carlo Lobrano ]
  * Ambiance, Radiance: fix horizontal linked suggested-action and
    destructive-action (LP: #1721102)
  * Ambiance, Radiance: Fixed border in switcher widget (LP: #1719355)

  [ Marco Trevisan (Treviño) ]
  * Ambiance, Radiance (gtk2): remove undefined "murrine-scrollbar" from
    mate panel (LP: #1723422)
  * Ambiance, Radiance: add theming for headerbar .destructive-action
    button's (LP: #1726318)
  * Ambiance, Radiance: Use inverted gradient for button actions in
    maximized titlebars (LP: #1726322)

 -- Marco Trevisan (Treviño) <mail@3v1n0.net> Tue, 14 Nov 2017 17:50:15 +0000

Changed in ubuntu-themes (Ubuntu):
status: In Progress → Fix Released
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in ubuntu-themes (Ubuntu Artful):
status: New → Confirmed

Hello dino99, or anyone else affected,

Accepted ubuntu-themes into artful-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/ubuntu-themes/16.10+17.10.20171115-0ubuntu1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-artful to verification-done-artful. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-artful. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in ubuntu-themes (Ubuntu Artful):
status: Confirmed → Fix Committed
tags: added: verification-needed verification-needed-artful
Thijs Kinkhorst (kink) wrote :

Upgrading from proposed-updates fixes the problem for me.

tags: added: verification-done verification-done-artful
removed: verification-needed verification-needed-artful

SRU verification for Artful:
I have reproduced the problem with ubuntu-themes 16.10+17.10.20171012.1-0ubuntu1 in artful and have verified that the version of ubuntu-themes 16.10+17.10.20171115-0ubuntu1 in -proposed fixes the issue.

Marking as verification-done

Changed in ubuntu-themes (Ubuntu Artful):
importance: Undecided → High
assignee: nobody → Marco Trevisan (Treviño) (3v1n0)
huerben (huerben) wrote :

installing artful-proposed ubuntu-themes/16.10+17.10.20171115-0ubuntu1 does not help.
starting kompozer then same issue as before

~$ kompozer
/usr/share/themes/Ambiance/gtk-2.0/apps/mate-panel.rc:30: error: invalid string constant "murrine-scrollbar", expected valid string constant

huerben (huerben) wrote :

It seems there is no change for me. This is my mate-panel.rc

# Panel specific settings for correct theming on MATE

style "panel" = "dark"
{
 xthickness = 0
 ythickness = 0

 engine "murrine" {
  colorize_scrollbar = TRUE
 }
}

style "panel_default" = "dark"
{
 engine "murrine" {
  colorize_scrollbar = TRUE
 }
}

widget "*Panel" style "panel"
widget "*PanelWidget*" style "panel"
widget "*PanelApplet*" style "panel" # workaround for right click menu corrupted bg
widget "*fast-user-switch*" style "panel" # workaround for Fast User Switch applet
widget "*CPUFreqApplet*" style "panel" # workaround for CpuFreq Applet
class "PanelApp*" style "panel"
class "PanelToplevel*" style "panel"
widget_class "*notif*" style "panel"
widget_class "*PanelApplet*" style "panel_default" # workaround for right click menu corrupted bg
widget_class "*Tray*" style "panel" # workaround for StarDict, gnubiff... tray icon bg
class "GtkScrollbar" style "murrine-scrollbar"

huerben (huerben) wrote :

@Marco Trevisan (Treviño) (3v1n0)
Is there no lin30 in your file?? I don see it.

line 30 in my file is:
30 class "GtkScrollbar" style "murrine-scrollbar"

huerben (huerben) wrote :

Install the ubuntu-artwork packages via synaptic do not change the file /usr/share/themes/Ambiance/gtk-2.0/apps/mate-panel.rc
I don now why.

so i copy the file from Marco Trevisan manualy in the file., do restart,

no error message in the terminal, but kompozer still not start.

$ kompozer
xxx@xxxxx:~$

I think that's another issue then...

Sorry to bump a closed bug report, but what is the proposed solution?

On 17.10, I've enabled the "proposed" through Software & Updates, but "ubuntu-themes" is not a valid package name. Since "ubuntu-artwork" is listed as a binary build from this package, I've updated that to no avail.

    Preparing to unpack .../ubuntu-artwork_1%3a16.10+17.10.20171115-0ubuntu1_all.deb ...
    Unpacking ubuntu-artwork (1:16.10+17.10.20171115-0ubuntu1) over (1:16.10+17.10.20171115-0ubuntu1) ...
    Setting up ubuntu-artwork (1:16.10+17.10.20171115-0ubuntu1) ...
    Processing triggers for hicolor-icon-theme (0.17-1) ...

But the original error ** "murrine-scrollbar", expected valid string constant ** still exists.

Please disregard the above message. Like @huerben, I have similar symptom but a separate issue after updating. The murrine-scrollbar error has disappeared with the above steps.

Sitaram Kumar (skshbag) on 2017-11-29
Changed in ubuntu-themes (Ubuntu Artful):
status: Fix Committed → Fix Released
Changed in ubuntu-themes (Ubuntu Artful):
status: Fix Released → In Progress
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntu-themes - 16.10+17.10.20171115-0ubuntu1

---------------
ubuntu-themes (16.10+17.10.20171115-0ubuntu1) artful; urgency=medium

  [ Andrea Azzarone ]
  * Fix osd progress bar look. (LP: #1724808)

  [ Carlo Lobrano ]
  * Ambiance, Radiance: Fixed border in switcher widget (LP: #1719355)
  * Ambiance, Radiance: fix horizontal linked suggested-action and
    destructive-action (LP: #1721102)

  [ Marco Trevisan (Treviño) ]
  * Ambiance, Radiance (gtk2): remove undefined "murrine-scrollbar" from
    mate panel (LP: #1723422)
  * Ambiance, Radiance: add theming for headerbar .destructive-action
    button's (LP: #1726318)
  * Ambiance, Radiance: Use inverted gradient for button actions in
    maximized titlebars (LP: #1726322)

 -- Marco Trevisan (Treviño) <mail@3v1n0.net> Wed, 15 Nov 2017 06:59:57 +0000

Changed in ubuntu-themes (Ubuntu Artful):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for ubuntu-themes has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers