The "Minimize", " Maximize" and "Close" buttons are too small to click

Bug #1693609 reported by Jeremy Bicha on 2017-05-25
28
This bug affects 4 people
Affects Status Importance Assigned to Milestone
Ubuntu UX
Undecided
Unassigned
ubuntu-themes (Ubuntu)
Medium
Unassigned

Bug Description

The window control buttons ( _ 🗖 X ) in Ambiance are noticeably smaller than other icon buttons in the headerbar of a "native" GNOME3 app.

I think this is both a visual issue and an accessibility issue since it is harder to click the window control buttons than the other buttons. Please compare with Adwaita which has a much larger click area for the window control buttons.

Commentary
----------
Remember that one of the major strengths of GNOME 3 is that it is usable on a touch-enabled laptop.

And while there are many people that complain about Adwaita, I believe many more actually like the proportions and padding of the default GNOME theme!

ubuntu-themes 16.10+17.10.20170518-0ubuntu1
Ubuntu 17.10 Alpha

Related branches

Jeremy Bicha (jbicha) wrote :
Jeremy Bicha (jbicha) wrote :
Daniel van Vugt (vanvugt) wrote :

Agreed. You read my mind.

Changed in ubuntu-themes (Ubuntu):
importance: Undecided → Medium
status: New → Confirmed
assignee: nobody → Marco Trevisan (Treviño) (3v1n0)
tags: added: gnome-17.10
Daniel van Vugt (vanvugt) wrote :

It's not just about touchscreens. Even using a mouse it takes slightly longer to get the cursor exactly on the smaller icons.

And with touchpads this is also a bigger problem in 17.10 than previous releases... Because the switch to libinput means (for many people) lower touchpad precision. So it's even harder to get the cursor onto the small window buttons.

Daniel van Vugt (vanvugt) wrote :

Actually we don't necessarily have to change the visual design at all. We could just add invisible padding around the circular graphics that makes their active area the same size as the bigger buttons.

summary: - Please make window control buttons larger
+ The "Minimize", " Maximize" and "Close" buttons are too small to click
Changed in ubuntu-ux:
status: New → Confirmed
Changed in ubuntu-themes (Ubuntu):
assignee: Marco Trevisan (Treviño) (3v1n0) → nobody
Ven (venorz) wrote :

The situation is even worse on my 13 inch laptop, with resolution 1920x1080. It seems that now gnome doesn't support fraction factor scale, so I didn't change anything except scaled font.Everthing looks fine except these three buttons, they look extremely small and hard to click.

Changed in ubuntu-themes (Ubuntu):
status: Confirmed → In Progress
assignee: nobody → Marco Trevisan (Treviño) (3v1n0)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntu-themes - 16.10+18.04.20180328-0ubuntu1

---------------
ubuntu-themes (16.10+18.04.20180328-0ubuntu1) bionic; urgency=medium

  * Ambiance, Radiance: use static bg imgs for window buttons and add
    padding (LP: #1693609)
  * Ambiance, Radiance: don't use any background image (gradient) when
    in backdrop
  * Ambiance, Radiance: add more specific selectors for scale states
    (LP: #1759481)
  * Ambiance, Radiance: set top and bottom margins for switch and
    separators in headerbar (LP: #1693474)

 -- Marco Trevisan (Treviño) <mail@3v1n0.net> Wed, 28 Mar 2018 06:27:32 +0000

Changed in ubuntu-themes (Ubuntu):
status: In Progress → Fix Released
Ven (venorz) wrote :

Hello, I updated my system but nothing happens, the window buttons are still very small as before, same with the click area. you can see from my screenshot.

Daniel van Vugt (vanvugt) wrote :

The update that was released actually solved more subtle issues. It didn't solve this bug, as was mentioned in https://code.launchpad.net/~3v1n0/ubuntu-themes/windowbuttons-bg-and-padding/+merge/342171

Changed in ubuntu-themes (Ubuntu):
status: Fix Released → Confirmed
assignee: Marco Trevisan (Treviño) (3v1n0) → nobody
status: Confirmed → Triaged
MadsRH (madsrh) wrote :

Please bare with me here, because this might not be the right way to do this, but changing the background-image size and the margin seems to look good here.

I haven't generated new PNG's, so they are stretched from 20px to 22px.

MadsRH (madsrh) wrote :
Daniel van Vugt (vanvugt) wrote :

Thanks, but this bug is about making the buttons significantly bigger (more like Adwaita).

Still, you can propose any change to ubuntu-themes by creating a Bazaar branch and propose it for merging into lp:ubuntu-themes (https://code.launchpad.net/~ubuntu-art-pkg/ubuntu-themes/trunk).

Carlo Lobrano (c-lobrano) wrote :

MadsRH sent me the changes css, so that I could propose it as a usual MP

https://code.launchpad.net/~c-lobrano/ubuntu-themes/increase-window-control-buttons-size/+merge/342898

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers