gnome-shell: no window shadows

Bug #1685272 reported by Ken VanDine on 2017-04-21
16
This bug affects 3 people
Affects Status Importance Assigned to Milestone
ubuntu-themes (Ubuntu)
High
Marco Trevisan (Treviño)
Artful
High
Marco Trevisan (Treviño)

Bug Description

Under gnome-shell, there are no window borders (shadows). See attached screenshot.

See also bug 1685271

Related branches

Ken VanDine (ken-vandine) wrote :
tags: added: gnome-17.10
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in light-themes (Ubuntu):
status: New → Confirmed
Amr Ibrahim (amribrahim1987) wrote :

The ubuntu-themes source replaced light-themes after precise. The light-themes source only exists in precise.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in ubuntu-themes (Ubuntu):
status: New → Confirmed
Daniel van Vugt (vanvugt) wrote :

Yes, what Amr said...

$ dpkg -s light-themes | grep Source
Source: ubuntu-themes

Changed in light-themes (Ubuntu Artful):
status: Confirmed → Invalid
Iain Lane (laney) wrote :

The bug as described is not a theme issue, AFAICS. The window borders are meant to look like that.

Are you really complaining about the lack of shadows? That *is* a bug.

As far as I can see that particular issue only happens for csd windows. For example, gnome-terminal looks fine.

Changed in ubuntu-themes (Ubuntu Artful):
status: Confirmed → Triaged
importance: Undecided → High
Daniel van Vugt (vanvugt) wrote :

I was initially content with the terse description "no window border" because I thought there was only this one bug covering the shadows and titlebar corner issues. But it turns out a second bug 1685271 exists for the latter. So yes, this bug now needs a better description...

summary: - gnome-shell: no window border
+ gnome-shell: no window shadows
description: updated
no longer affects: light-themes (Ubuntu)
no longer affects: light-themes (Ubuntu Artful)
Changed in ubuntu-themes (Ubuntu Artful):
assignee: nobody → Marco Trevisan (Treviño) (3v1n0)
status: Triaged → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntu-themes - 16.10+17.10.20170510-0ubuntu1

---------------
ubuntu-themes (16.10+17.10.20170510-0ubuntu1) artful; urgency=medium

  * Ambiance, Radiance: fix shadows, handlers, decorations look for CSD
    and SSD in GS (LP: #1685271, #1685272, #1689239)

 -- Marco Trevisan (Treviño) <mail@3v1n0.net> Wed, 10 May 2017 12:42:22 +0000

Changed in ubuntu-themes (Ubuntu Artful):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers