Menus are jumping up and down when moving mouse

Bug #1617415 reported by Dmitry Shachnev on 2016-08-26
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
ubuntu-themes (Ubuntu)
Undecided
Unassigned

Bug Description

If a menu is opened, when moving the cursor from the menu bar to the first menu item, the whole menu moves down for one pixel. The same happens when moving the mouse between two menu items separated with a separator: when a mouse is on the separator, the whole menu jumps.

This happens with different menu types: "classic" GTK+ menus, Unity global menus and in-title menus.

A screencast is attached.

Related branches

Dmitry Shachnev (mitya57) wrote :
tags: added: gtk320 yakkety

The problem is that on hover border is added...

menuitem { border: 1px solid transparent } did fix problem when I added it to ~/.config/gtk-3.0/gtk.css. I don't have time to look if this breaks something else...

Dmitry Shachnev (mitya57) wrote :

Right, that snippet makes the bug disappear.

I am not yet sure if that would be the correct fix. First it would be nice to identify the CSS rule which adds the border to hovered items (I didn't manage to find it).

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntu-themes - 16.10+16.10.20160829.3-0ubuntu1

---------------
ubuntu-themes (16.10+16.10.20160829.3-0ubuntu1) yakkety; urgency=medium

  [ Alberts Muktupāvels ]
  * Remove box-shadow from .background:backdrop.
  * Fix jumping menu items. (LP: #1617415)

  [ Dmitry Shachnev ]
  * Added styling for gnome-flashback: OSD windows, input source
    switching, candidate popups and monitor labels.

 -- Dmitry Shachnev <email address hidden> Mon, 29 Aug 2016 18:42:30 +0000

Changed in ubuntu-themes (Ubuntu):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers