Metacity theme does not scale well on HiDPI

Bug #1603218 reported by Alberts Muktupāvels on 2016-07-14
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
ubuntu-themes (Ubuntu)
Undecided
Unassigned
Xenial
Undecided
Unassigned
Yakkety
Undecided
Unassigned

Bug Description

[Impact]
When Abmiance or Radiance is used as theme with Metacity on HiDPI screen unfocused window button background does not look good:
https://s31.postimg.org/dhjiqv1ff/Screenshot_from_2016_07_14_11_52_22.png

[Test Case]
* start Metacity as window manager
* set Ambiance or Radiance as metacity theme:
  gsettings set org.gnome.metacity theme Ambiance
* open multiple windows so at least one window is not focused

[Regression Potential]
Should not cause any regressions. Solid color image is replaced by same color rectangle.

Related branches

affects: ubuntu-themes → ubuntu-themes (Ubuntu)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntu-themes - 14.04+16.10.20160720-0ubuntu1

---------------
ubuntu-themes (14.04+16.10.20160720-0ubuntu1) yakkety; urgency=medium

  [ Alberts Muktupāvels ]
  * Simplify Metacity theme by replacing solid color image with filled
    rectangle to improve HiDPI support. (LP: #1603218)

  [ Matthieu James ]
  * [Suru icons] Added the keyboard indicators in a dedicated folder.
  * [Suru icons] Added mono arrow icons for the toolkit widgets: up,
    down, left, right and scrollbar stepper.

 -- Dmitry Shachnev <email address hidden> Wed, 20 Jul 2016 18:01:01 +0000

Changed in ubuntu-themes (Ubuntu Yakkety):
status: New → Fix Released
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in ubuntu-themes (Ubuntu Xenial):
status: New → Confirmed

Hello Alberts, or anyone else affected,

Accepted ubuntu-themes into xenial-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/ubuntu-themes/14.04+16.04.20160804-0ubuntu1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in ubuntu-themes (Ubuntu Xenial):
status: Confirmed → Fix Committed
tags: added: verification-needed
tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntu-themes - 14.04+16.04.20160804-0ubuntu1

---------------
ubuntu-themes (14.04+16.04.20160804-0ubuntu1) xenial; urgency=medium

  [ Dmitry Shachnev ]
  * Simplify Metacity theme by replacing solid color image with filled
    rectangle to improve HiDPI support. (LP: #1603218)

  [ <email address hidden> ]
  * Adds specific border widths to left and right of GtkSwitch buttons
    to hide the overflowing background of the button. (LP: #1594816)

 -- Dmitry Shachnev <email address hidden> Thu, 04 Aug 2016 17:59:45 +0000

Changed in ubuntu-themes (Ubuntu Xenial):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for ubuntu-themes has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers