[SRU] GtkSwitch button background overflows the border

Bug #1594816 reported by Will Cooke on 2016-06-21
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
ubuntu-themes (Ubuntu)
Medium
Will Cooke
Xenial
Medium
Unassigned

Bug Description

[Impact]
Where GtkSwitch is used, for example in the Screen Display section of Unity Control Center the background of the toggle buttons appears outside of the borders.

[Test Case]
Open the Screen Display section of the control centre and notice that on the left of toggle buttons you can see some white background over flowing the border of the toggle. See attached screenshot for an example.

Once the fix is applied this white overflow section should no longer be visible.

[Regression Potential]
Low. This is purely a CSS change and will only affect the look of the toggle buttons. It has been tested in the widget factory for affects on other UI elements and none were found.

Related branches

Will Cooke (willcooke) wrote :
Changed in ubuntu-themes (Ubuntu):
status: New → Confirmed
Will Cooke (willcooke) on 2016-06-21
Changed in ubuntu-themes (Ubuntu):
importance: Undecided → Medium
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntu-themes - 14.04+16.10.20160706-0ubuntu1

---------------
ubuntu-themes (14.04+16.10.20160706-0ubuntu1) yakkety; urgency=medium

  [ <email address hidden> ]
  * Adds specific border widths to left and right of GtkSwitch buttons
    to hide the overflowing background of the button. Fixes LP: #1594816
    (LP: #1594816)

 -- <email address hidden> (<email address hidden>) Wed, 06 Jul 2016 21:30:06 +0000

Changed in ubuntu-themes (Ubuntu):
status: Confirmed → Fix Released
Dmitry Shachnev (mitya57) wrote :

I can include this in my Xenial ubuntu-themes upload, can you please add the SRU paperwork?

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in ubuntu-themes (Ubuntu Xenial):
status: New → Confirmed
Will Cooke (willcooke) on 2016-08-05
summary: - GtkSwitch button background overflows the border
+ [SRU] GtkSwitch button background overflows the border
Will Cooke (willcooke) wrote :

SRU paperwork added.

description: updated

Hello Will, or anyone else affected,

Accepted ubuntu-themes into xenial-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/ubuntu-themes/14.04+16.04.20160804-0ubuntu1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in ubuntu-themes (Ubuntu Xenial):
status: Confirmed → Fix Committed
tags: added: verification-needed
Changed in ubuntu-themes (Ubuntu Xenial):
importance: Undecided → Medium
Will Cooke (willcooke) wrote :

Installed 14.04+16.04.20160804-0ubuntu1 from proposed and the bug is fixed.

tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntu-themes - 14.04+16.04.20160804-0ubuntu1

---------------
ubuntu-themes (14.04+16.04.20160804-0ubuntu1) xenial; urgency=medium

  [ Dmitry Shachnev ]
  * Simplify Metacity theme by replacing solid color image with filled
    rectangle to improve HiDPI support. (LP: #1603218)

  [ <email address hidden> ]
  * Adds specific border widths to left and right of GtkSwitch buttons
    to hide the overflowing background of the button. (LP: #1594816)

 -- Dmitry Shachnev <email address hidden> Thu, 04 Aug 2016 17:59:45 +0000

Changed in ubuntu-themes (Ubuntu Xenial):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for ubuntu-themes has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments