Ubuntu need a dark theme and background

Bug #158392 reported by Michal Suchanek on 2007-10-29
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
ubuntu-themes (Ubuntu)
Wishlist
Ubuntu Artwork Team

Bug Description

Binary package hint: gnome-themes

There is no Ubuntu theme with dark background in the theme package that is installed by default.

There are the special high contrast themes that do not look well on hardware that provides sufficient contrast, and there is the Darklooks modification of Clearlooks that is in the extra themes. Darklooks is usable and does have dark background but it looks somewhat bland since it has no colors.

Themes with dark background are useful because some screen defects manifest more noticeably when dark text is rendered on light background making the text harder to read. Also I find too light backgrounds tiring for my eyes.

Another reason to use dark background might be that it probably saves energy on most CRT screens ;-)

Michal Suchanek (hramrach) wrote :

I modified the Darklooks theme to go better with the other brown Ubuntu stuff.

The theme could probably use some more tuning but I tried to use it and there should be no obvious errors like invisible text or selections.

Daniel Stoyanov (dankh) wrote :

+1 , as a developer I spend 6 to 10 hours in front of the screen almost everyday. Dark background is more friendly for the eyes, what I do at the moment is install ubuntu studio theme and modify it a bit to fit my needs. It will be great if the artwork team work a bit on an "EYE FRIENDLY" theme. There are some problems with dark backgrounds especially when browsing the web or using some programs that not integrate well with the gnome desktop, but globally almost all the apps included in the default desktop are looking good and fully useful with dark background.

Marcelo Atie (marceloatie) wrote :

I Can confirm this :)
Ubuntu need this

Changed in ubuntu-artwork:
status: New → Confirmed
assignee: nobody → ubuntu-art
description: updated
Marcelo Atie (marceloatie) wrote :

I think that we should use BasicIdeals as Dark theme,
many people will love it !

But Ubuntu still need a clear theme in default,
Dark is not for the masses

Binary package hint: gnome-themes

I concur that Ubuntu should have a dark theme and background by
default. I find that bright / light colors strain my eyes after
several hours of working on the computer.

Although kind of ugly I've been using Aero with a few modifications to
darken up the screen and some custom backgrounds I rendered myself to
tone down the display.

I've also spoken to a professional optometrist about this here in the
US and he agrees that most computer screens need far less white and
far more dark colors to easy eye strain. He recommends blues and grey
tones for easy viewing.

We could patch up Aero a little (to make it look a little better) and
I could contribute a couple of desktops with Ubuntu themes if anyone
thinks that they would be needed / desired.

>
> There is no Ubuntu theme with dark background in the theme package that
> is installed by default.
>
 ** Affects: Ubuntu-artwork (Ubuntu)
      Importance: Undecided
      Assignee: Ubuntu Artwork Team (Ubuntu-art)
          Status: Confirmed

 --
Ubuntu need a dark theme and background
https://bugs.edge.launchpad.net/bugs/158392
> You received this bug notification because you are a member of Ubuntu Artwork Team, which is a bug assignee.
 --
------------------------------------
 The Phantomgraph };8>

Christophe Olinger (olingerc) wrote :

I completely agree. PLease consider adding a dark theme in the default themes package.

Here a small screey of my desktop

  • unnamed Edit (2.2 KiB, text/html; charset=ISO-8859-1)

It doesn't save much energy on modern monitors. But I agree. I end up
inverting all of my colors when I'm working in the dark/late at night. It's
nice to have the option of bright colors or dark. I've seen a few dark
remixes of the Heron BG that look very nice. And it's an svg, so with the
right transparancy it can be changeable on the fly.

On Wed, Apr 23, 2008 at 10:02 AM, Christophe Olinger <
<email address hidden>> wrote:

> I completely agree. PLease consider adding a dark theme in the default
> themes package.
>
> Here a small screey of my desktop
>
> ** Attachment added: "Screenshot.png"
> http://launchpadlibrarian.net/13839150/Screenshot.png
>
> --
> Ubuntu need a dark theme and background
> https://bugs.launchpad.net/bugs/158392
> You received this bug notification because you are a member of Ubuntu
> Artwork Team, which is a bug assignee.
>
> Status in Source Package "ubuntu-artwork" in Ubuntu: Confirmed
>
> Bug description:
> Binary package hint: gnome-themes
>
> There is no Ubuntu theme with dark background in the theme package that is
> installed by default.
>
> There are the special high contrast themes that do not look well on
> hardware that provides sufficient contrast, and there is the Darklooks
> modification of Clearlooks that is in the extra themes. Darklooks is usable
> and does have dark background but it looks somewhat bland since it has no
> colors.
>
> Themes with dark background are useful because some screen defects
> manifest more noticeably when dark text is rendered on light background
> making the text harder to read. Also I find too light backgrounds tiring for
> my eyes.
>
> Another reason to use dark background might be that it probably saves
> energy on most CRT screens ;-)
>

Marcelo Atie (marceloatie) wrote :

My tentative

Marcelo Atie (marceloatie) wrote :

I think it was fix released with Intrepid, I will change the status of the Bug, if someone disagree change the status to confirmed.

Changed in ubuntu-artwork:
status: Confirmed → Fix Released

you can get a free ipad from this site
http://reviews.getmyipad.net/?Zmp=kHSJc I don't know how long they're
gonna give them away but I got mine. I was skeptical about this whole
idea of free stuff but this site is for real, you just have to send
them back a review and then you can keep it.

Sent from my iPad

Michal Suchanek (hramrach) wrote :

I tried the Ububnto 10.10 live CD and this is not fixed.

There are Ambiance, Clearlooks, Dust, Dust Sand, New Wave and Radinace themes all using light controls (in spite of the New Wave preview picture showing otherwise) and the two hi-con themes.

Changed in ubuntu-artwork (Ubuntu):
status: Fix Released → Confirmed

In Maverick alphas there was a completely dark variation of Ambiance. Any way to get it back?

Alin Andrei (nilarimogard) wrote :

The Dark Ambiance was removed for now, they've said it was just a test. I agree a dark theme should be installed by default. Maybe something like Atolm [1]?

[1] http://www.webupd8.org/2010/12/atolm-new-great-looking-dark-theme.html

Michal Suchanek (hramrach) wrote :

If you compare

Atolm http://lh4.ggpht.com/_1QSDkzYY2vc/TRuBDMhY0qI/AAAAAAAACjU/aeXX8nv-7XA/atolm_by_skiesofazel-d35xysb.png

The previously posted dark theme https://bugs.launchpad.net/ubuntu/+source/ubuntu-artwork/+bug/158392/+attachment/282012/+files/Captura_da_tela-2.png

and Chocolate I would say Chocolate is more Ubuntu-like. It may be too low-contrast for some screens, though.

The background used for the screenshot is here

http://www.2desktop.com/download_Ecto_Volcano_Abstract_free_quality_desktop_wallpaper_1920_1200_resolution_4744.html

I have no idea about its license so I only post a link for your information.

Michal Suchanek (hramrach) wrote :

An update of the Chocolate theme that fixes link colour (such as in the theme selection dialog).

The warning is still kind of odd coloured but I have no idea how to set colour on that. It is broken in the hi-con themes as well.

Their is no dark theme in Ubuntu, the closest is the Ambiance theme. Their
is a black background-wallpaper though.

*With all due respect,*

Jason Odoom
https://launchpad.net/~jasonodoom <https://launchpad.net/%7Ejasonodoom>

Sent from Ubuntu <http://www.ubuntu.com/desktop>.

On Thu, Jan 6, 2011 at 1:25 PM, Michal Suchanek <email address hidden> wrote:

> An update of the Chocolate theme that fixes link colour (such as in the
> theme selection dialog).
>
> The warning is still kind of odd coloured but I have no idea how to set
> colour on that. It is broken in the hi-con themes as well.
>
> ** Attachment added: "updated Chocolate (fixes link color)"
>
> https://bugs.launchpad.net/ubuntu/+source/ubuntu-artwork/+bug/158392/+attachment/1785412/+files/Chocolate.tgz
>
> --
> You received this bug notification because you are a member of Ubuntu
> Artwork Team, which is a bug assignee.
> https://bugs.launchpad.net/bugs/158392
>
> Title:
> Ubuntu need a dark theme and background
>
> Status in “ubuntu-artwork” package in Ubuntu:
> Confirmed
>
> Bug description:
> Binary package hint: gnome-themes
>
> There is no Ubuntu theme with dark background in the theme package that is
> installed by default.
>
> There are the special high contrast themes that do not look well on
> hardware that provides sufficient contrast, and there is the Darklooks
> modification of Clearlooks that is in the extra themes. Darklooks is usable
> and does have dark background but it looks somewhat bland since it has no
> colors.
>
> Themes with dark background are useful because some screen defects manifest
> more noticeably when dark text is rendered on light background making the
> text harder to read. Also I find too light backgrounds tiring for my eyes

affects: ubuntu-artwork (Ubuntu) → ubuntu-themes (Ubuntu)
Changed in ubuntu-themes (Ubuntu):
importance: Undecided → Wishlist
Michal Suchanek (hramrach) wrote :

the MATE themes include a plain dark theme.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers