Use of Ubuntu logo as default app icon dilutes the brand

Bug #1520615 reported by dobey on 2015-11-27
12
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Canonical System Image
Undecided
Zoltan Balogh
Click Package Index
Undecided
Unassigned
Snap Store
Medium
Daniel Manrique
Software Center Agent
Undecided
Unassigned
ubuntu-sdk-ide (Ubuntu)
Undecided
Unassigned
ubuntu-themes (Ubuntu)
Undecided
Unassigned
ubuntu-touch-meta (Ubuntu)
Undecided
Unassigned

Bug Description

Currently, MyApps and CPI are using the "placeholder-app-icon.png" from the Suru theme, which is a basic greyscale image, including a version of the Ubuntu logo. Showing this logo as the app icon for apps which have no icon, implies they are officially supported apps by Ubuntu, and dilutes the brand and trademark, when they are not actually such apps, particularly when they have no function directly linked to any part of Ubuntu.

Instead, a better representation would be a generic representation of an app window or similar.

James Tait (jamestait) wrote :

CPI does nothing more than return the URL passed to it from SCA. Marking the CPI task as invalid.

Changed in click-package-index:
status: New → Invalid
dobey (dobey) wrote :

Added ubuntu-touch-meta here, as ubuntu-sdk seems to be including this image in newly generated projects from the Ubuntu template, and those then get included in packages, and may be distributed with this image. Retroactively fixing all the packages which may exist and be distributed in the store already might be an additional requirement to fully resolve the issue.

Changed in software-center-agent:
status: New → Invalid
Changed in ubuntu-ux:
status: New → Triaged
importance: Undecided → Medium
assignee: nobody → Matthieu James (tiheum)
Changed in canonical-devices-system-image:
assignee: nobody → Zoltan Balogh (bzoltan)
status: New → Confirmed
Daniel van Vugt (vanvugt) wrote :

I don't recall seeing this bug. But if it's not already fixed then probably "Won't Fix" is accurate if it's about Ubuntu Touch.

Changed in ubuntu-themes (Ubuntu):
status: New → Incomplete
Matthew Paul Thomas (mpt) wrote :

This is still a problem with snapstore, the sequel to MyApps.

affects: ubuntu-ux → snapstore
Changed in snapstore:
assignee: Matthieu James (tiheum) → nobody
Matthew Paul Thomas (mpt) wrote :
Changed in ubuntu-themes (Ubuntu):
status: Incomplete → Confirmed
Bret Barker (noise) wrote :

mpt: Can you provide us with a new icon for snapstore usage?

Changed in snapstore:
assignee: nobody → Daniel Manrique (roadmr)
Carla Berkers (carlaberkers) wrote :

We had the same problem in snapweb, Karl worked on a solution for that case that we can reuse.
Karl can you attach the asset to this bug please, and also add it on the snapweb github repo?

Thanks!

Hi Bret,

Please find new placeholder icon attached in SVG format along with a visual reference so you can see it in situ. I ran it past head of brand yesterday and he is happy to use this 'app store' icon as the replacement placeholder icon.

Thanks.

Visual reference attached.

Thanks.

Changed in snapstore:
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers