ubuntu 13.04 gnome-panel shows the Applications and Places menu in the top bar together without a space in-between them.

Bug #1154814 reported by Felix Moreno on 2013-03-13
94
This bug affects 18 people
Affects Status Importance Assigned to Milestone
Ubuntu theme
Low
Unassigned
ubuntu-themes (Ubuntu)
Low
Unassigned
Raring
Low
Unassigned

Bug Description

In the new ubuntu 13.04 there are changes in the way Programs and Places look, there is no space between them so both menus are together. Is in the top bar by default of gnome-panel. Next to the ubuntu icon.

In previous version ubuntu 12.10 there is a space between the two menus.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gnome-panel (Ubuntu):
status: New → Confirmed
Rafael Medina (gex-ux64) wrote :

In the Menu, Applications and Places Labels are showing like "ApplicationPlaces", without blank separator
> Im using gnome-fallback-session instead unity.
> Unity was removed from my system.
> This installation is a Distro Upgrade from Ubuntu 12.10
> The system is up to date until 24-03-2013 through APT

description: updated
summary: - ubunt 13.04 gnome-panel show the Programs and Places menu in the top bar
- together without any space between them.
+ ubuntu 13.04 gnome-panel shows the Applications and Places menu in the
+ top bar together without a space in-between them.
Petro (petrochemicals) wrote :

Yet another bug that made it into the "stable" release of 13.04.

JuneHyeon Bae (devunt) wrote :

+1 for other language (ko_KR)

Dmitry Shachnev (mitya57) wrote :

Doesn't happen with Metacity, so is probably a Compiz bug.

Changed in compiz (Ubuntu):
status: New → Confirmed
Petro (petrochemicals) wrote :

Sooo, is no one going to fix this? I mean if it is too much work for Canonical to support the software in their own repo, maybe they should not be putting that software in.

Felix Moreno (felix-justdust) wrote :

gnome-panel in ubuntu 13.04 works really bad, not only this bug, there are other problems like maximize, close and minimize button doesn't work, but seems nobody interested in this gnome-panel desktop anymore... I can't move to 13.04 in a working environment...

On Wed, May 15, 2013 at 12:23 PM, Petro wrote:
> Sooo, is no one going to fix this? I mean if it is too much work for
> Canonical to support the software in their own repo, maybe they should
> not be putting that software in.

gnome-panel is in universe and not main, so AFAIK it's not officially
supported by Canonical and it's up to the community to develop fixes
and propose them for inclusion.

On Wed, May 15, 2013 at 1:55 PM, Felix Moreno wrote:
> gnome-panel in ubuntu 13.04 works really bad, not only this bug, there
> are other problems like maximize, close and minimize button doesn't
> work, but seems nobody interested in this gnome-panel desktop anymore...
> I can't move to 13.04 in a working environment...

I guess you're talking about bug #1158161 or maybe bug #1158267, but I
don't really see the connection as those are bugs in Compiz and not
gnome-panel, and at least bug #1158161 happens in Unity as well...

Petro (petrochemicals) wrote :

"gnome-panel is in universe and not main, so AFAIK it's not officially
supported by Canonical and it's up to the community to develop fixes
and propose them for inclusion."

First, why is Canonical letting non tested software into IT'S repos? Second, like I said, if Canonical can not support the software in it's repos, it should not be in there. Frankly I am tired of using buggy or broken software because Canonical is unable to handle the workload they took on to make this OS. No one care if it comes from "universe" or someones ass, all they want is for it to work. There is too much broken software in Ubuntu's repos.

Dmitry Shachnev (mitya57) wrote :

All bugs mentioned here are affecting only Compiz session. If you use Metacity (aka "no effects") session, everything works well.

The GNOME Panel is mostly unmaintained upstream, though there is a group of enthusiasts willing to support it. See https://live.gnome.org/GnomeFlashback for details.

Rafael Medina (rafael-medina) wrote :

Ubuntu 13.10 is still affected.

Package:

gnome-session-fallback:
Installed: 1:3.6.2-0ubuntu11
Candidate: 1:3.6.2-0ubuntu11
Version table:
*** 1:3.6.2-0ubuntu11 0
500 http://archive.ubuntu.com/ubuntu/ saucy/universe amd64 Packages
100 /var/lib/dpkg/status

Maybe its Related to New Bug 1196177

Joost Hink (johink-quicknet) wrote :

Logging in with Gnome-fallback (no-effects!!) there is a space between Applications and Places.

In the recovery console I tried to reset settings to their defaults by going to the Recovery Console [CTRL-ALT-F1] command: 'gconftool-2 --recuresive-unset /apps/compiz-1' for Compiz and
command 'rm -rf .gnome .gnome2 .gconf .gconfd .metacity' for Gnome.
But no difference: still in 'no-effects' a space where it should be in the top panel and also new windows (when opening a new application/program) are appearing below the top panel and not with the top hidden underneath the top panel.

Back to Gnome-Fallback Standard [compiz] and there's no space between applications and places and windows of newly started programs annoyingly open with their top, and there their menu bar, hidden underneath the top panel.

affects: gnome-panel (Ubuntu) → ubuntu-themes (Ubuntu)
Changed in ubuntu-themes (Ubuntu):
importance: Undecided → Low
status: Confirmed → In Progress
Changed in compiz (Ubuntu):
importance: Undecided → Low
affects: compiz (Ubuntu) → ubuntu-themes
Changed in ubuntu-themes:
status: Confirmed → In Progress
Dmitry Shachnev (mitya57) wrote :

The linked branch fixes this bug, subscribed sponsors so that some core-dev can mark it as approved.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntu-themes - 13.04+13.10.20130802-0ubuntu1

---------------
ubuntu-themes (13.04+13.10.20130802-0ubuntu1) saucy; urgency=low

  [ James Schriver / Exalm ]
  * Fix regression, bring back dark toolbars in Gtk+3 apps. (LP: #1118838)
  * Apply dark toolbar fixes for Evince.

  [ Alberts Muktupavels ]
  * Restore padding between texts 'Applications' and 'Places' in
    gnome-panel, currently there is no space running
    gnome-session-fashback. (LP: #1154814)

  [ Nick Dedekind ]
  * Add missing battery icon links to ubuntu-mobile theme, needed for
    indicator-power.

  [ Ubuntu daily release ]
  * Automatic snapshot from revision 302
 -- Ubuntu daily release <email address hidden> Fri, 02 Aug 2013 00:02:43 +0000

Changed in ubuntu-themes (Ubuntu):
status: In Progress → Fix Released
Changed in ubuntu-themes:
status: In Progress → Fix Released
Felix Moreno (info-justdust) wrote :

How can I apply this fix? is not in the updates of ubuntu n still i have the same problems...

Fix currently is available only in 13.10... I have submitted fix for raring (13.04) too, but no one has approved it.

1) Open this [/usr/share/themes/Ambiance/gtk-3.0/apps/gnome-panel.css] file for editing:
sudo nano /usr/share/themes/Ambiance/gtk-3.0/apps/gnome-panel.css

2) Delete 9. line and save file:
padding: 0;

3) Restart gnome-panel or logout and login ar restart pc.

3 step solution by Alberts Muktupāvels (albertsmuktupavels) wrote on 2013-09-05: fixed my menu problem in Ubuntu 13.04.

Changed in ubuntu-themes (Ubuntu Raring):
status: New → Confirmed
importance: Undecided → Low
PS Jenkins bot (ps-jenkins) wrote :

Fix committed into lp:ubuntu-themes/raring at revision 286, scheduled for release in ubuntu-themes, milestone Unknown

Changed in ubuntu-themes:
status: Fix Released → Fix Committed
Felix Moreno (info-justdust) wrote :

The 3 steps sollution is not a sollution, it not fix the space between icons, it makes a space between everithing, between apps and places and also between every icon in the bar... is not like it was it fixs the space between apps and places but it introduce a new bug of space between icons in the top bar...

Changed in ubuntu-themes (Ubuntu Raring):
status: Confirmed → Fix Committed
Dmitry Shachnev (mitya57) wrote :

Status should not be Fix Committed until the package is accepted to -proposed.

Changed in ubuntu-themes (Ubuntu Raring):
status: Fix Committed → In Progress

Attached screenshot to compare gnome-panel before and after fix. This is on saucy. Do you get other results?

Top panel definetly looks better. In bottom panel show desktop icon looks better too.

pcworld (pcworld) wrote :

The patch e.g. breaks spacing between application launchers put in the top panel (what's happened to absolute positioning anyway?).

Changed in ubuntu-themes:
status: Fix Committed → Fix Released
Changed in ubuntu-themes (Ubuntu Raring):
status: In Progress → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers