columns width redrawn by multiple events

Bug #1018718 reported by dino99 on 2012-06-28
134
This bug affects 27 people
Affects Status Importance Assigned to Milestone
Nautilus
Fix Released
Undecided
Unassigned
One Hundred Papercuts
Low
Unassigned
ubuntu-themes (Ubuntu)
Low
Lars Karlitski
unico (Ubuntu)
Low
Unassigned

Bug Description

Quantal i386 logged as gnome-classic

when nautilus is opened, then the columns width is disturbed & redrawn if events like:
- mouse click somewhere inside nautilus
- opening a terminal
- loading an other app like browser etc
- nautilus window where the contents are larger than window, then it's seen simply with focus on/off/on, ect

other users also have seen this issue: http://ubuntuforums.org/showpost.php?p=12058978&postcount=6

Compiz* has been purged but seems not related , and Ambiance theme is used on my side, but seems also not related with this problem.

ProblemType: Bug
DistroRelease: Ubuntu 12.10
Package: nautilus 1:3.5.2-0ubuntu3
ProcVersionSignature: Ubuntu 3.5.0-2.2-generic 3.5.0-rc4
Uname: Linux 3.5.0-2-generic i686
NonfreeKernelModules: nvidia
ApportVersion: 2.2.5-0ubuntu1
Architecture: i386
Date: Thu Jun 28 08:19:41 2012
SourcePackage: nautilus
UpgradeStatus: No upgrade log present (probably fresh install)

Related branches

dino99 (9d9) wrote :
description: updated
Changed in nautilus (Ubuntu):
importance: Undecided → Low
Sebastien Bacher (seb128) wrote :

Thank you for your bug report, the description is not really to understand though ... could you do a small screencast showing the bug?

philinux (philcb) wrote :

Here's a link to the thread and a video of this in ubuntuforums.org.

http://ubuntuforums.org/showpost.php?p=12058978&postcount=6

Same thing happens on 64 bit.

Focusing on Firefox then nautilus causes same behaviour of redrawing nautilus columns etc.

Changed in nautilus (Ubuntu):
status: New → Confirmed
dino99 (9d9) wrote :

hi Sebastien

the ubuntuforum link posted at the beginning of this report already have a video showing this problem, click on it

http://ubuntuforums.org/attachment.php?attachmentid=220357&d=1340838687

Sebastien Bacher (seb128) wrote :

that link displays a "You are not logged in or you do not have permission to access this page. This could be due to one of several reasons:", I'm not interested to create an account on forum to see what the bug is about, is anyone wanting to add the video to the bug?

philinux (philcb) wrote :

Here's the vid.

dino99 (9d9) wrote :

nautilus 3.5.3 installed but still the same issue

Sebastien Bacher (seb128) wrote :

Did that start recently?

dino99 (9d9) wrote :

started 3 days back i think

tags: added: amd64
dino99 (9d9) wrote :

i also get nautilus crashing on logout, but i cant report because of this error:

slice indices must be integers or None or have an __index__ method

I have posted a video on YouTube showing this bug before finding this bug reports (thanks Dino99!)
http://www.youtube.com/watch?v=MxB5TsqbojM
I'm experiencing this on Nautilus 3.5.90 in Quantal up-to-date (Aug. 24th, 2012).

I think I can provide some additional info.

1) I do not see the bug when I use a New instance of Nautilus to browse a new, empty directory:
sudo killall -s KILL nautilus
cd $HOME
mkdir nautilus-test
cd nautilus-test
xdg-open .

2) I do not see the bug if I create files in this new directory
sudo killall -s KILL nautilus
cd $HOME/nautilus-test
//Create some example files
touch test1
ls /usr/bin | tee -a ls-output.txt
cp /usr/bin/ld ld.bin
xdg-open .

3) Resizing the columns does not work: They return to the previous width. As far as I can see, they behave like this:
- "Size", "Type", "Modified", "Group", "Location", "Mime Type", "Owner", "Permissions" are set to have as small width as possible.
- "Name" takes the entire remaining width.
- This widths are refreshed every time you click Nautilus window.

4) As a consequence, one can maximize/minimize the symptoms of this bug by changing the order of (and/or adding/removing) columns (at "Gear Icon", Preferences, List-Columns). If "Name" is the last to the right, for example, the effect is minimized.

dino99 (9d9) wrote :

Wonder if its related, but now get this logged:

(nautilus:2828): Gtk-CRITICAL **: /build/buildd/gtk+3.0-3.5.12/./gtk/gtktreeview.c:5302 (gtk_tree_view_bin_draw): assertion `has_child' failed.
There is a disparity between the internal view of the GtkTreeView,
and the GtkTreeModel. This generally means that the model has changed
without letting the view know. Any display from now on is likely to
be incorrect.

Curiously enough I noticed System Monitor does the same, columns shrink and expand by themselves every time window is clicked or moved 8-P

By the way, another thing I noticed is that it stops doing this after adjusting the width of columns manually. But after closing the instance and opening another one the bug presents itself again...

Anyone know a workaround fix for this? It's driving me crazy.

dino99 (9d9) on 2013-04-26
tags: added: raring saucy
Adam Dingle (adam-yorba) wrote :

I see this too with Nautilus 3.6.3 in Saucy. I can reliably reproduce this bug like this:

1. Start Nautilus.
2. Go to the /etc folder in list view. On a typical machine this directory will have a few hundred files.
3. Make sure you're displaying the default set of columns (Name, Size, Type, Modified).
4. Now move the window, or resize it, or right click on any file to open a context menu. The columns will jump around.

I originally filed this upstream at https://bugzilla.gnome.org/show_bug.cgi?id=698970, but then I realized I could reproduce this only in Ambiance, not Adwaita. So I believe this problem is theme-related.

dino99 (9d9) wrote :

hi Adam,

i still have that issue with nautilus 3.9.0 with the Ambiance theme.

Stuart Gillies (gillies) wrote :

This is a real nusiance on my 12.10 64 bit plain vanilla instalation. It seems to set the filename column to accommodate the longest name (undesirable) and then the columns leap about when you click out of the window, or back in. It may be of 'low' importance according to the techies but it is a major cosmetic snafu when compared with other systems where the user experience matters.

I'm using Adwaita.

Why not simply leave the column widths the way the user sets them?

Changed in ubuntu-themes (Ubuntu):
status: New → Confirmed

Since this bug is confirmed for the default GNOME 3 theme, it's invalid for the 'ubuntu-themes' package.

Changed in ubuntu-themes (Ubuntu):
importance: Undecided → Low
Changed in nautilus (Ubuntu):
status: Confirmed → Invalid
status: Invalid → Confirmed
Changed in ubuntu-themes (Ubuntu):
status: Confirmed → Invalid

This bug needs to be forwarded upstream (https://wiki.ubuntu.com/Bugs/HowToTriage#Forwarding_upstream).

Aibara Iduas (aibaraiduas) wrote :

Why should it be forwarded upstream (which it already was, see comment #18)? I just tested it again, and this is a problem that affects the default Ambiance theme (in 13.04 and still present in 13.10) but *not* other themes like Adwaita.

Aibara, it seems that I misunderstood comment 20 where Stuart says 'I'm using Adwaita.'.

Stuart, if you're experiencing this bug in Adwaita mark this report with a status of:

- 'Confirmed' for the 'nautilus (Ubuntu)' package.
- 'Invalid' for the 'ubuntu-themes (Ubuntu)' package.

Thank you.

Changed in nautilus (Ubuntu):
status: Confirmed → Triaged
Changed in ubuntu-themes (Ubuntu):
status: Invalid → Triaged
Changed in hundredpapercuts:
assignee: nobody → Paper Cuts Ninja (papercuts-ninja)
status: New → Confirmed
Aibara Iduas (aibaraiduas) wrote :

Ah, I see Alberto.

I've narrowed down the problem down to two lines in the Ambiance theme. If lines 66 and 68 in /usr/share/themes/Ambiance/gtk-3.0/gtk-widgets.css are deleted, the columns are perfectly stable. The two lines are:

-unico-focus-border-color: alpha (@selected_bg_color, 0.5);
-unico-focus-fill-color: alpha (@selected_bg_color, 0.1);

But that has a nasty side effect, namely an ugly pink color that appears when selecting tabs and files in list view. No clue if this is just a problem with Ambiance and Radiance or the Unico theme engine. I really don't know much about themes (got this through trial and error).

affects: unico → unico (Ubuntu)
Changed in unico (Ubuntu):
status: New → Confirmed
Changed in unico (Ubuntu):
status: New → Confirmed
Changed in unico (Ubuntu):
status: Confirmed → Triaged
affects: unico (Ubuntu) → gtk3-engines-unico (Ubuntu)

Since the package that manages the theme engine is "gtk3-engines-unico", status is:

- "Triaged" for this package.
- "Invalid" for the "Nautilus" package.

Changed in nautilus (Ubuntu):
status: Triaged → Invalid
Changed in gtk3-engines-unico (Ubuntu):
importance: Undecided → Low

Thanks Aibara for that information: it has been of great usefulness.

Andrea Cimitan (cimi) on 2013-11-13
Changed in ubuntu-themes (Ubuntu):
assignee: nobody → Andrea Cimitan (cimi)
Changed in gtk3-engines-unico (Ubuntu):
assignee: nobody → Andrea Cimitan (cimi)
Changed in hundredpapercuts:
status: Confirmed → Triaged
assignee: Papercuts Ninjas (papercuts-ninja) → nobody
importance: Undecided → Low
Changed in gtk3-engines-unico (Ubuntu):
assignee: Andrea Cimitan (cimi) → Lars Uebernickel (larsu)
status: Triaged → Fix Committed
Changed in ubuntu-themes (Ubuntu):
assignee: Andrea Cimitan (cimi) → Lars Uebernickel (larsu)
status: Triaged → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unico - 1.0.3+14.04.20140109-0ubuntu1

---------------
unico (1.0.3+14.04.20140109-0ubuntu1) trusty; urgency=low

  [ Lars Uebernickel ]
  * Use outline attributes for focus to avoid custom attributes Custom
    attributes are deprecated, slow, and are causing problems with gtk
    3.10. Adwaita is using the same hack for some time now [1]. This
    patch is a bit more hacky in that it hard codes the a fill color.
    [1] https://git.gnome.org/browse/gnome-themes-
    standard/commit/?id=6e641cf46cc70ce770482b3fc331b1fa3cd7af2b. (LP:
    #1018718)

  [ Ubuntu daily release ]
  * Automatic snapshot from revision 151
 -- Ubuntu daily release <email address hidden> Thu, 09 Jan 2014 07:10:33 +0000

Changed in unico (Ubuntu):
status: New → Fix Released
Adolfo Jayme (fitojb) on 2014-01-09
no longer affects: gtk3-engines-unico (Ubuntu)
no longer affects: nautilus (Ubuntu)
Changed in hundredpapercuts:
status: Triaged → Fix Released
Lars Karlitski (larsu) on 2014-03-25
Changed in ubuntu-themes (Ubuntu):
status: Fix Committed → Fix Released
Changed in unico (Ubuntu):
importance: Undecided → Low
dino99 (9d9) wrote :

issue not seen since a while; closing it.

Changed in nautilus:
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.