lspci and lshw causing total system freeze

Bug #1729893 reported by Daeld on 2017-11-03
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
ubuntu-terminal-app (Ubuntu)
Undecided
Unassigned

Bug Description

Hi, not sure if this is the best place to file this bug report and I couldn't find any other similar.

System: Dell XPS 15 laptop late 2017, 32GB ram, 1TB SSD, 7th Gen i7 quad-core 8-thread, etc

OS: Fresh install Ubuntu 17.10; dual boot with windows 10 pro on AHCI

Bug: Total system freeze with certain commands
Always reproduced with lspci | grep network (ie I typed it with n instead of N)
also always reproduced with any other use of lspci | grep <any other parameter that is not found>
Often reproduced with lspci | grep Network (correctly spelled)
and occasionally reproduced with just lspci on its own.
when it doesn't freeze the system, it takes it about 2 or 3 seconds to respond (whereas on my old ASUS 8GB ram, dual core quad thread i5 3rd gen it works instantly; same on my ubuntu server running on a crappy headless HP pavillion tower)

Also happens when using lshw, esp with lshw -C <some parameter>.

It does not matter how long the system has been running.

At the same time, it will let me run crunch together with aircrack-ng when pen testing my home lab without any problems even though all 8 threads are maxed out to 100% and I can still use the system as if nothing else is happening. Also, running lspci and lshw on a virtualbox install of Kali 2017.2 will work instantly as expected without any problems.

Any suggestions or request of more info would be welcome.

Thanks

Daeld (daeld-daeldia) on 2017-11-03
description: updated
Daeld (daeld-daeldia) wrote :

addendum
I have just tired it with a Kali 2017.2 live USB (also debian based) and had no problems
I then tried it with an Ubuntu 17.10 live USB and had the problems as described

Daeld (daeld-daeldia) wrote :

addendum
I've just tried booting to a root console and it runs normally there and quite snappy, but after returning to a normal GUI, the terminal app problem persists.

Also trying to open an x.org session freezes the system requiring hard reboot (regardless of NVIDIA being on or off).

17.10 sucks on XPS15 9560 :-(

Daeld (daeld-daeldia) wrote :

and another one
using reboot or shutdown -P now will also cause a total freeze requiring a hard shutdown

I have tried to install from a new and verified copy of ubuntu 17.10 and the same problems exist

Daeld (daeld-daeldia) wrote :

After two further re-installs, I had almost given up on using the terminal for hardware detection. However, today I did an update and for some reason this seems to have fixed the problem there were three packages to update but I didn't pay too much attention because they didn't seem to be related to my issue.

Anyway, all seems to be working well for now.

Daeld (daeld-daeldia) wrote :

I'm not sure what fixed it but the recent update seems to have done the job. Whether it was a software conflict, I'm not sure, but as I seem to have been the only one affected I'll mark it as fixed.

Changed in ubuntu-terminal-app (Ubuntu):
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers