Don't depend on system-image-dbus for the desktop

Bug #1612263 reported by Ken VanDine
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
ubuntu-system-settings (Ubuntu)
High
Ken VanDine

Bug Description

There are plans to seed unity8-desktop-session which needs system-settings. We really don't want or need system-image-dbus on the desktop. We need to drop the depends to a suggests.

To do this we need to:
 * Make system-updates and reset panels dynamically visible, based on the presence of s-i-d
 * Hide the sections of the about panel that needs s-i-d

Related branches

Changed in ubuntu-system-settings (Ubuntu):
importance: Undecided → High
Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in ubuntu-system-settings (Ubuntu):
status: New → Confirmed
Changed in ubuntu-system-settings (Ubuntu):
assignee: nobody → Ken VanDine (ken-vandine)
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntu-system-settings - 0.4+16.10.20160913-0ubuntu1

---------------
ubuntu-system-settings (0.4+16.10.20160913-0ubuntu1) yakkety; urgency=medium

  * Only display the software section and the check for updates button
    if we know the current build (LP: #1612263)
  * cellular, phone, hotspot: Don't default to visible
  * Updated depends to match renaming of qml-module-ofono (LP: #1342031)
  * Handle rename of qtquick-layouts build depends
  * Dropped aethercast to a suggests

 -- Ken VanDine <email address hidden> Tue, 13 Sep 2016 14:29:15 +0000

Changed in ubuntu-system-settings (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers