AltGr not working on external keyboards

Bug #1565236 reported by Sergi Quiles Pérez on 2016-04-02
232
This bug affects 45 people
Affects Status Importance Assigned to Milestone
Canonical System Image
High
Stephen M. Webb
Mir
Fix Released
High
Andreas Pokorny
mir (Ubuntu)
High
Unassigned
ubuntu-system-settings (Ubuntu)
Undecided
Unassigned
unity8 (Ubuntu)
High
Michael Zanetti

Bug Description

Using my keyboard with Spanish layout:

 - PC: Everything works perfect.
 - Ubuntu Touch: I can't write accented characters (dead acute, áéíóú).

Extra info:

- Keyboard: https://goo.gl/photos/xZUE8kRsReW1VKPA6 (http://www.logitech.com/en-hk/product/wireless-touch-keyboard-k400r2)
- Ubuntu Desktop: 12.04
- Ubuntu Touch: bq Aquaris E4.5 15.04 (r305)

Related branches

Jonas G. Drange (jonas-drange) wrote :

Marking this incomplete for System Settings for now—not sure there's anything we can do there. These ALT+GR symbols should work out of the box with the given layout, right?

It might be lower in the stack, so I've marked mir as affected for starters.

Changed in ubuntu-system-settings (Ubuntu):
status: New → Incomplete
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in mir (Ubuntu):
status: New → Confirmed
Changed in canonical-devices-system-image:
status: New → Confirmed
costales (costales) wrote :

Same bluetooth keyboard:
- In PC are working dead_acute
- In phone not.
Thanks in advance!

costales (costales) wrote :

Sorry, Spanish layout and not same keyboard as Sergi. Same keyboard in PC or UT.

Sergi Quiles Pérez (sergiqp) wrote :

I have heard that there is an issue with ALT+GR in mir. I filed the bug here because I didn't know where to file it. Sorry.

I think this bug is critical because in Spanish you can't use a keyboard correctly with the new Ubuntu Tablet.

Thanks.

description: updated
Víctor R. Ruiz (vrruiz) on 2016-04-07
tags: added: touch-l10n
Oliver Grawert (ogra) wrote :

same goes for a german keyboard where AltGr is needed for @ € ~ and | signs ...

summary: - Spanish keyboard layout wrong
+ AltGr not working on external keyboards
Sergi Quiles Pérez (sergiqp) wrote :

AltGr doesn't work but dead accent neither.

Tomas Öqvist (tomoqv) wrote :

Which apps have you tried on Ubuntu Touch? I had the same issue with accented characters (Å,Ä,Ö etc.) on a Swedish keyboard layout with my Nexus 4 running rc-proposed pocket desktop. Turned out keyboard didn't work in Gedit, LibreOffice, Firefox etc., but worked fine in the regular UT applications.

Sergi Quiles Pérez (sergiqp) wrote :

In my case it doesn't work in any application. I've tried Telegram, Browser, Edit at least.

Dead accute (áéíóú) is not working in my keyboard with Ubuntu Touch:

This is my keyboard:
http://es.aliexpress.com/store/product/Aluminum-Wireless-KEYBOARD-Bluetooth-3-0-for-Apple-IOS-Android-Windows-PC-Lithum-battery/833175_32633606243.html

It's working rigth in Ubuntu Desktop & Windows 7 with Spanish layout
or with Ubuntu Touch in English layout.

It's not working in any app for me either.

description: updated
description: updated
tags: added: input
3524 (esra) wrote :

in case it matters to find the solution:
if i am ubuntu touch shell and i press "alt gr" + "[0-9]" it writes out "(arg: [0-9])", on all keyboard layouts i tried (all related to switzerland and english).
example: pressing "alt gr" + "1" results in "(arg: 1)"

Stephen M. Webb (bregma) on 2016-04-26
Changed in mir:
importance: Undecided → Medium
status: New → Confirmed
Changed in mir (Ubuntu):
importance: Undecided → Medium

I'm experiencing the same problem with Aquarius M10, OTA-10.1. Tried with two different keyboards.
Remedy seems to hit left Alt, then right Alt+Gr and the letter I wanted \ - for example.

Keyboards tested, Apple Bluetooth keyboard and Microsoft Wegde Mobile.

Sergi Quiles Pérez (sergiqp) wrote :

@timo-leppiniemi-d I have reproduced what you say in Telegram app (except for | ) but I can't reproduce it in Navigator to write this comment. I have had to disconnect the keyboard for using the OSK to write the symbol @. I think it could be a good clue.

Changed in mir:
importance: Medium → High
Changed in mir (Ubuntu):
importance: Medium → High
Stephen M. Webb (bregma) on 2016-04-28
Changed in mir:
assignee: nobody → Andreas Pokorny (andreas-pokorny)
Oliver Grawert (ogra) wrote :

i created http://paste.ubuntu.com/16187883/ that at least gives you the AltGr keys in the terminal app (on a german kbd, other langs might have different needs indeed).

save it as /home/phablet/.config/com.ubuntu.terminal/Layouts/AltGrKeys.json on your device and you will have the keys in terminals "extra keys" selection.

I can confirm this also for my Aquarius M10. Furthermore, the workaround desrcibed in the duplicate bug (pressing shift before pressing AltGr ) does not work in the terminal.
When I'm in the browser or other programs pressing shift before AltGr, then releasing shift before pressing the modified button works a charm, however in the terminal it doesn't.
I found that in using vim (vi should be the same) if I try to make a [ it will show up shortly before being deleted, If I try to make a { the { functionality of vim gets invoked, this means that there is an escape character before the wanted character.
Also in the web browser, inputting anything with AltGr works for the address line (line edit?) but doesn't for the comment on this page ( text edit? ).
Hope this helps

Just another quick test
It seems when I use xinput (through gvim, the only way I can run commands in libertine) The AltGr key registers as a normal alt key and doesn't get released for some reason.
Will post again when I have done a QML test

Confirmed for my BT keyboard with German layout (manufacturer: CSL).

In *some* applications, the AltGr-Symbols can be accessed via the "leftAlt-AltGr-key"-combination Timo describes in comment #12 (must be pressed in that order). But this varies from app to app.
In most situations, there is no way of typing the "@" character, which is particularly annoying.

None of the AltGr-characters work in the terminal app (though it sometimes shows undefined characters in response). I confirm the behaviour user 3524 describes in #11 ("(arg: [0-9])" prompt.)

This is on a MEIZU MX4 with OTA 10.1.

Reinaldo Cabanita (rcabanita) wrote :

I have an external keyboard, portuguese layout, and I can't type the accented characters ( as if the dead keys have been supressed)linked to an Aquaris M10 Ubuntu Edition. The characters linked to AltGr (@, £, €) are not typed also. The same keyboard works fine with an Android tablet.

Those input scenarios work when unity8 is not used as mirserver.

The right alt scan code does not reach the client. Unity8 seems to filter out the key press. In some occasions it seems to be sent at a later timer. Long holding of right alt and then pressing sometimes help.

Changed in mir:
status: Confirmed → Invalid
Changed in mir (Ubuntu):
status: Confirmed → Invalid

Ok there is actually another problem here, the modifier information provided to unity8 from usc indicates that alt is pressed even though the currently consuming client interprets the scan code of right alt as level 3 shift... So still a mir change is required.

Changed in mir:
status: Invalid → In Progress
Changed in mir (Ubuntu):
status: Invalid → Confirmed
Changed in mir:
milestone: none → 0.24.0
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in unity8 (Ubuntu):
status: New → Confirmed
kevin gunn (kgunn72) on 2016-05-20
Changed in canonical-devices-system-image:
assignee: nobody → Stephen M. Webb (bregma)
milestone: none → 12
importance: Undecided → High
Changed in mir:
milestone: 0.24.0 → 0.23.1
milestone: 0.23.1 → 0.24.0
Sitarane (sitarane) wrote :

BQ m10 + Anker ultra slim mini keyboard.

Same as everyone: Alt-Gr not modifying keys. Renders keyboard useless in German and or French layout. Can't type a "at" sign = Can't log in to most web services. This makes the "convergence" idea completely useless to anyone that types in a non-ascii language (everyone minus single language anglophones).

The Left-alt + Alg-Gr + Key works in some cases, some not.

Dead keys not working either.

Another thing I have noticed: My keyboard had a german layout. I set the layout in the settings, and when I type "qwertz", in any unity8/mir app, I get "qwertz" as expected. But in xmir apps, such as firefox and gedit, typing "qwertz" gives me "qwerty". I.E. the german keyboard layout seems to be set only for mir apps, i haven't found a way to set the keyboard layout for xmir apps.

Sergi Quiles Pérez (sergiqp) wrote :

Dead acute (áéíóú) already works in Mir.

ALT+GR is still not working.

Sergi Quiles Pérez (sergiqp) wrote :

Forgot to say comment #23 is referred to OTA 11.

Changed in unity8 (Ubuntu):
status: Confirmed → In Progress
assignee: nobody → Michael Zanetti (mzanetti)
Michael Zanetti (mzanetti) wrote :

So there are two things why this happened:

a) Currently, in unity8 Alt and Alt+Gr are the same. There is a change in Mir coming up which allows unity8 to fix that. That's still to be done.

b) Unity8 has some workaround for delaying the alt presses in case they'd be consumed by the shell (Alt+Tab). The linked branch changes that behavior to actually forward Alt but then cancels it again for the app in case unity8 consumes it. That happens to fix this bug, still a) needs to be fixed too.

Changed in unity8 (Ubuntu):
importance: Undecided → High
Changed in ubuntu-system-settings (Ubuntu):
status: Incomplete → Invalid
Changed in canonical-devices-system-image:
status: Confirmed → In Progress
XaRz (perecastanyer) wrote :

Same here:
No accentuation in Spanish catalan layout with ubuntu touch OTA-11 in a Aquaris m10 tablet.

Here I'm using a Rii ultra-slim bluetooth 3.0 keyboard.

regards.

Sergi Quiles Pérez (sergiqp) wrote :

@perecastanyer Try in Firefox as described in comment #23

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity8 - 8.12+16.10.20160617-0ubuntu1

---------------
unity8 (8.12+16.10.20160617-0ubuntu1) yakkety; urgency=medium

  [ Michael Terry ]
  * Do not create Label/Icon if we don't need it
  * Fix Z-ordering of prompt surfaces (LP: #1586219)
  * Drop bottom edge tutorials completely and small fixes for other
    edges. (LP: #1565103)
  * Redo visuals for greeter prompt box. (LP: #1435923)
  * Make tutorial qmltests more robust. (LP: #1590810)
  * Stop showing an extra lockscreen in desktop unity8 sessions. (LP:
    #1582987)

  [ Albert Astals Cid ]
  * Improve dash plugin mock
  * Stabilize PreviewExpandableTest::test_all_widgets_height
  * Workaround QTBUG-53460
  * Split artShape code for cardTool card and regular card
  * Simplify the code since fixedArtSize code is mandatory for regular
    cards
  * Desktop stage: Support rotatesWindowContents (LP: #1547481)
  * Turn if if else into if elseif else
  * Fix leaks in QInputDeviceManagerPrivate::addDevice
  * Do not call |= on uninitialized sigterm.sa_flags
  * initialize udevMonitor
  * Make notifier and notifierFd function local variables
  * Fix crash if a component that is not an Item is given to
    sectionDelegate
  * Tests: Do not use dynamic_cast if we're not going to test it anyway
  * Minor coverity fixes
  * Fix warning about anchors.fill in ProportionalShape (LP: #1590963)
  * Make wait in cleanup() wait for snapTo animation to have finished

  [ Alexandros Frantzis ]
  * Improve the way notifications interact with power management (LP:
    #1570922)

  [ Andrea Cimitan ]
  * Correctly refresh cardcreator cache on artshapestyle changes (LP:
    #1588335)
  * Same tweaks we have for click scope now for libertine
  * add a timer to pull to refresh to work on small windows (LP:
    #1589060)

  [ Daniel d'Andrada ]
  * Clean up debug leftovers
  * Ensure mouse and window movement are pixel-aligned (LP: #1510382)
  * Fix SpreadDelegate rotation animations
  * No point in version-controlling files that are automatically
    generated
  * Center cursor on screen when it's first shown
  * Custom cursor name just have to start with "custom"
  * Work around AnimatedSprite infinite loop bug (LP: #1588929)

  [ Josh Arenson ]
  * Disable showDash when it is already shown. (LP: #1506708)
  * Add a timestamp to the dash log (LP: #1580074)
  * Add timestamp to unity8 log (LP: #1498169)

  [ Lukáš Tinkl ]
  * Implement keyboard shortcuts info panel
  * Implement window controls overlay activatable with 3 fingers tap
    (LP: #1489020)
  * Select correct Chinese input method for OSK in the wizard (LP:
    #1588633)

  [ Michael Zanetti ]
  * Add support for the launcher surface pips displaying the correct
    number of surfaces
  * Add support for the persistent alert state. (LP: #1575147, #1584348,
    #1586621)
  * send a Alt-release event on alt+tab instead of delaying it
    completely and invoking it later (LP: #1565236)

  [ Stephen M. Webb ]
  * added a new upstart $SESSION for unity8-desktop-session (LP:
    #1376715)

 -- Michael Terry <email address hidden> Fri, 17 Jun 2016 01:22:57 +0000

Changed in unity8 (Ubuntu):
status: In Progress → Fix Released
Michał Sawicz (saviq) on 2016-06-18
Changed in canonical-devices-system-image:
status: In Progress → Fix Committed
Kevin DuBois (kdub) on 2016-07-05
no longer affects: mir/0.23
Einar Mostad (einarmostad) wrote :

Same her on a Norwegian layout with M10 on OTA 11.

JyotiGomes (jyotigomes) wrote :

there is not Portuguese layout

2016-05-20 4:19 GMT+01:00 kevin gunn <email address hidden>:

> ** Changed in: canonical-devices-system-image
> Assignee: (unassigned) => Stephen M. Webb (bregma)
>
> ** Changed in: canonical-devices-system-image
> Milestone: None => 12
>
> ** Changed in: canonical-devices-system-image
> Importance: Undecided => High
>
> --
> You received this bug notification because you are subscribed to a
> duplicate bug report (1576161).
> https://bugs.launchpad.net/bugs/1565236
>
> Title:
> AltGr not working on external keyboards
>
> Status in Canonical System Image:
> Confirmed
> Status in Mir:
> In Progress
> Status in Mir 0.23 series:
> Triaged
> Status in mir package in Ubuntu:
> Confirmed
> Status in ubuntu-system-settings package in Ubuntu:
> Incomplete
> Status in unity8 package in Ubuntu:
> Confirmed
>
> Bug description:
> Using my keyboard with Spanish layout:
>
> - PC: Everything works perfect.
> - Ubuntu Touch: I can't write accented characters (dead acute, áéíóú).
>
> Extra info:
>
> - Keyboard: https://goo.gl/photos/xZUE8kRsReW1VKPA6 (
> http://www.logitech.com/en-hk/product/wireless-touch-keyboard-k400r2)
> - Ubuntu Desktop: 12.04
> - Ubuntu Touch: bq Aquaris E4.5 15.04 (r305)
>
> To manage notifications about this bug go to:
>
> https://bugs.launchpad.net/canonical-devices-system-image/+bug/1565236/+subscriptions
>

JyotiGomes (jyotigomes) wrote :

AltGr not working on external keyboards. There is not Portuguese layout
with '`^~ etc

2016-05-20 4:19 GMT+01:00 kevin gunn <email address hidden>:

> ** Changed in: canonical-devices-system-image
> Assignee: (unassigned) => Stephen M. Webb (bregma)
>
> ** Changed in: canonical-devices-system-image
> Milestone: None => 12
>
> ** Changed in: canonical-devices-system-image
> Importance: Undecided => High
>
> --
> You received this bug notification because you are subscribed to a
> duplicate bug report (1576161).
> https://bugs.launchpad.net/bugs/1565236
>
> Title:
> AltGr not working on external keyboards
>
> Status in Canonical System Image:
> Confirmed
> Status in Mir:
> In Progress
> Status in Mir 0.23 series:
> Triaged
> Status in mir package in Ubuntu:
> Confirmed
> Status in ubuntu-system-settings package in Ubuntu:
> Incomplete
> Status in unity8 package in Ubuntu:
> Confirmed
>
> Bug description:
> Using my keyboard with Spanish layout:
>
> - PC: Everything works perfect.
> - Ubuntu Touch: I can't write accented characters (dead acute, áéíóú).
>
> Extra info:
>
> - Keyboard: https://goo.gl/photos/xZUE8kRsReW1VKPA6 (
> http://www.logitech.com/en-hk/product/wireless-touch-keyboard-k400r2)
> - Ubuntu Desktop: 12.04
> - Ubuntu Touch: bq Aquaris E4.5 15.04 (r305)
>
> To manage notifications about this bug go to:
>
> https://bugs.launchpad.net/canonical-devices-system-image/+bug/1565236/+subscriptions
>

Changed in mir:
milestone: 0.24.0 → 0.25.0
milestone: 0.25.0 → 0.24.0
Daniel van Vugt (vanvugt) wrote :

Hasn't this bug missed 0.24 already or are we blocking 0.24 for this bug?

Kevin DuBois (kdub) on 2016-07-20
Changed in mir:
status: In Progress → Fix Committed
Changed in canonical-devices-system-image:
status: Fix Committed → Fix Released
Sergi Quiles Pérez (sergiqp) wrote :

AltGr does work now. Thnaks!.

But accented characters (as described in this bug report) are not working yet. Should I file a new bug?

Daniel van Vugt (vanvugt) wrote :

Yes, please log a new bug if it's still broken in OTA-12 for you...
https://bugs.launchpad.net/ubuntu/+source/unity8/+filebug

Sergi Quiles Pérez (sergiqp) wrote :
JyotiGomes (jyotigomes) wrote :

Unbelievable!!! After all this time, still not PORTUGUESE for external keyboards!!!

I am a Ubuntu supporter and was one of the first to buy the Ubuntu BQ M10 tablet. We, the Portuguese speaking supporters were surprised that was not possible to write in PORTUGUESE with the EXTERNAL KEYBOARD. We were assured that this issue would be resolved soon. But… it's been months and several OTAs and we still can not write Ã, Á, À, etc…This problem makes it impossible at all to use the tablet that we bought in desktop mode.

Me, and all the people in Portugal who bought the Ubuntu tablet are very tired of all this situation, we are on the edge. Many of us are thinking about returning the tablet due to this fatal problem that has never been solved, despite promises. Canonical is not interested in the Portuguese users, this is the conclusion for many of us...

Michael Zanetti (mzanetti) wrote :

@Jyoti: There are 13 (!) Portuguese variants for external keyboard layouts. I have just tried typing è and é etc. It works for me in classic apps (Libreoffice, firefox etc) but you're right that there seems to be a problem with native applications.

Where did you report the bug for that?

Michael Zanetti (mzanetti) wrote :

Here's a screenshot with portuguese layout selected and typed some dead accute characters.

LlamasJM (llamasfortesjm) wrote :

Alt-Gr works for me in XApps, but not in normal apps as Uwriter or Telegram. Bq M10 FHD. OTA 12.

JyotiGomes (jyotigomes) wrote :

I am a Ubuntu supporter and was one of the first to buy the Ubuntu BQ M10 tablet. We, the Portuguese speaking supporters were surprised that was not possible to write in PORTUGUESE with the EXTERNAL KEYBOARD. We were assured that this issue would be resolved soon. But… it's been months and several OTAs and we still can not write Â, Ã, Á, À, Õ, etc…This problem makes it impossible at all to use the tablet that we bought in desktop mode.

Me, and all the people in Portugal who bought the Ubuntu tablet are very tired of all this situation, we are on the edge. Many of us are thinking about returning the tablet due to this fatal problem that has never been solved, despite promises. Canonical is not interested in the Portuguese users, this is the conclusion for many of us...

Daniel van Vugt (vanvugt) wrote :

I see no evidence or history of work on this topic in the Mir code. Please clarify if there were any code changes for it in Mir 0.24.0

Changed in mir:
status: Fix Committed → Incomplete
jordibardaji (jordibardaji) wrote :

Hi,

In Spanish is the same bug. In general, this occurs in all not English
languages that need dead keys ALT + other key combination.

I have BQ M10 ubuntu tablet + AQUARIS E4.5 UBUNTU EDITION both with OTA-12.
I'm disappointed with this bug. I expected that after OTA11 it was fixed. I
agree with Jyoti, this bug do unusable the phone or the tablet in ours
languages. We can not write e-mails because we can not write the @
character because in our languages this character need a ALTGR + 2
combination!!!

It's disappointing.

And I think that this bug is already reported before.

I apologize for my English.

Jordi Bardají

2016-07-29 3:57 GMT+02:00 Daniel van Vugt <email address hidden>:

> I see no evidence or history of work on this topic in the Mir code.
> Please clarify if there were any code changes for it in Mir 0.24.0
>
> ** Changed in: mir
> Status: Fix Committed => Incomplete
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1565236
>
> Title:
> AltGr not working on external keyboards
>
> To manage notifications about this bug go to:
>
> https://bugs.launchpad.net/canonical-devices-system-image/+bug/1565236/+subscriptions
>

--
Jordi
http://www.elmarathon.com

Einar Mostad (einarmostad) wrote :

It seems to be only partially fixed also for the Norwegian keyboard layout.

For the Norwegian keyboard layout everything works in the Xapps (both special glyphs like @$£[]... and accented characters like àáêëñ...).

In the Ubuntu touch apps, only special glyphs work, but not accented characters.

Michael Zanetti (mzanetti) wrote :

Guys, accented characters (with dead keys) is a different thing than AltGr.

AltGr should be fixed for everyone now while the accented characters are tracked in this bug:

https://bugs.launchpad.net/ubuntu/+source/unity8/+bug/1607237

jordibardaji (jordibardaji) wrote :

AltGr is not working nor in phone neither tablet OTA12

Do you need a video?

Jordi

El divendres, 29 de juliol de 2016, Michael Zanetti <
<email address hidden>> va escriure:
> Guys, accented characters (with dead keys) is a different thing than
> AltGr.
>
> AltGr should be fixed for everyone now while the accented characters are
> tracked in this bug:
>
> https://bugs.launchpad.net/ubuntu/+source/unity8/+bug/1607237
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1565236
>
> Title:
> AltGr not working on external keyboards
>
> To manage notifications about this bug go to:
>
https://bugs.launchpad.net/canonical-devices-system-image/+bug/1565236/+subscriptions
>

--
Jordi
http://www.elmarathon.com

Sergi Quiles Pérez (sergiqp) wrote :

My original description was more general. Someone changed the summary. Perhaps I had to file two independent bugs from the beginning.

Michael Zanetti (mzanetti) wrote :

@jordibardaji, what layout are you using, what characters are you trying to type?

jordibardaji (jordibardaji) wrote :

@Michael Zanetti

Spanish is the layout I'm using. I live in Spain,

The most important characters I need are those: á é í ó ú à è ò ü ï @

Obviously I'm writing this message from ubuntu 16.04 PC. This is impossible
to write those characters in Tablet M10 ubuntu edition or BQ aquaris E4.5.
Both on OTA-12 with external bluetooth keyboard.

I tried in default navigator: "@" nor á é í ó ú, ..... Its don't work.
Libreoffice has dissapeard when I update to OTA 12 in M10 ubuntu tablet!!!

Thanks for your interest,

Jordi

2016-07-29 17:05 GMT+02:00 Michael Zanetti <email address hidden>:

> @jordibardaji, what layout are you using, what characters are you trying
> to type?
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1565236
>
> Title:
> AltGr not working on external keyboards
>
> To manage notifications about this bug go to:
>
> https://bugs.launchpad.net/canonical-devices-system-image/+bug/1565236/+subscriptions
>

--
Jordi
http://www.elmarathon.com

Michael Zanetti (mzanetti) wrote :

I have just switched my tablet to spanish. @ works fine there. Note that there is a separate issue which affects only the Browser and the Terminal and it is tracked here: https://bugs.launchpad.net/ubuntu/+source/webbrowser-app/+bug/1590515

This issue is already fixed, but sadly did not make it into OTA-12. It will land in rc-proposed soon and be included in OTA-13.

jordibardaji (jordibardaji) wrote :

OK. Thanks a lot!!! @Michael Zanetti.

I hope OTA-13 will be released soon!!

2016-07-29 17:57 GMT+02:00 Michael Zanetti <email address hidden>:

> I have just switched my tablet to spanish. @ works fine there. Note that
> there is a separate issue which affects only the Browser and the
> Terminal and it is tracked here:
> https://bugs.launchpad.net/ubuntu/+source/webbrowser-app/+bug/1590515
>
> This issue is already fixed, but sadly did not make it into OTA-12. It
> will land in rc-proposed soon and be included in OTA-13.
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1565236
>
> Title:
> AltGr not working on external keyboards
>
> To manage notifications about this bug go to:
>
> https://bugs.launchpad.net/canonical-devices-system-image/+bug/1565236/+subscriptions
>

--
Jordi
http://www.elmarathon.com

Sergi Quiles Pérez (sergiqp) wrote :

I have done some tests (spanish layout, catalan language):

- In bq Aquaris E4.5 (OTA 12):
     ALTGR works in most of the native apps except Navigator and Terminal (for me).
     ALTGR doesn't work in webapps.

- In bq Aquaris M10 (OTA 12):
     ALTGR works in most of the native apps except Navigator and Terminal (for me).
     ALTGR doesn't work in webapps.
     ALTGR works in all Xapps. In Firefox it works in the address bar as well in any field inside a web page.

Sergi Quiles Pérez (sergiqp) wrote :

I think ALTGR doesn't work in webapps because of the related bug to the Navigator (bug #1590515), as webapps use it to run their content:

   Navigator:
      ALTGR works in address bar.
      ALTGR doesn't work in the body.

   Webapps:
      ALTGR would work if they had the address bar.
      ALTGR doesn't work in the body (all the webapp).

ALTGR works in both native apps and xapps.

jordibardaji (jordibardaji) wrote :

Thanks to Sergi I have restored Xapps in TAblet and phone. Now, i'm able to
write accents and @ characters in xapps apps.

But it's curious what it's happened in my phone and tablet with OTA-12.
Firefox and Libreoffice had dissapeared.

Thanks a lot,

Jordi

2016-07-30 9:18 GMT+02:00 Sergi Quiles Pérez <email address hidden>:

> I think ALTGR doesn't work in webapps because of the related bug to the
> Navigator (bug #1590515), as webapps use it to run their content:
>
> Navigator:
> ALTGR works in address bar.
> ALTGR doesn't work in the body.
>
> Webapps:
> ALTGR would work if they had the address bar.
> ALTGR doesn't work in the body (all the webapp).
>
> ALTGR works in both native apps and xapps.
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1565236
>
> Title:
> AltGr not working on external keyboards
>
> To manage notifications about this bug go to:
>
> https://bugs.launchpad.net/canonical-devices-system-image/+bug/1565236/+subscriptions
>

--
Jordi
http://www.elmarathon.com

Changed in mir:
status: Incomplete → Fix Committed
Daniel van Vugt (vanvugt) wrote :

Thanks for fixing that Andreas.

As the fix is only in Mir 0.24.0 it is incorrect to say fix released in OTA-12. Mir 0.24 is more likely going to hit OTA-13 or OTA-14 with the fix.

Daniel van Vugt (vanvugt) wrote :

Could someone please reassign this bug to OTA-13 or OTA-14 (depending where Mir 0.24.0 lands)?

Michał Sawicz (saviq) on 2016-08-02
Changed in canonical-devices-system-image:
milestone: 12 → 13
Daniel van Vugt (vanvugt) wrote :

Thanks. That should say 'Fix Committed' instead of 'Fix Released'. And I hear it's reasonably likely Mir 0.24 will miss OTA-13 so this might shift to OTA-14.

There were two related sources that led to the problem. The quick fix in unity8 was already released. The mir series of changes that ended up being part of 0.24 would have avoided the problem too but only as a side effect.

Daniel van Vugt (vanvugt) wrote :

Oh I see sorry.

Sometimes a bug needs all the tasks fixed to be fixed. Sometimes a bug needs only one of its tasks fixed and this is one such case.

So yeah, Fix Relesaed in OTA-12 and the continuing issues should be discussed in bug 1607237.

Launchpad Janitor (janitor) wrote :
Download full text (5.7 KiB)

This bug was fixed in the package mir - 0.24.0+16.10.20160815.3-0ubuntu1

---------------
mir (0.24.0+16.10.20160815.3-0ubuntu1) yakkety; urgency=medium

  * New upstream release 0.24.0 (https://launchpad.net/mir/+milestone/0.24.0)
    - ABI summary:
      . mirclient ABI unchanged at 9
      . mirserver ABI bumped to 41
      . mircommon ABI unchanged at 6
      . mirplatform ABI bumped to 12
      . mirprotobuf ABI unchanged at 3
      . mirplatformgraphics ABI bumped to 10
      . mirclientplatform ABI unchanged at 5
      . mirinputplatform ABI unchanged at 5
    - Enhancements:
      . Added a new tool 'mirvanity' which can use a high speed video camera
        to measure client-to-screen latency.
      . Added (build-time) support for desktop full OpenGL servers (disabled
        by default in favor of GLESv2).
      . Introduced new buffer semantics (NBS) and enabled it by default.
      . Avoided using libmirserver in mir_demo_standalone_render_overlays,
        making bringup traces less cluttered.
      . Removed TilingWindowManager from example servers.
      . Added two new mir_*_performance_test tools that are run as part of
        'mir_performance_tests'.
      . Added pointer confinement to the client API.
      . Added new platform supporting software EGLStreams.
      . Added an input platform that the nested server can use.
      . Allow configuration of the application_not_responding_detector
      . Handle server-side keymapping using XKBMapper.
      . Remove the offscreen display.
      . Add callback option to notify shells that the server is about to stop.
      . Add logging for ANativeWindow events on Android.
    - Bugs fixed:
      . usage of std:call_once in mirclient causes TLS collisions with some
        android devices (LP: #1599867)
      . AltGr not working on external keyboards (LP: #1565236)
      . [regression] unity8 fails to start when built with 0.24 series (lp:mir)
        (LP: #1597717)
      . CI failure in MirSurfaceVisibilityEvent.exposed_received_when_surface_
        raised_over_occluding_surface [called twice - over-saturated and active]
        (LP: #1556045)
      . package-built mir_demo_server does not start on device (LP: #1577357)
      . During surface creation, first stream in spec becomes default stream.
        (LP: #1577967)
      . mouse is getting stuck on a phantom edge (LP: #1580774)
      . [testsfail] in MirSurfaceVisibilityEvent.exposed_received_when_surface_
        raised_over_occluding_surface [never called] (LP: #1581385)
      . [enhancement] Add support for full OpenGL compositing (LP: #1420581)
      . [testsfail] ServerSignal.terminate_handler_is_called_for_SIGINT|SIGTERM
        (LP: #1570353)
      . [testsfail] ClientLatency.triple_buffered_client_has_less_than_two_
        frames_latency (LP: #1576690)
      . [testsfail] NestedServer.when_monitor_plugged_in_client_is_notified_of_
        new_display_configuration (LP: #1576760)
      . mir server crashed in what(): drmModeMoveCursor failed (returned -13)
        (LP: #1579630)
      . mirtest-dev is hard to use as the objects used are compiled with LTO
        (LP: #1583536)
      . [testsfail] ClientLogging.repo...

Read more...

Changed in mir (Ubuntu):
status: Confirmed → Fix Released
Changed in mir:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments