Does not handle failure to respond to reboot request on update install

Bug #1489389 reported by Stuart Langridge on 2015-08-27
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
ubuntu-system-settings (Ubuntu)
Medium
Jonas G. Drange

Bug Description

<aquarius> I've just had OTA-6 arrive on my MX-4; told it "install and restart" and I now have a black screen, spinning Ubuntu logo, flashing "In Progress", and "Restarting...". But the phone can lock, and when I unlock it takes me back to this screen. It's been like it for ten minutes, so I assume that something has gone wrong with the upgrade. What should I do?
<kenvandine> that's still in the system-settings screen
 it means system-image-dbus didn't respond to the reboot request
<kenvandine> aquarius, can you kill settings and try again?
<kenvandine> i've seen that happen once, ages ago
 must be a bug in system-image-dbus
 but when i did it a second time it worked
<aquarius> ok, swiped away the black screen
 back in settings; checking for updates
 aha and there is an update
<aquarius> and installing it seems to have restarted the phone!
 so, fixed.
<kenvandine> maybe we should add some error handling there, if we don't actually reboot after some period of time retry

Related branches

Changed in ubuntu-system-settings (Ubuntu):
assignee: nobody → Ken VanDine (ken-vandine)
Changed in ubuntu-system-settings (Ubuntu):
status: New → In Progress
importance: Undecided → Medium
tags: added: updates
Changed in ubuntu-system-settings (Ubuntu):
assignee: Ken VanDine (ken-vandine) → Jonas G. Drange (jonas-drange)
status: In Progress → Fix Committed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers